Unable to boot from any other OSes

I originally had just Fedora. I am looking for a good user interface and high performance, so I chose openSuSE 12.1 with KDE 4. I installed openSuSE with KDE 4 with no problems, but now whenever I try to boot, it only gives me its failsafe and SuSE. The other partition with Fedora has been checked, and it isn’t corrupt. It is bootable, and a primary, but it still won’t boot! Help!

You have 2 different and unrelated problems.

  • Graphical login doesn’t work as expected. Please post the output of the following command:
hwinfo --gfxcard
su -l
zypper ar [noparse]http://download.opensuse.org/repositories/home:/please_try_again/openSUSE_12.1/[/noparse]  PTA
zypper refresh -r PTA
zypper in updategrub
updategrub -i

An alternate option which openSUSE’s bootloader has is a feature “Propose and Merge with Existing Grub Menus”
It should pull in what was missed during the installation.

  1. Navigate to Yast → System → Boot Loader
  2. On the Boot Loader tab select Other -> “Propose and Merge with Existing Grub Menus”
  3. You should see Fedora appear. However, the name might be slightly altered
  4. Rename everything to your liking
  5. Save your changes and exit

Do 12.1 and previous look in /boot/grub2/grub.cfg, where Fedora’s Grub menu located is? I would be surprising.
Next release uses Grub2 and os-prober, and should detect Fedora, Ubuntu and any other Grub2 based distro.

It searches /boot/grub/menu.lst and /boot/grub2/grub.cfg,

I’m looking forward to the “devs” creating some sort of template from which we can edit the title. At present, I’m using “vim” to edit the /boot/grub2/grub.cfg file.
I think there is a kcm_grub2 module that will appear in “Configure Desktop”.

We still need graphics for the Grub2 menu.

Interesting! Actually, os-prober doesn’t search /boot/grub2 at all but only looks for grub.cfg in Debian location( /boot/grub). I submitted a patch for this bug


The os-prober version in my repo includes this patch (among others). It allows openSUSE to find Fedora as well as itself. Other os-prober versions (from 1.48 to 1.52) only detect Ubuntu, Debian, etc correctly. Well, it’s a little bit more complicated than that (See the bug report).

But 12.1 is not using os-prober yet. It will be installed by default in 12.2 - together with grub2.

You can safely skip this (far out of topic) post, since you’re not dealing with grub2 in openSUSE yet - it will become the default boot manager in the next release.

I find the code written for Grub2 is a lot better.

But getting back to my previous comment about openSUSE 12.1’s Grub1 and the “Propose and Merge” option.

It does bring in other operating systems installed on the computer.

Give it a try.

I did out of curiousity (but I already know in which state the perl boolloader leaves my boot menus when it is run after a kernel update). It would be way out of topic here. If you are interested here’s the result in a new thread: updategrub vs YaST method. Your suggestion wouldn’t have worked here for Fedora (15 and greater ).

You were right, it actually found Fedora (but not Ubuntu or Mint) but it would have destroyed its bootloader if it was installed in MBR (it probably happened to the OP during installation) and this even if you had

  • clicked on “Boot Loader Installation”
  • clicked on “Boot Loader Options”
  • unchecked “Write generic Boot Code to MBR”

You got me, @Romanator. rotfl! This machine had never seen a generic boot code in its life and I’m sure it was a funny experience. But I have a sense of humour and it allowed me to bring into light a bug that I had suspected for a long time: in this situation, YaST does write a generic boot code to MBR even if you instruct it not to do so. See yourself (look at the boot loader in sda MBR):