Unable to boot after upgrading to 13.1 - grub_term_highlight_color not found?

Upgraded my 12.3 (full updated) system to 13.1.

After the reboot I get:

GRUB loading
Welcome to GRUB

error: symbol `grub_terminal_highlight_color’ not found
Entering rescue mode

Any idea how to fix this, and also what caused it? I have a few remote servers that I wouldn’t want to upgrade until I know what happened as if they dont reboot normally I can’t access them to fix.

Update:Seems to be a major bug:


I followed this article to get the server up and running again.


Hopefully it helps someone.

I’ve submitted the info required to bugzilla.

Same bug as op. Cannot get solution work from 2nd poster. grub2 complaints about: no uefi id. Going once more to rescue mode to see if something can be done about it. I also did upgrade via zypper dup.

For people getting the “EFI distributor id isn’t specified message.” try specifying target for grub2-install. It auto tries to put EFI if your system gives such signal.

grub2-install --target=i386-pc /dev/sda

Replace sda device of your own choice. Also folder: /usr/lib/grub2/ seems to have listing of those target options.

I attempted as you stated, thank-you for that tidbit (the /usr/lib/grub2)

however I still receive

# grub2-install --target=x86_64-efi /dev/sda
EFI distributor id isn't specified.

I have verified the contents of that dir:

# pwd
# ls -ltr                                                                                                                                                                                               
total 40                                                                                                                                                                                                                          
drwxr-xr-x 2 root root 20480 Nov 25 11:19 i386-pc                                                                                                                                                                                 
drwxr-xr-x 2 root root 20480 Nov 25 11:20 x86_64-efi

any help would be great as this is very frustrating.

I’ve also get this error after upgrading openSuse 12.3 to 13.1.

error: symbol `grub_terminal_highlight_color' not found
Entering rescue mode 

But I was good practised due to the problems I had before updating openSuse (see also my bug report to the boot-repair tool https://bugs.launchpad.net/boot-repair/+bug/1258805, cause repairing instructions were not completely correct for openSuse installation)

I’ve used my DVD with Linux Mint Nadja and installed the boot-repair tool as described here https://help.ubuntu.com/community/Boot-Repair. With the small exception: the mediaubuntu repository isn’t reachable and I had to remove it from the repositories for the command ‘apt-get update’ to succeed.

After having done the default repairing, the openSuse could be booted as expected.

Unfortunately I haven’t found anything about installing boot-repair under openSuse.

But the steps done by the tool contained full reinstallation of the grub. It was something like this:

>sudo chroot "xxx/" zypper remove -y grub*
>sudo chroot "xxx/" zypper install grub*

And if I remember it correctly, I’ve got some confirmations during the grub installation.

As a proposal for you: possibly it would help, if you perform manual reinstallation of the grub directly after openSuse upgrade without restarting the computer.

For those who interested in the details to my booting problem, here are the reports of the boot-repair tool before http://paste.ubuntu.com/6533796 and after http://paste.ubuntu.com/6534574 openSuse upgrade.

Was it offline or online (zypper dup) update or some other means?

error: symbol `grub_terminal_highlight_color' not found
Entering rescue mode

This means that grub2 files in /boot/grub2 were updated but core bootloader (that is loaded on power on) was not. That sounds like a bug. If you still have logs from update it makes sense to open bug report.

In my case it was an online update.
Sorry for the dummy question, but where to find update logs?

On 2013-12-14 19:36, kostgr wrote:
> Sorry for the dummy question, but where to find update logs?


Cheers / Saludos,

Carlos E. R.
(from 12.3 x86_64 “Dartmouth” at Telcontar)

I have reported a bug here https://bugzilla.novell.com/show_bug.cgi?id=855538

***“EFI distributor id isn’t specified message.” ***

Solution for my ThinkPad Edge E540
Restart with SuperGrubDisk2: Rescatux

  • [Detect any Operating System]
  • Start SuSE
  • mount “Efi System Partition (ESP)” to /boot/efi/
  • install Bootloader with Yast bootloader installation (grub2-efi)
  • Have a lot of fun

I followed the instructions here: http://en.opensuse.org/SDB:System_upgrade and got the same error as OP.

I fixed it by following the instructions here (using my old 12.3 DVD as the rescue media). http://forums.opensuse.org/content.php/128-Re-install-Grub2-from-DVD-Rescue