unable to boot after updating some packages


Since the last packages update, after selecting in GRUB, I have this error:
systemd[1]: sysroot.mount: What= setting is missing. Refusing

sysroot.mount: what=setting is missing.

I cant save /run/initramfs/rdsosreport.txt to USB key
I cant either boot with recovery mode: I still get the same error at boot.

I cant either boot with an alternative kernel: again, I have the same error.

I can only use read-only snapshot to boot.

What can I do to fix such error.

thanks for feedback

Perhaps roll back to the last working snapshot as outlined in comment #33 here:


and try the update again.

Edit: You might want to check your repositories before attempting the update again, just to be sure there’s nothing amiss there.

sudo zypper lr -d

Although that doesn’t address the issue of what went wrong, it may well get your machine up and running again.

Thanks a lot, it solved my issue. Snapshots work really fine on Opensuse.

I was able after to update the packages and the system has worked after.