Unable to assign meta key after Plasma 6.1 update

Hello fellow Suse users,
Before the Plasma 6.1 update, I used to open the Overview with the meta key, using this

kwriteconfig5 --file kwinrc --group ModifierOnlyShortcuts --key Meta "org.kde.kglobalaccel,/component/kwin,,invokeShortcut,Overview"

After the 6.1 update, that no longer works.
I thought being able to assign the meta key by itself was a new feature in 6.1, but I’m not able to make it work at all.

These are the steps I’ve tried so far

  • Un-ckeck “Meta” under the Activate Application Launcher
  • Created a new user account
  • Created a tumbleweed VM

Any ideas?
Thank you!

Is this what you call overview?

If so, try “Meta + w”.
You can find it under: “System configurations → Keyboard → Shortcuts → KWin”.

Thanks for your reply.

This is what I’m referring to. In Plasma 6.1, we are able to assign modifier-only keys to shortcuts.

Previously, I had only tried to add it through the Desktop Effects screen, where it won’t accept the keypress.
Perhaps this is just a lingering bug from the 6.1 update.

I didn’t realize there was a second location to change the shortcut. I just tried it in the kwin shortcuts screen and the keypress was accepted.


All is well in Overview land.
Thank you!

(sorry for the multiple replies. New user rules)

Please, mark as resolved.

1 Like

I did just switch from Fedora 40 KDE spin towards OpenSuse Tumbleweed with KDE.
If I try the overview (like mentioned above through Meta W), the workspaces are shown at the left side of the screen and not on top. Is this also a setting somewhere ?
Thanks in advance,

1 Like

If you change this from 2 rows to 1 row, they will be side to side instead of top to bottom.

1 Like

Thank you very much !
Indeed, this is the solution :wink:

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.