Unable to ADSL Router

I originally had a WRT54G working together with ADSL Router DSL-500T and everything was fine. The wireless router stopped working yesterday and I’m hooking up my computer to the ADSL router directly.

I tried everything but my computer just won’t hook to the ADSL router. I can’t even ping the web address of the ADSL (192.168.1.1). I tried to change to static IP address like what I did with DSL-302G but it didn’t work. If I select dynamic, I get this message when I run:


samson-2:~ # /sbin/ifup eth0
    eth0      device: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 01)
Starting DHCP4 client on eth0. . . . . . . .
    eth0      DHCP4 continues in background

The route -n result is


samson-2:~ # route -n
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
192.168.1.0     0.0.0.0         255.255.255.0   U     0      0        0 eth0
169.254.0.0     0.0.0.0         255.255.0.0     U     0      0        0 eth0
127.0.0.0       0.0.0.0         255.0.0.0       U     0      0        0 lo
0.0.0.0         192.168.1.1     0.0.0.0         UG    0      0        0 eth0

My ifcfg-eth0 file looks like this:


BOOTPROTO='dhcp'
BROADCAST=''
ETHTOOL_OPTIONS=''
IPADDR=''
MTU=''
NAME='RTL8111/8168B PCI Express Gigabit Ethernet controller'
NETMASK='255.255.255.0'
NETWORK=''
REMOTE_IPADDR=''
STARTMODE='auto'
USERCONTROL='no'
DEVICE='eth0'
PREFIXLEN='24'

what do I do wrong?

I just had a look at your ADSL routers manual and it says to use a Straight Through cable (should be supplied) when connecting it to a pc directly. The cable you had going to the Netgear router should be a cross-over cable.

Try and swap the cable for a straight throught cable if this is the problem.

Check the manual here at page 19.

It says:

Use standard twisted-pair cable with RJ-45 connectors. The RJ-45 port on the Router is a crossed port (MDI-X).
Follow standard Ethernet guidelines when deciding what type of cable to use to make this connection. **When
connecting the Router directly to a PC or server use a normal straight-through cable. **You should use a crossed
cable when connecting the Router to a normal (MDI-X) port on a switch or hub. Use a normal straight-through
cable when connecting it to an uplink (MDI-II) port on a hub or switch.

If you know your ethernet works and you can’t connect to a working modem then I would usually query the connections.

Hope this works.

Oh yeah, I was also going to say why not buy a ADSL modem and wireless router in one? They are not that expensive anymore. I don’t know where you live but here in Ireland you can pick up a the excellent Netgear DG834G for as little as 60 euro.

One less device to compicate your connection. Also, with most ISP’s you can get a free wireless modem when you sign up. Maybe change providers for a better package and a free wifi modem.

Hi
When you setup the WR54G did you put the ADSL modem in bridge mode and
use the WRT54G features?

If so, then there should be a reset button to restore the defaults on
the modem, use this and try again.


Cheers Malcolm °¿° (Linux Counter #276890)
SUSE Linux Enterprise Desktop 11 (x86_64) Kernel 2.6.27.29-0.1-default
up 1 day 21:23, 2 users, load average: 0.10, 0.10, 0.09
GPU GeForce 8600 GTS Silent - CUDA Driver Version: 190.18

I am using a crossover cable.

Do you think I might have configured the network wrongly?

I mean I have tried both the crossover and the straight through cable to hook up to the adsl. It doesn’t work. But both cables work fine with Windows box.

I gave up trying to figure out the DSL-500T and was thinking of reinstalling the old OpenSuse 10.0. I bought an all in one DSL-2640t. But, unexpectedly, everything goes back to normal! I configured the new modem/switch from my Linux box.

By the way, reset buttons on both WRT54G and DSL-500T didn’t work. I had to reconfigure the DSL-500T from bridge to PPPoE mode. After this incident, I won’t be getting separate router and modem anymore.

Thanks for everyone’s help!

Glad it worked out for you. 1 device is always simpler than 2 :wink: