Unable to adjust trackpad sensitivity


just installed LEAP 42.2.

as shown in the below screenshot, when I attempt to change my trackpad sensitivity, the slider is greyed out:


The synaptics touchpad on my Acer Aspire V is rather sensitive, here’s the info I could get from the hardware manager:

If you would be so kind as to guide me towards the KB article that shows how I could change this, that would be lovely.

Kind regards,


In what manner did you install?

Also post the output of:

grep "Using input driver" /path_to/Xorg.0.log 

… the path will be either /var/log/Xorg.0.log or ~/.local/share/xorg/Xorg.0.log

Cool, I’ll try that out after lunch!

I installed like a pleb using the GUI from USB to my SSD

Ah, my mistake, as I wasn’t explicit … what I was actually wondering was whether this was a clean or brand new installation of Leap, or whether it was an upgrade from a prior openSUSE version.

Thanks for your reply Tyler,

It was a fresh install of LEAP with a format using all default FS and partitioning settings.

Here’s the output from grep:

14.938] (II) **Using input driver** 'libinput' for 'Power Button'
14.955] (II) **Using input driver** 'libinput' for 'Video Bus'
15.010] (II) **Using input driver** 'libinput' for 'Video Bus'
15.026] (II) **Using input driver** 'libinput' for 'Power Button'
15.038] (II) **Using input driver** 'libinput' for 'Sleep Button'
15.053] (II) **Using input driver** 'libinput' for 'Logitech USB Receiver'
15.196] (II) **Using input driver** 'libinput' for 'Logitech USB Receiver'
15.255] (II) **Using input driver** 'libinput' for 'HD WebCam'
15.296] (II) **Using input driver** 'libinput' for 'AT Translated Set 2 keyboard'
15.355] (II) **Using input driver** 'libinput' for 'SynPS/2 Synaptics TouchPad'
15.384] (II) **Using input driver** 'libinput' for 'Acer WMI hotkeys'
15.431] (II) **Using input driver** 'libinput' for 'Logitech USB Receiver'

Sorry if I’m not using the proper formatting for terminal output! Newbie here!

Okay, that output is actually what you’d would want to see. I asked whether you had updated because if you had previously been using the synaptics driver instead in an older openSUSE release, things have changed now and libinput is the default xorg input driver for such devices.

Sorry if I’m not using the proper formatting for terminal output! Newbie here!
Just wrap output text in the code tags (the “#” symbol above the editing box). But for your very little output, which retained its formating, its no big deal

Now, returning to your particular problem. I don’t know offhand why the slider is greyed out for you:

Perhaps others will have some insight (Deano, in particular, is quite knowledgable about input related matters)

see forum:applications “touchpad setting are non-active in 42.2”

Only Tumbleweed though, not on 42.2.
And only if you use KDE, as a dependency has been added to the Plasma packages to pull in synaptics again.

The problem maybe can be solved by installing the package xf86-input-synaptics though.

See also: https://forums.opensuse.org/showthread.php/522336-touchpad-setting-are-non-active-in-42-2

Interesting. FWIW, on my laptop, utilising the libinput xorg driver in TW, the sensitivity slider is NOT greyed out (i.e works fine)

There is a bit on the forthcoming touchpad config here: https://www.kde.org/announcements/plasma-5.8.95.php … though that looks like its just addressing its functioning in Wayland

Noticed on the weekend that there is mention in the archwiki that the kcm is not working with libinput (I beg to differ), but obviously there is a hit and miss with it; see https://wiki.archlinux.org/index.php/Libinput#Touchpad_settings_not_taking_effect_in_KDE.27s_Touchpad_KCM

Well, as I understand it, more complete support for libinput (which is mandatory for Wayland) has been added, and that may help on Xorg too (if synaptics is not installed/used)…
I’m not really sure though.