Unable to acces usb-sticks

Hi!

I am new to linux and have recently installed openSUSE 12.1 on my laptop. I tried to connect an external mouse to the computer via a usb-port, however the mouse was not detected. I initially thought this was due to a problem with the mouse. When I try to connect a normal usb-stick, however, I am unable to locate that as well. I am not sure if it is relevant to this problem, but I have tried to apply the fix detailed in this thread: http://forums.opensuse.org/english/get-technical-help-here/hardware/459197-automount-external-ntfs-usb-drive-fails-when-using-device-notifier.html

I hope I have posted this in the right place.

Thanks in advance!

Which desktop are you using? KDE, Gnome, …?

Thanks for the answer. I’m using KDE.

On 08/27/2012 08:46 PM, DaNi92 wrote:
>
> Thanks for the answer. I’m using KDE.
>
>

it should “just work” which means maybe you had a bad install, or maybe
you have some kind of hardware problem…lets look at hardware first:

  • do you have another operating system on board? if so boot to it and
    see if all the USB ports work (sometimes one will fail and the others
    will work, etc)

  • if you do not have another OS, then boot from a live CD (any) and
    check the hardware operates as expected, or not…

now, we all know here that both the mouse and USB memory stick should
work…so, tell us about your hardware (maybe openSUSE doesn’t ‘like’
it…maybe you checked the hardware with windows, which loves it, but
no Linux known to man will work with it): brand, model number, form
factor, CPU, RAM, etc

be SURE to mention if your hardware has an Apple on the cover!!

if the hardware is good for both windows and Linux, then you must have a
software problem, so:

  • did you download your install iso from http://software.opensuse.org/?
    if not, from where did you get it?

  • once downloaded did you check the md5sum to make SURE you had the
    exactly correct iso, before you burned the disk? (if you do not know
    what i’m talking about, ASK!)

  • once the iso check out ok, did you then do a disk self test like:
    http://tinyurl.com/3qde66h ? what were the results of that test?

  • if you did all of those things to make sure you had a good disk, then
    tell us what errors were encountered during the install (because if you
    have compatible hardware, tested install medium and trouble free
    install, then

then: your USB mouse/stick works or . . .

or, i don’t know!

oh!

  • did the USB mouse/stick ever work after the install??

  • have you run YaST Online Update since completing the install?

  • have you added software to the system since the install AND before you
    started having troubles? (what was installed? was it via 1-Click Install
    buttons on the net, or how was it installed?)

  • did you make any customizations before the USB started not working?


dd http://tinyurl.com/DD-Caveat