Unable set/modify display parameters with a Dell Latitude E6420 with an Intel chipset

Hello everybody,

First of all, please excuse my english as it is not my first language.

After having used Mandriva (I’m french :wink: ) for a few years, and Ubuntu on a second machine, as I got a new laptop from my company I decided to try another distro, and chose OpenSuse. So, despite being “quite old” in the usage of Linux, I am not very used to this system. However, to minimize the gap, I wanted to stay with KDE.

I experience difficulties setting display properties with my Dell Latitude E6420, running OpenSuse 11.4 64 bits:

  • I cannot change the resolution of my LCD
  • xrandr cannot detect any external VGA monitor

It has an Intel graphical chipset, so I boot with the nomodeset kernel parameter, with kernel version “I” (that is, the installation process :wink: ) also set vga=0x36b.

My chipset, as identified by a lspci is

00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)

xrandr -q returns

xrandr: Failed to get size of gamma for output default
Screen 0: minimum 1600 x 900, current 1600 x 900, maximum 1600 x 900
default connected 1600x900+0+0 0mm x 0mm
   1600x900       77.0*

There is no mention of my external monitor, nor of other resolutions for my LCD (a MJ154 140KT model).

However, the external monitor is detected through YaST2 (IIyama PL2206W).

I suspect a problem with my driver and I have tried to force the usage of intellegacy by specifying Device “intellegacy” in 50-device.conf, but the X server does not start. I have downloaded and installed (what I suppose is) the last version of the driver, xorg-x11-driver-video-intel-legacy-2.9.1-24.2.x86_64.rpm from this repository.

I have lost 3/4 of my day surfing from one forum to another one and have done multiple attempts. The strangest thing, however, is that when I plugged the external monitor for the first time (before booting), I actually got a display on it, but as my LCD remained black, I rebooted and… plop, I since have lost my external monitor (which still works :wink: )

Here is my Xorg.0.log without the legacy driver specified, and with the legacy driver specified in 50-device.conf (which does not work…).

Could you please help me? Thank you!

I have found that doing a Ctrl-Alt-F1 (Switch to Terminal) and then doing a Ctrl-Alt-F7 to switch back can help detect an External Monitor after KDE has started up. I have found that upgrading to the most recent Kernel can be helpful (kernel 3.1.2 is the most recent stable kernel). See my blog on that subject here: S.A.K.C. - SUSE Automated Kernel Compiler - Version 2.50 - Blogs - openSUSE Forums

You can add in the following repository and update all YaST components if you wish: Index of /repositories/YaST:/Head/openSUSE_11.4

You can find the most recent X11 components here in this repository: Index of /repositories/X11:/XOrg/openSUSE_11.4

Updating the kernel version is pretty painless and this is where the base drivers are located. Other components may need upgrading as well, but go slower on YaST and X11 updates. We also now have openSUSE 12.1 which may work better. You could always try a KDE LiveCD and see how that works before loading anything on the PC: software.opensuse.org: Download openSUSE 12.1

Perhaps something will be helpful to you.

Thank You,

Thank you jdmcdaniel3 for your answer.

Before trying your solutions, I moved back to the previous, default version of the legacy driver (the log I had posted suggested it was not adapted to my version of the X server).

I have tried Ctrl-Alt-F1 then Ctrl-Alt-F7, nothing.

I have upgraded to 12.1, nothing (except of losing 1h because of an unexpected corrupted ext4 partition, which I had to repair :P)

I have upgraded to kernel 3.1.2, nothing (BTW, thank you for your script!)

I have added the repositories you suggested, nothing. Apparently, there is no update uvailable (and before you ask, I have of course replaced 11.4 by 12.1 :slight_smile: )

Here is the latest version of my Xorg.0.log with my attempt at using the legacy driver.

What surprises me is that when I installed 12.1, the external monitor properly duplicated the LCD during the installation process, but after the reboot (and the subsequent repair of my corrupted partition), as before, nothing appears.

Standby for the moment. I have just discovered this topic, which I will explore tomorrow.

Standby for the moment. I have just discovered this topic, which I will explore tomorrow.

When searching for any new program after adding in a new repository, don’t forget to check out the versions tab as a newer version may not automatically be loaded what it requires a vendor (repository) change. Selecting a different version allows changing the repository (vendor) as well.

Thank You,

Well, well, well…

I am desperate. Here is my situation as I understand it:

  1. According to the release notes, I cannot boot without settting nomodeset (or, alternatively, i915.modeset=0 for my Intel chip)
  2. As I have an Intel chipset, this results in OpenSUSE switching back to the fbdev driver
  3. I should therefore specify Driver “intellegacy” in my 50-device.conf
  4. Unfortunately, my chip is modern and the old legacy driver does not support it

So, for the rest of the life with this computer, I will get stuck with a 1600×900 resolution (good), no possibility to adjust the light levels (bad), no possibility to use an external monitor (bad) nor any videoprojector with Linux (very bad: as a teacher, I will therefore have to boot on Windows 7 each time I will have to make a presentation). This is a big #fail :frowning:

I do not want to develop the necessary skills to rewrite the legacy driver for my specific case :wink:

… but I still expect a miracle. Does anybody here have an idea?

Looks like this is an Optimus, hybrid, system:
Dell Latitude E6420 - Specifications, Reviews & More | Dell
what’s the output of /sbin/lspci | grep VGA?

This is one possible configuration among others.

See my first post:

00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)

Does your laptop have HDMI output as well? I only ask, as it would be interesting to see if it detects/supports an external HDMI-connected monitor correctly.

It has, and I had the same idea when I read hank_se’s question, but I can’t remember if the Iiyama I use at my office as external monitor has this connector. I don’t think it has, but I’m not 100% sure. I will not be able to check before monday.

However, my TV has a HDMI connector. I may try it tomorrow… but for the moment, it’s time to go to bed in France…

So the HDMI output works perfectly with Windows, but remains undetectable with Linux <sigh>…

I’m having the same problem, a brand new Dell Latitude E6420 with the dual graphics card setup that can’t detect external monitors plugged into either the notebook VGA port or the DVI connectors on the docking station. xrandr doesn’t see it.

I tried installing the NVidia drivers, but that just broke X completely.

I just started this job, so I really need to get this working in a hurry. Help?

If it uses the NVIDIA Optimus graphics architecture, then this guide may help: