Unable build rt73.ko after upgrade to 11.2


On my opensuse 11.1 system. I used my tp-link tl-wn321g usb wireless adapter to access the internet. It runs on rt2501 chipset and I used the serial monkey rt73 driver from here.


What I did was I installed the kernel-headers, kernel source, gcc and make. And then I cd to the module directory and did

make install
modprobe rt73

And then I configured the network with yast.

That was until I upgraded to 11.2 using the guide here.


The upgrade went well, but I could no longer use my wireless adapter. I tried installing the driver again but when I tried to run “make”, it says

make: *** /lib/modules/ No such file or directory.  Stop.
rt73.ko failed to build!
make: *** [module] Error 1

I’ve checked that kernel-headers, kernel-source, gcc and make are all installed.

I installed “ralink-firmware-1.1-1.5.noarch.rpm” from Software.openSUSE.org. I tried “make” again, but still the same error return.

I’d really appreciate your help.

I wonder if you need kernel-devel, to match the kerenl type you are using (default, pae, desktop)?

How do I install that?
I tried using yast, and it says error downloading. Well I can’t get online since wireless adapter isn’t working.
I haven’t got the 11.2 DVD either (if that is needed) since I did the live update.

You would need the DVD or to get online
Or use a different computer and download it manually then install it manually. Are you using PAE kernel?

Thanks for your reply.
Yes, I am using pae. It was installed automatically when I installed something - I think it was the kernel-source, or the kernel header; back when I used 11.1.
I’ve managed to download kernel-pae-devel and have installed it.
Then I tried building using “make” again, but I still got an error.

make[1]: Entering directory `/usr/src/linux-'
make -C ../../../linux- O=/usr/src/linux- modules
  Building modules, stage 2.
  MODPOST 0 modules
make[1]: Leaving directory `/usr/src/linux-'
rt73.ko failed to build!
make: *** [module] Error 1

A bit different to last time though. Maybe this is heading somewhere?:wink:

Please post result of

rpm --query --all '*kernel*'

Sorry I take very long to reply.
Anyway here is the result of rpm --query --all ‘kernel’.


Your kernel-headers should be


make sure you update them

I’ve updated it to “linux-kernel-headers-2.6.31-3.4.noarch”. This is my new rpm --query --all ‘kernel result.


And then I tried the “make” command again.

make[1]: Entering directory `/usr/src/linux-'
make -C ../../../linux- O=/usr/src/linux- modules
  Building modules, stage 2.
  MODPOST 0 modules
make[1]: Leaving directory `/usr/src/linux-'
rt73.ko failed to build!
make: *** [module] Error 1

Still no luck. Maybe I’m missing some steps between updating and building.

Tell me what you think of this here

HCL/Network Adapters (Wireless) - openSUSE

Thank you caf4926. You are awesome.
My wireless card is up and running.
I am able to send this post using my PC on opensuse 11.2 and that wireless network card.
A few things still puzzles me though.

Let me recap what happened.

I checked the link you gave me, and my wireless adapter is listed there. The chipset is rt2501. It says ‘ralink-firmware’ package required. I’ve installed the ralink-firmware package before, as mentioned in my first post.

I scrolled up the page and found the command

hwinfo --wlan

I ran that command and get this reply

19: USB 00.0: 0282 WLAN controller                                   
  [Created at usb.122]                                               
  UDI: /org/freedesktop/Hal/devices/usb_device_148f_2573_noserial_if0
  Unique ID: ADDn.9pajj3PUrd8                                        
  Parent ID: k4bc.RJPqUTMMECB                                        
  SysFS ID: /devices/pci0000:00/0000:00:03.3/usb1/1-1/1-1:1.0        
  SysFS BusID: 1-1:1.0                                               
  Hardware Class: network                                            
  Model: "Ralink 54M.USB......."                                     
  Hotplug: USB                                                       
  Vendor: usb 0x148f "Ralink Technology, Corp."                      
  Device: usb 0x2573 "54M.USB......."                                
  Revision: "0.01"                                                   
  Features: WLAN                                                     
  Speed: 480 Mbps                                                    
  Module Alias: "usb:v148Fp2573d0001dc00dsc00dp00icFFiscFFipFF"      
  Driver Info #0:                                                    
    Driver Status: rt2500usb is not active                           
    Driver Activation Cmd: "modprobe rt2500usb"                      
  Driver Info #1:                                                    
    Driver Status: rt73usb is not active                             
    Driver Activation Cmd: "modprobe rt73usb"                        
  Config Status: cfg=no, avail=yes, need=no, active=unknown          
  Attached to: #12 (Hub)

It says “Driver status” is inactive for both rt2500usb and rt73usb.

So I did

modprobe rt2500usb
modprobe rt73usb

For both commands, I got a reply

WARNING: All config files need .conf: /etc/modprobe.d/ralink, it will be ignored in a future release.

I was pretty sure there was something wrong. But when I checked the status on hwinfo --wlan again, both drivers are activated.

Driver Info #0:
    Driver Status: rt2500usb is active
    Driver Activation Cmd: "modprobe rt2500usb"
  Driver Info #1:
    Driver Status: rt73usb is active
    Driver Activation Cmd: "modprobe rt73usb"

I tried setting up the network with yast, and on Hardware tab, three modules appeared - rt73, rt73usb and rt2500usb. I chose rt73, and scanned for wireless network. I was surprised that it found my wireless network. I couldn’t even build the rt73 module. I went on with the configuration anyway.

When I clicked Accept, there is a popup saying that I need to install iw package. The installation failed since I needed to get online to download the package. The network configuration went on after I aborted the installation. Somehow, my network card managed to get activated.

So three things puzzled me - the WARNING after modprobe, how did the rt73 suddenly works and the “iw package”.

Still, caf4926, I can’t thank you enough.:slight_smile:

;)Happy to help -enjoy

If you still want to compile this driver you must replace the Makefile with this one: http://forum.aircrack-ng.org/index.php?&action=dlattach;topic=1824.0;id=569

I’ve got some compiler errors but I found a better solution:

  1. Download this Debian source package: https://edge.launchpad.net/~marco/+archive/ppa/+files/rt73-k2wrlz-source_3.0.3-2~ppa0~karmic_all.deb
  2. Extract the package with for example file-roller
  3. Extract data.tar.gz
  4. Extract rt73-k2wrlz-3.0.3.dkms.tar.gz
  5. cd to dkms_source_tree
  6. make && make install

Hey there, I´ve been looking for a solution on all forums that i could find on google, but still nothing…I even bought that card in purpose (WUSB54GC v3). And can´t have it running on Backtrack.

I´ve followed last thread (mvsroot) but still, i´m stuck here:

make: *** /lib/modules/ No such file or directory. Stop.
rt73.ko failed to build!
make: *** [module] Error 1

I´m running on Backtrack 3 Final Live CD (on USB pen drive)

I can see that theres a “Makefile” file, but no “Make” file

So ive tried it and it says (damm, cant even copy past from linux to windows…):
./Makefile: line 42: MODULE_NAME: command not found
./Makefile…and so on until line 52

Please help me i just wanna have that card running and i dont know nothing about linux,

Thank you very much

The fifth (main) Google hits I got for a search with
WUSB54GC v3 linux
According to that you device may have the numeric ID 1737:0077.


  1. Are you sure what device you have? Have you got/proved the numeric ID according to the stickies in this forum?

  2. I do not really get all the drivers and configuration things for wireless devices, but are you sure that you need (to compile) rt73.ko ?
    Take a look at:
    1737:0077 - Google Search on cateee.net

rt73 - Google Search on cateee.net

rt73 1737:0077 - Google Search on cateee.net

I am not in charge here nor would call myself a wireless/linux expert but I would guess opening a new thread for your hardware and software configuration (with more information on the first one) may help the helpers to help you a bit more…

And “Backtrack 3 Final Live CD” -> Maybe it would be a good Idea to adapt the used forum to your software or vis versa?
What packages or programs are missing in a openSUSE 11.4 GNOME or KDE live CD for your task?
Is a “Backtrack 3 Final Live CD (on USB pen drive)” ??? probably a live installation with special data structure and compression, not a normal/permanent one] ??? the best way to use linux software for you purpose?
Is not BackTrack 4 (based on Debian) the last stable version of BackTrack ?
see: BackTrack - Wikipedia, the free encyclopedia