Ultra Slow on 12.3 KDE

Not sure where to post this but noticing the memory fragmentation post I think this is a related problem and nothing to do with the applications.

The other day I found myself typing ahead by several seconds while posting on here using Opera 12.6. Opera had around 10 tabs open and Firefox 23 14 tabs open. Okular was also open loaded with a 437 page pdf. As Firfox had 2 yahoo group tabs open there would be occasional web activity - advert updates and mail notification. Also backups from on here through Opera. There would also be other web activity passing through the router either from my son’s ipad or desktop. That traffic is heavy at times but the router is more than capable of handling the band width available from my isp and sharing it correctly with far more users than are ever on it.

I would say that the typing was taking near 5 secs to display. I have had this on 11.4 but no where near this long. I closed Firefox and all returned to normal.

The machine is an HP workstation fitted with a 3.6ghz 4 core E5-1620 Xeon and 24gb of ram. 10gb of swap available as well which never seems to be used. I’m running 12.3 KDE updated 19 Aug 13 via YAST. The OS is on a flash drive, swap, home, tmp and var on hard drives, home exclusively to a mirrored raid.

I’ve loaded up the same again and Kinfocentre shows 17% used total memory, free physical memory 75%, disk cache 12% and app data 11%.

I wonder if anyone else has had this problem and why it occurs and also when it happens again what incantations might tie down what is causing it. I mention web activity as I sometimes had the feeling that the same much less severe problem occurred 11.4 when other user traffic was heavy but I am not really sure about that. It could also be a memory leak etc elsewhere. As I have many gb hanging of my desktop similar but only slight problems occurred when desktop indexing was active so I always disable it. I’m also running Kmail 3 to stay well away from the current indexing code. Kmail 3 wasn’t up and running anyway.

Graphics is Nvidia Silent, OS driver, 2560x1440 display, one monitor.

The Xeon is a whim - always wondered what they were like to use and ex demo HP machines can be a bargain.

Whoops, this occurred before the 19aug update. The previous update was some time before, probably over 2 weeks ago. I had notifications of 8 (?) and 2 updates before making the 19aug one.


If you think it is a memory problem, have you run memtest from the grub screen?

I haven’t run that as the PC uses ECC memory so should show up problems of that sort. I will run it though as a check.

My feeling is that it is more likely to be a system / application memory problem or some form of contention problem that more or less locks up the machine so key board response lags way way behind the input. On 12.3 the one instance of this happening was very severe, 5secs for characters to appear on the screen is probably a bit of an exaggeration but not by much. On 11.4 and my previous machine I reduced the number of times it happened by increasing the ram from 4 to 8gb and the delay was around 1 sec on that and it still happened with 8gb but less often.

Web searches bring up bug type problems of this sort but only mentioned several years ago. The nvidia driver is mentioned at times. Old machine used that, the new one is using the OS driver.

The only thing I am sure about is that loads and loads of browser tabs and maybe one the browsers having 2 windows open cause it to happen and on the latest instance closing firefox fixed it instantly. I only use firefox because yahoo tends to discount Opera and yahoo groups make use of yahoo mail. :sarcastic: An insular lot, the uk £ sign has only relatively recently appeared in their character set.


:\ I can’t see any way of running a memory test from the boot screen. Just 12.3 normal mode or advanced mode. The advanced mode just offers more 12.3’s one of which required root permissions for restarts.


Boot from the Installation DVD or a LiveCD and the entry should be there at the boot menu.

Or install the package “memtest86+”, that should add a memtest entry to your boot menu.

Installing the mem test with YAST adds it to the boot menu but it gives a “can’t find linux16” error message.

I ran the one on the install package instead. 3 passes and no errors.


Hm, works fine here.

But apparently memtest86+ cannot be run in EFI mode:
grub2 - Error when running memtest86+ - Ask Ubuntu

But doesn’t matter now anyway, when you can run it from the installation disk… :wink:

Could it be Flash’s hardware acceleration? IIRC my son had issues like you’re having, disabling hw acceleration in Flashplayer fixed it.

I did have some tabs with Qt training video’s on them but none where active but they had been since boot. When I reported the mem usage the same tabs were open in Firefox and again not active but I had restarted.

An interesting thought. I will try the same things again later and see if the same thing happens.

I’m not sure how to permanently disable Flash hardware acceleration?

I am running boot/efi. My feeling on memtest is that maybe it could do with a bit of an update - for instance 4 cores and 4 memory channels sockets filled. HP use that as excuse to fit 4 x 2gb and why I finished up with 24gb by adding 4x4gb to them. :’(At least it has enough slots.