UK USB stick modems problems

Hi, I live in the uk and I am trying to buy one of those usb stick modems from some of the major companies (vodafone, orange, tmobile). I went to carphone warehouse and the seller said that no matter which modem I choose it is not going to work with linux. he suggested I should migrate back to windows which I dont want to do at all. but if I cant get the internet to work I will have to do it. please please do you have any suggestions? are you aware of existence of some drivers that might solve the problems? the seller said that its not going to work because linux is opensource.

thank you so much for help

Bought a BELKIN USB WIFI 54 MBPS ADAPTER F5D7050 two monthes ago for a friend where I support openSUSE. No problem. And there are more.
Check the Hardware - openSUSE, it is not perfect, but there is information.

And browse throough these Forumm.

I have come across several USB stick mobile modems and all of them worked so far. If you have a laptop, carry it to the shop and it is easy to check too.

Generally, I don’t bother asking the shop guys (the so called “computer experts”) about Linux compatibility.

I went to carphone warehouse and the seller said that no matter which modem I choose it is not going to work with linux. he suggested I should migrate back to windows which I dont want to do at all.

Not true at all. I’ve used a few of Huawei and Sierra Compass usb broadband wireless modems without any issues so far.

Search the forum, or via google (with sensible keywords) first if you are in doubt before you go shopping.


I’ve never had any problems with Huawei USB modems in GNU/Linux that
couldn’t be solved very easily.

Sure the pathetic software that comes with them is for Windows, but with
Network Manager finding and setting up USB modems, who needs it.

My advice is: never listen to the checkout operator in a shop about
technology, especially GNU/Linux, which they probably know nothing about.
10 minutes of research on the internet about hardware you are
considering buying would give you far more information than they have.

Barry Nichols

thanks for the answers everyone.

so i bought the modem (huawei K3565) and I cant get it to work. the problem seems weird and on I found a couple of people who are having the same problem but no one really came up with a solution to it.

I will try to describe the problem step by step.

I installed both umtsmon and vodafone mobile connect card driver for linux from betavine.
after several unsuccessful tries I managed to find the proper apn on betavine which is PPBUNDLE.INTERNET
now I can get both umtsmon and vodafone to connect (the modems blue light keeps lighting which suggests it is connected). however as soon as i open firefox it says it is offline and whatever i do (file-work offline) has no effect on that.

interestingly enough when I try to start skype it works and I can call!

yesterday late at night it seemed like i got the solution. in knetwork manager I tried to connect with all the necessary details and it did. then I could use everything. but the next day in the morning I try it knet doesnt even start connecting with the same details like yesterday. there is no response whatsoever.

I am not a complete linux noob I have been using it for almost a year now but I am definitely not an expert and this problem seems unsolvable to me. I assume its something with ppp (whatever that is, ok maybe i am a noob:)

btw I run opensuse 11.1

do you reckon upgrading to 11.2 might help?

I really need to come up with the solution quickly because I am working on a project which requires constant internet connection. If i cant get it done in a couple of days I will have to go back to windows.

so please any help is very much appreciated

thank you so much

Just a short remark. I can see how your original question softly flows into a technical poblem. However I would advise you to make a new thread with a new title (with huawei K3565 in it). Tuis that thread will hopefully attrackt people who have any experience with the device.

good idea