UEFI Issue after install

I had used Fedora for years and decided to install OpenSuse Leap 42.2 a few weeks ago. I have an odd problem that I can’t seem to resolve. First, let me say that the OS runs very smoothly, quickly, and after installing the Cinnamon desktop, I’m very happy with the results - very nice work to all who develop this OS.

On to my issue:

When booting, I get an error - kernel not found.

I reboot, hit escape to get to the boot manager (in UEFI) and I see a fedora instance and an opensuse instance. I can’t seem to be able to get rid of the fedora instance - which is causing my problem. So I select the opensuse instance and my laptop boots right up.

I don’t know how to remove that instance in the UEFI boot manager. Is this something I can edit out of the Grub2 configuration?

Thanks in advance for any help anyone can provide.

Yehudah

Hi and welcome to the forum :slight_smile:
As root user, check the output from;


efibootmgr -v

I think you will see the Fedora entry and perhaps no openSUSE entry?

You can remove via;


efibootmgr -b N -B N

Where N is the offending entry, then set the boot order to point at openSUSE with the -o option.

If not sure, post back the output from the above commands.

You should then be able to go into YaST bootmanager and make a change, eg wait time and if only opnSUSE uncheck the probe other os check box. YaST should do it’s thing and create new entries…

Okay:
BootCurrent: 0006
Timeout: 2 seconds
BootOrder: 0002,0004,3004,2001,2002,2003
Boot0000* Internal EFI Shell MM(b,a78b8010,a80b800f)RC…
Boot0001* Internal EFI Shell MM(b,a78b8010,a80b800f)RC…
Boot0002* opensuse-secureboot HD(1,800,64000,3495f81c-18bf-4f17-8a99-42ddf772c67e)File(\EFI\opensuse\shim.efi)
Boot0003* Internal EFI Shell MM(b,a78b8010,a80b800f)RC…
Boot0004* Fedora HD(1,800,64000,3495f81c-18bf-4f17-8a99-42ddf772c67e)File(\EFI\fedora\shim.efi)
Boot0005* Internal EFI Shell MM(b,a78b8010,a80b800f)RC…
Boot2001* USB Drive (UEFI) RC
Boot3000* Internal Hard Disk or Solid State Disk RC
Boot3001* Internal Hard Disk or Solid State Disk RC
Boot3002* Internal Hard Disk or Solid State Disk RC
Boot3004* Internal Hard Disk or Solid State Disk RC

So it does show Fedora. I edited the boot order, but didn’t seem to be able to remove the Fedora entry. Went into Yast to make sure only Opensuse was being looked at/booted from.

Thanks so much

That did the trick; now it boots directly into Leap like it’s supposed to.

Logging this fix. Thanks so much!

Hi
Your welcome :slight_smile: To remove the entry, use;


efibootmgr -b 4 -B 4

One good thing about UEFI if something screws up, you can boot from a rescue system and then use efibootmgr to recreate/fix things as well.

Note you may still have Fedora code in the efi boot partition (/boot/efi in the OS). Don’t think it will hurt but you can remove it just to be neat