UEFI, GPT, and MS-DOS Partitions

I now have an unbootable system after upgrading from 15.3 to 15.4.

I DID notice the warning message before update about booting from an EFI device for a Legacy MBR. Sure enough, I saw it and I stepped in it - hoping that all would be fine. Under “1.4 UEFI, GPT, and MS-DOS Partitions” at https://doc.opensuse.org/release-notes/x86_64/openSUSE/Leap/15.4/index.html#installation, it says to *“convert the legacy MBR partition to GPT.” *BTW: I also noticed that my windows drive is missing from the grub menu.

Considering that I can’t get into the system (which is encrypted, btw) please tell me what is my best option. Thanks in advance.

P.S. Under UEFI Firmware Settings in the grub menu: error: …/…/grub-core/script/function.c:119:can’t find ‘fwsetup’

You failed to tell us how you upgraded.

You possibly used the DVD installer or NET installer for the upgrade. And it seems that you booted the installer in UEFI mode. That was your mistake. You should have booted it in legacy MBR mode.

Switching a disk from DOS/legacy partitioning to GPT partitioning will often result in a loss of data. Your best bet might be a clean install of Leap 15.4, though you might lose Windows.

There is no evidence that this happened either.

At the very least we need output of

fdisk -l

from this system.

Yes, I used the DVD installer. Please tell me how do I boot it in legacy MBR mode. I have windows on another drive, so I’m not worried about that. Thanks in advance.

I believe I can get in through the 15.3 snapshot, but not 15.4. How do I get

fdisk -l

from 15.4? Thanks in advance.

What if I tried upgrading again using legacy MBR? Is there a way to repair what I have? Thanks in advance.

That’s between you and your BIOS.

I have two UEFI boxes, and they behave differently. With one of them, I hit F12 during boot and it gives me both UEFI and legacy boot choices provided that secure-boot is disabled. On the other one, I have to tell the BIOS whether to prefer UEFI booting or CSR booting before I start.

I do not know what works for your BIOS.

We do not know what you have. So we cannot answer that.

If you booted 15.3 on the same PC, exactly the same way you would get it booted to 15.4 - anyplace you can type in a command from a root login. If there’s any problem to copy & paste, redirect output to a file:

fdisk -l > somefile1.txt
lsblk -f > somefile2.txt

Notice the change in the second command name.

Sincere apologies for the delay. Thank you for waiting. My motherboard broke down, so I am in the process of connecting to an ASUS TUF Gaming B450M-Pro S MB. BTW: I am having trouble finding info booting legacy bios on these newer MBs. Like this new one, ASUS only wants to talk about how great UEFI is.

I actually agree with them about that. Given a choice, I prefer UEFI. But it doesn’t solve your original problem.

Since you now have a new MB, maybe a fresh start using UEFI is the way to go.

Evidently, there was some kind of damage to both my linux and windoz drives when the motherboard died; I am unable to boot into both of them.

On the OSS side, I have tried almost every 15.3 snapshot, but I keep getting a message to the effect, “no IRQ available to handle that vector,…” then the system restarts. The same happens with 15.4.

The motherboard also reports on the handy LED display that there is something wrong with these drives.

There is a possibility that I installed a damaged 15.4 from DVD. I did not do a checksum because openSUSE-Leap-15.4-DVD-x86_64-Media.iso.sha256 was empty when I downloaded it. I just now checked it; now there’s data.

The new ASUS MB has a facility for legacy USB. The problem is I no longer have a PC for creating that OSS 15.4 USB.

I plan on reinstalling OSS 15.3 from DVD on a another drive. Thanks to all for your help. I will be starting a different thread under hardware to get help on extracting data from my encrypted OSS 15.3 / 15.4 drive.

After correcting hardware errors, here is the output from my install of OSS 15.4:

linux-8wry:/home/randolph # blkid
/dev/mapper/system-swap: UUID="9597356d-19a2-48e9-ab08-d72565c51c3a" TYPE="swap"
/dev/sdb2: UUID="40d7d154-c996-40de-b650-1df1ef24acff" TYPE="crypto_LUKS" PARTUUID="b2051ab0-51ed-4348-933c-eacca016448c"
/dev/sdb1: PARTUUID="db4ff8e6-7c15-438e-859d-71cd5cf33408"
/dev/mapper/system-root: UUID="b118c182-8846-4348-9153-3787a3cb392b" UUID_SUB="896b1c7b-85a8-4b5a-9cb1-fb3a6f77d9c7" BLOCK_SIZE="4096" TYPE="btrfs"
/dev/mapper/cr_sda2: UUID="Fz90dt-oTxZ-PH0l-ILiE-qrUI-JBG1-4Lo8HV" TYPE="LVM2_member"
/dev/sda: LABEL="slate 32gb" BLOCK_SIZE="512" UUID="45FD2A252E31F813" TYPE="ntfs"
/dev/mapper/system-home: UUID="bd8a0124-fdf8-43a0-a4ef-341d2b792f84" BLOCK_SIZE="512" TYPE="xfs" 

linux-8wry:/home/randolph # fdisk -l

Disk /dev/sda: 28.91 GiB, 31042043904 bytes, 60628992 sectors
Disk model: Patriot Memory  
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: dos
Disk identifier: 0x00000000

Disk /dev/sdb: 238.47 GiB, 256060514304 bytes, 500118192 sectors
Disk model: ADATA SU800     
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: gpt
Disk identifier: 351D0869-97DD-4B7B-B445-C8BFF38079F7

Device     Start       End   Sectors   Size Type
/dev/sdb1   2048     18431     16384     8M BIOS boot
/dev/sdb2  18432 500118158 500099727 238.5G Linux LVM

Disk /dev/mapper/cr_sda2: 238.46 GiB, 256048963072 bytes, 500095631 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes

Disk /dev/mapper/system-swap: 11.46 GiB, 12306087936 bytes, 24035328 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes

Disk /dev/mapper/system-root: 40 GiB, 42949672960 bytes, 83886080 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes

Disk /dev/mapper/system-home: 25 GiB, 26843545600 bytes, 52428800 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes 

linux-8wry:/home/randolph # lsblk -f
NAME              FSTYPE      FSVER    LABEL      UUID                                   FSAVAIL FSUSE% MOUNTPOINTS
sda               ntfs                 slate 32gb 45FD2A252E31F813                         13.5G    53% /run/media/randolph/slate 32gb
└─sdb2            crypto_LUKS 1                   40d7d154-c996-40de-b650-1df1ef24acff                  
  └─cr_sda2       LVM2_member LVM2 001            Fz90dt-oTxZ-PH0l-ILiE-qrUI-JBG1-4Lo8HV                
    ├─system-swap swap        1                   9597356d-19a2-48e9-ab08-d72565c51c3a                  [SWAP]
    ├─system-root btrfs                           b118c182-8846-4348-9153-3787a3cb392b     21.7G    45% /var
    │                                                                                                   /usr/local
    │                                                                                                   /tmp
    │                                                                                                   /srv
    │                                                                                                   /root
    │                                                                                                   /opt
    │                                                                                                   /boot/grub2/i386-pc
    │                                                                                                   /boot/grub2/x86_64-efi
    │                                                                                                   /.snapshots
    │                                                                                                   /
    └─system-home xfs                             bd8a0124-fdf8-43a0-a4ef-341d2b792f84      3.9G    84% /home

This install does not seem stable. What do you think of installing the UEFI Arm 64-bit servers, desktops, laptops and boards (aarch64) version of 15.4 over the AMD 64-bit desktops, laptops, and servers (x86_64)? Thanks in advance.

I’ve been trying to understand the 15.4 docs on what I experienced so far during installation. The install threatened me with an unbootable system because I didn’t boot through legacy bios (my ASUS MB is UEFI). I had to replace a defective graphics card that gave me the impression it wasn’t booting. After, putting in working hardware, 15.4 boots, but it acts like it’s not quite stable. I plan on upgrading with 15.4 (x86_64) again with a DVD, this time with checksum and disk verification on the working system (checksum was empty when I first downloaded).

Please show us what the graphics system is doing. From Konsole, Xterm or other GUI terminal, run sudo inxi -U, then show here input and output from inxi -GSaz --vs pasted within code tags.

I decided to reinstall 15.4 again via newly generated DVD and working system. The 2nd time around, I got no such warning message about legacy bios. All is stable and working fine now. What I figure is that defective graphics card brought on that warning message. The non-booting disability was by happenstance due to the defective graphics card. Thanks for your reply. I will make note of your instructions - just in case.