UEFI Dualboot Windows 8 Suse 12.3

Hi,
I tried to install openSUSE 12.3 on a Dell Inspiron 17r laptop with Windows 8 pre installed.
I used the openSUSE DVD and ran it from Windows as it is described in the manual.
Also as expected the installation inserted an entry into the windows 8 boot menu.
But when I click on that entry I get a screen indicating windows could not be started cause a file is missing.

\grldr.mbr
status: 0x000007b

Does anyone know what went wrong here?

I tried that with both: secure boot on and off.

I considered to boot from the SUSE Installation DVD and install from there directly. But to do so I have to switch to Legacy boot and I’m not sure if both OS will still work. I would have to switch back to UEFI anyway since Windows 8 would not boot in Legacy boot mode.
So since the linux install from windows is supposed to work but doesn’t I’m sort of scared to mess up my system.

Any suggestion is welcome.

Regards
Heiko

You can not install form windows burn to a DVD/USB device and boot from that to install.

What instructions are you using that told you to start the install from Windows???

Yes, that’s the way to do it. You should not have to switch to Legacy boot.

I copied the 12.3 DVD iso file to a USB using “dd_rescue”, but “imagewriter” or straight “dd” should also work. Or installing with an actual DVD should work. My install was done completely in UEFI mode, and completely with secure boot still enabled. The 12.3 installer can handle UEFI.

Thanks for your responses.

@gogalthorp:

it’s from the official opensuse documentation. And the install.exe is supplied on the official openSUSE DVD. See1.2.3. Installing with the openSUSE 12.3 Installer from Windowshttp://doc.opensuse.org/documentation/htmlsingle/openSUSE/opensuse-reference.html#sec.i.yast2.source.instlux

@nrickert:

The laptop does not give you a boot option to boot from USB or DVD unless you switch to legacy mode.
Anyway, did you install for dualboot with windows 8 pre installed?

On Thu 21 Mar 2013 11:16:01 PM CDT, HeikoGer wrote:

Thanks for your responses.

@gogalthorp:

it’s from the official opensuse documentation. And the install.exe is
supplied on the official openSUSE DVD. See1.2.3. Installing with
the openSUSE 12.3 Installer from
Windowshttp://doc.opensuse.org/documentation/htmlsingle/openSUSE/opensuse-reference.html#sec.i.yast2.source.instlux

@nrickert:

The laptop does not give you a boot option to boot from USB or DVD
unless you switch to legacy mode.
Anyway, did you install for dualboot with windows 8 pre installed?

Hi
The system should detect that it’s a UEFI bootable DVD? Can you browse
the UEFI (as in select boot device) from the system menu, you should be
able to at least browse to the openSUSE bootx64.efi file, even if it
won’t boot from either USB or DVD. Have you tried creating a bootable
USB device?


Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 12.3 (x86_64) Kernel 3.7.10-1.1-desktop
up 21:31, 3 users, load average: 0.09, 0.07, 0.05
CPU Intel® i5 CPU M520@2.40GHz | GPU Intel® Ironlake Mobile

I’m surprised.

My own UEFI system is a Dell inspiron (but a desktop, not a laptop).

The typical thing to do with a Dell, is pound the F12 key while booting. And that should bring up a boot menu if there are any alternative options such as a DVD or USB.

e

Yes, it has Windows 8 preinstalled.

Soon after I received the system, I inserted a CD for acronis backup software, and hit F12 during boot. It booted straight into Windows. So I went to BIOS settings, and disabled “secure-boot”. Then I tried again with the CD and it was able to boot that CD in UEFI mode (the CD had been designed to allow UEFI, but not for secure boot).

My USB with the 12.3 DVD image will be visible for booting, even with secure-boot enabled. I hit F12 repeatedly during boot (until it beeps at me for hitting it too often), and the boot menu comes up. The difference is that the 12.3 install image is designed for secure boot.

That has never worked before I’d be truly surprised if this method was reliable

On Fri 22 Mar 2013 12:16:01 AM CDT, nrickert wrote:

Soon after I received the system, I inserted a CD for acronis backup
software, and hit F12 during boot. It booted straight into Windows. So
I went to BIOS settings, and disabled “secure-boot”. Then I tried again
with the CD and it was able to boot that CD in UEFI mode (the CD had
been designed to allow UEFI, but not for secure boot).

My USB with the 12.3 DVD image will be visible for booting, even with
secure-boot enabled. I hit F12 repeatedly during boot (until it beeps
at me for hitting it too often), and the boot menu comes up. The
difference is that the 12.3 install image is designed for secure boot.

Hi
Secure boot is on the DVD (or USB with DVD image)…it pops up (very
quickly) a short message to say not booting in secure mode on my
systems.

On this DELL E5510 I get either legacy boot from the DVD or UEFI boot,
I actually did the install via a USB device, but it only has openSUSE
12.3 on it. I UEFI multiboot Windows 7, 12.2 and 12.3 on a HP ProBook.


Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 12.3 (x86_64) Kernel 3.7.10-1.1-desktop
up 22:42, 3 users, load average: 0.07, 0.06, 0.10
CPU Intel® i5 CPU M520@2.40GHz | GPU Intel® Ironlake Mobile

Ups, now I’m surprised. If that never has worked why is it in docs? Even updated. Someone has worked on it otherwise they would not be able to install an entry in the windows 8 boot menu.
By the way how do I get rid of the not working suseinstall windows 8 boot menu entry?
Ok, that’s another topic.

Technically, there is no reason why it shouldn’t work. You can have several entries in a boot menu each starting a different OS. Why not a SUSE installation dvd?

Ok, after pressing F12 i see two UEFI-entries in the boot menu:
Windows8 Bootmanager
Network

It does not make a difference if Secure Boot is enabled or disabled. Maybe my SUSE DVD is broken, so that the firmware does not recognize the UEFI boot medium.
But it works on legacy mode. (By the way: I updated the firmware to the newest version, no change in behavior)

I might try the USB thing as Malcolm suggested.

Regards
Heiko

I have not tried it, but I presume it works for legacy booting, but probably not for UEFI booting.

On my reading of the documentation, what it does (and what should work), is setup the Windows boot manager so that the next boot is from the DVD.

What does not work, and what posts in this forum show people attempting (and failing), is booting from the disk image of the DVD this way, rather than booting from the real DVD.

if it would work for legacy booting it would make no sense since Windows8 does not boot in legacy mode.
Anyway as you suggest I want to boot from the real DVD. But how? It does not offer that except if I switch to legacy.

On Sat 23 Mar 2013 04:36:04 PM CDT, HeikoGer wrote:

nrickert;2539423 Wrote:
> I have not tried it, but I presume it works for legacy booting, but
> probably not for UEFI booting.
>
> On my reading of the documentation, what it does (and what should
> work), is setup the Windows boot manager so that the next boot is from
> the DVD.
>
> What does not work, and what posts in this forum show people
> attempting (and failing), is booting from the disk image of the DVD
> this way, rather than booting from the real DVD.

if it would work for legacy booting it would make no sense since
Windows8 does not boot in legacy mode.
Anyway as you suggest I want to boot from the real DVD. But how? It
does not offer that except if I switch to legacy.

Hi
Is there a way to browse in the UEFI boot options (on my HP ProBook I
do this for booting UEFI). Have you tried via USB device?

Can you get a camera shot of your screen option? Or a link to the
manual for the system?


Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 12.3 (x86_64) Kernel 3.7.10-1.1-desktop
up 1:11, 3 users, load average: 0.34, 0.89, 1.18
CPU Intel® i5 CPU M520@2.40GHz | GPU Intel® Ironlake Mobile

Hi,
i finaly got it working. Just for the case someone else ran into this, here is how:

I finaly found a way to boot the openSUSE-DVD. Using F12 to show the UEFI-Bootmenu did not offer an entry to boot from DVD or USB. But in the Windows8 bootmenu (unexpectedly deep inside :slight_smile: I found one.
When the Windows8 bootmenu is displayed there is text at the bottom:
“Change Standardsettings”
(I see it in german, so I’m not sure what exactly is shown in the English version. I just translate and guess)
From there several new entries are shown choose —> “Other Options”
From there choose → “Use device”
From there choose → “Show other devices”
From there choose → “CD/DVD”

After doing so the openSUSE DVD booted in uefi and secure boot on.
When it came to partitioning I had to pay attention. The openSUSE installation did NOT see the Windows installation and tried to overwrite the windows partition. I changed it to the (unused) second disc.
I set the secure boot switch in the boot settings (which was off by default) as “nrickert” described in his really helpful dualboot blog
(see https://forums.opensuse.org/blogs/nrickert/dual-boot-opensuse-12-3-windows-8-uefi-box-133/)
Than the installation worked like a charm.

Now, when I turn on the computer it boots openSUSE in uefi and secure boot on. Fine default
If I want to boot windows8 I press F12 on startup (see nrichert’s blog). In the uefi boot menu there are 2 new entries for opensuse and the old windows8 entry.
Works perfect for me.

Thanks everybody for the help.
Regards
Heiko

Great. I’m glad you got it working.

On 2013-03-22 00:16, HeikoGer wrote:
> Thanks for your responses.
>
> @gogalthorp:
>
> it’s from the official opensuse documentation. And the install.exe is
> supplied on the official openSUSE DVD. See1.2.3. Installing with
> the openSUSE 12.3 Installer from
> Windowshttp://doc.opensuse.org/documentation/htmlsingle/openSUSE/opensuse-reference.html#sec.i.yast2.source.instlux

Ha!

Then you will have to ask those same sources for guidance. >:-)

As far as I know, that method does not work, and probably nobody here
can help you with it. We do not recommend it.


Cheers / Saludos,

Carlos E. R.
(from 12.1 x86_64 “Asparagus” at Telcontar)

On 2013-03-22 14:56, nrickert wrote:
>
> HeikoGer;2539345 Wrote:
>> Technically, there is no reason why it shouldn’t work. You can have
>> several entries in a boot menu each starting a different OS. Why not a
>> SUSE installation dvd?
>
> I have not tried it, but I presume it works for legacy booting, but
> probably not for UEFI booting.
>
> On my reading of the documentation, what it does (and what should
> work), is setup the Windows boot manager so that the next boot is from
> the DVD.

I have raised the issue in the factory mail list.


Cheers / Saludos,

Carlos E. R.
(from 12.1 x86_64 “Asparagus” at Telcontar)

I have a question.

I think that I’ve learned that booting from the openSUSE installer DVD in UEFI mode was possible already using the openSUSE 12.1 64 Bit installer DVD.
No need for legacy booting already then.

Then came secure boot, and the prohibition of booting from CDs and DVDs and USBs.

Still, switching off secure boot, but booting in UEFI mode is an option then, isn’t it ?

Now as early as in the posting #4 in this thread:

Actually there is a difference between non-secure-boot (still UEFI) and legacy-boot !

If the OP booted in legacy-boot mode on a UEFI system - is there anything good that could be expected from that ?

On Mon 25 Mar 2013 09:16:01 PM CDT, ratzi wrote:

I have a question.

I think that I’ve learned that booting from the openSUSE installer DVD
in UEFI mode was possible already using the openSUSE 12.1 64 Bit
installer DVD.
No need for legacy booting already then.

UEFI booting has been around well before openSUSE 12.1 via ELILO…

Then came secure boot, and the prohibition of booting from CDs and DVDs
and USBs.

Still, switching off secure boot, but booting in UEFI mode is an option
then, isn’t it ?

AFAIK, yes, but don’t have windows 8 to confirm…

Now as early as in the posting #4 in this thread:

HeikoGer;2539244 Wrote:
> The laptop does not give you a boot option to boot from USB or DVD
> unless you switch to legacy mode.

Actually there is a difference between non-secure-boot (still UEFI) and
legacy-boot !

If the OP booted in legacy-boot mode on a UEFI system - is there
anything good that could be expected from that ?

Only from openSUSE 12.3 can it co-exist (if it doesn’t work then a
bug should be raised) with secure boot and running a signed kernel,
drivers etc.

Legacy booting != UEFI booting two completely different methods, so no
nothing good comes out of this scenario…


Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 12.3 (x86_64) Kernel 3.7.10-1.1-desktop
up 16:30, 3 users, load average: 0.02, 0.05, 0.07
CPU Intel® i5 CPU M520@2.40GHz | GPU Intel® Ironlake Mobile

You know programming in C, don’t you :wink:

Thank you.

Mike