UEFI dual boot windows, no oS selectable

Good evening,

I see a few threads involving the difficulty of getting a dual boot with windows 10 and oS. There is a recent thread which is solved covered my first set of install problems. I was gratefully helped this similar problem by diogenes_ on the IRC channel where he guided me through making a multiboot USB disk to overcome issues with my system. I have oS 42.3 installed sucessfully in shared partitions and mounted the /boot/efi (on second attempt, admitedly). However I cannot select oS upon boot up, I only default boot into Windows. I have seen many online documents to just use easyUEFI to fix the problem. However I am unsure what to do within the programme as I do not want to ruin my current windows install, even if it is backed up.

I can add new entry to my NVMe0 disk, where I can then select “Linux or other OS” & the /boot/efi. When browse for file to mount I can see the following


Within the opensuse tree is the following:


What do I select, my gut says grub64.efi ? Are their further steps after selecting one of the above.

This install has been very difficut to when I installed oS on my last laptop, though admittetly that was not in dual boot mode so I could use the whole hard disk. It was suggested that it is the lenovo laptop that I am using is being a *******, which is most likely as I have never had such issues before.

Some other info
System → Lenovo thinkpad X1 carbon 2017, secure boot disabled, UEFI only boot (CM disabled), bit locker encryption disabled, Windows 10

Any advice would be greatly appreciated. If there is another thread similar to this I would also be willing to read it would be great also, I like to learn as I fix through these problems :slight_smile:

So there is no BIOS option to select the boot order?

If you select the efi file and boot into openSUSE, as root user wat is the output from the command;

efibootmgr -v

I wonder if the efi default is set to the HDD rather than a specific efi file… This can be tweaked with the efibootmgr command, but some efi nvram setups default to windows or a hdd.

Hello Malcom,

Nope, I just boot straight to windows, I also should add that I moved Windows boot manager to the bottom of the boot list, but doesnt do much if it is th eonly boot option.

I took a jump with my gut and selected the grubx64.efi and added it. It worked sucessfully so I now have the oS menu to select what to boot into to. Now however when I select oS it just boots into a blank screen… so fixed one issue and onto the next, I cannot access the command line using ctrl+alt+f2. I can still boot into windows.

My apologies for not trusting my gut and using grubx64.efi my issues are now in a confused post, perhaps there is still something wrong in a config file…

All working now :slight_smile: Sucessfully dual booted and can post from my fresh oS install.

My apologies again for a nonsense thread. I will mark it solved.

… no threads are nonsense when someone is trying to get help to solve a problem.

Glad to hear you are up and running, and thanks for coming back to report.

With that list of files, “shim.efi” is the best choice. It is the one that works with secure-boot enabled (or with it disabled). You could also use “grubx64.efi” but that would only work if secure-boot is disabled.