UEFI Boot openSUSE 12.3 with ASUS M5A99FX

I have struggled and succeeded to create this and have all the details of how to do it. I t would seem that this is best added as a blog or an article but I can not find out how to add to these areas. If anyone can point me in the right direction then I will add this help others

Installation of openSUSE 12.3 on Asus M5A99FX Pro R2.0 under UEFI I already had a 12.3 installation but there were problems with the motherboard an MSI and one of the hard disks, a Maxtor 250GB. I decided to make a new machine and transfer the old software and data. The new machine as to be
Motherboard - Asus M5A99FX Pro R2.0
Graphics – Asus HD 6450
Memory – 8 GB Kingston KHX16C9B1RK2/8X (2 x 4GB)
Hard disks- Intel SSD (180GB) 2 x WD 1TB (to be used partly as a Raid 10)
Like the old machine it was to be used as a office machine and web development with a little multimedia stuff.
After the assembly the nightmare started. Firstly the USB key with the DVD image failed to get past the checking repositories with the message that it could not find the repositories. Burnt a DVD with the same result. Then thought to use the KDE live on both DVD and USB (USB created with Rufus on a windows machine and defined as UEFI. Both these failed after a while with message that it could not find the boot device. Then success with network install burnt onto a USB key.
But on reboot – it wouldn’t, so back to square one – several times until I found one of the articlaes addressing this Booting openSUSE on UEFI BIOS with ELILO and Grub2 and Installation on M5A99FX Mobo. Then I managed to get a proper UEFI installation at least I thought so. Installation was
sda1 – FAT /EFI partition
sda2 – Ext4 SWAP
sda3 – Ext4 /
sda4 – Ext4 /srv
sdb1 – Ext2 /boot (500MB)
sdb2 – Raid
sdb3 - Ext4 /var
sdc1 – Raid
sdc2 – Ext4 /usr/local
sdc3 – Ext4 /tmp
md127 - Raid /home
Rebooted and it worked so rebooted under old Maxtor and copied over the files and rebooted. Result – text on the top left of the screen GRUB with flashing cursor but no response to the keyboard. Looked at UEFI boot screen and there was no UEFI drive. The INTEL drive had reverted to a non-UEFI drive.
Then using the Booting from openSUSE doc (on openSUSE) and a little thought managed to get it all back together as follows

  • Put in the USB ‘Install openSUSE from Network’

  • Booted the USB key and on appearance of Grub hit the “E” key

  • Then F2 to go to the Grub commands

  • At Grub: ls (to find out the hard disk layout)

  • Grub: set root=(hd7,gpt1)

  • Grub: linuxefi /boot/vmlinuz root=/dev/sd3 ro

  • Grub: initrdefi /boot/initrd

  • Grub: boot

Miraculously my original system re-appeared but still needed work
Using openSUSE:UEFI - openSUSE I managed to do the necessary

  • efibootmgr – v (to find out what was installed

  • efibootmgr -c -L “openSUSE” -l ‘\EFI\opensuse\grubx64.efi’ (to recreate the efi boot partition)

Under YAST I examined the boot loader which as in error as it was pointing to the part2 not 3, so changed that.
Rebooted, checked in the UEFI BIOS and there was the INTEL drive marked as UEFI and it worked!
A real lot of hassle for a small change and I do not have the courage to change the boot to a secure boot as this seems a step too far.

Thanks for posting. I’ll reread your post later, so might have another comment at that time.

Before changing to secure-boot, you would have to install the secure boot component for opensuse. Perhaps you did. It would create a file “/boot/efi/EFI/opensuse/shim.efi”.

In any case, I’m not sure that there is any real advantage from using secure-boot, so just keep doing things the way that you are.

Just a few comments, now that I have more time to read this post.

The online instructions for using a USB say to hit F4, and tell the installer to search for repos on hard drives. Since 12.3, that no longer works for me. If I try that, I get a failure to find repos. Instead, I need to directly select “install” on the boot screen.

That’s not something I have experienced. Perhaps it’s an oddity of ASUS systems.

For my box, whether to use UEFI or legacy MBR is a global option that affects everything. There is no setting for particular disks.

In any case, I’m glad you have it working. I appreciate your posting, and I hope that helps others.

My note to other people – at present there is a lot of variation between different implementations of UEFI, so you might experience something different. Let’s hope this all settles down within a couple of years.

I only used the F4 to get to the Grub prompt and to see if I could get the installation to work. For the unsuccessful installation I used “Install”
Anyway it is still working though I found that changing the parameters of the mobo to performance or power saving caused the installation to fail