udev problem

Buggered up my system (opensuse 11.4 + tumbleweed) today!

I updated the udev packages from the tumbleweed repo - which also updated the 2 x aaa base packaged. The aaa base packages caused a minor problem elsewhere and I rolled these back.

This has knacked undev - so when I boot (which works fine) the keyboard and mouse is frozen and does not respond. Any ideas how I can access my system to roll back the udev packages?

Many thanks

Have you tried
Boot to Level 3, then Yast and More…

It may not work, but worth a go

On 06/17/2011 08:36 PM, dth2 wrote:
> Any ideas how I can access my
> system to roll back the udev packages?

easiest: restore from pre-“Buggered up” backup…


maybe: disable all but the standard repos and then do something_like this:

zypper clean -a
zypper ref
zypper dup

but, get someone else confirm those incantations and/or read my caveat,


Thanks for posting.

My system is set to boot to init 5. How can I stop it from loading the desktop and stop at init 3 - so I can use yast2 to to roll-back the udev packages.

I thought the guide shows that:


If level 3 doesn’t work I know a way you can do it with the install DVD

You are a star caf4926.

Thanks worked a treat. Once I was able to get to init3 (with your help) it was a 2 minute job to fix the problem.

Easy when you know how.

We do our best
Happy it worked :smiley:

On 06/17/2011 10:36 PM, dth2 wrote:
> Easy when you know how.

oh wow, i’m really sorry i missed the easy way! sorry!!