udev issues with device permissions


I am sure this question was asked many times before, but I am at a loss with the following. I am running SLED 10 SP2 Kernel I have configured a usb camera (QuickCam Pro 4000) by compiling the kernel with pwc driver for it. The camera works great and all is good, however I am having some issues with permissions for /dev/video0 device. When my machine boots the permissions are set for /dev/video0 to crw- — — 1 username, video, 81,0. I need them to be crw- rw- — 1,username, video, 81,0. I can change these permissions manually with chmod 660 once logged in, but when I reboot the machine the permissions are reverted back to 600.

I read that udev is what controls this in 2.6.x kernels, however after spending few hours reading about it I cannot make this work. I have made the following in udev per various posts on different blogs/forums but to no avail. Is there a way to do this another way? I even tried /etc/init.d/boot.local and added chmod 660 /dev/vidoe0 but still no go. Any help is greatly appreciated. Thank you.

Cheers, Swimming Penguin

KERNEL==“video*”, NAME="%k", GROUP=“video” SYMLINK+=“video”, MODE=“0660”, OPTIONS=“last_rule”

I also modified the following under 50-udev-default.rules


SUBSYSTEM==“video4linux”, GROUP=“video”
SUBSYSTEM==“graphics” GROUP=“video”
KERNEL==“vtx*”, NAME="%k", GROUP=“video”
KERNEL==“vbi*”, NAME="%k", GROUP=“video”
KERNEL==“winradio*”, NAME="%k", GROUP=“video”
KERNEL==“vttuner*”, NAME="%k", GROUP=“video”
KERNEL==“nvidia*”, NAME="%k", GROUP=“video”
KERNEL==“nvidiactl*”, NAME="%k", GROUP=“video”
KERNEL==“video0”, SYMLINK+=“video”, GROUP=“video”, MODE=“0666”, OPTIONS=“last_rule”
KERNEL==“radio0”, SYMLINK+=“radio”

Udevtest shows the following that will be done however nothing happens when box is rebooted. Permissions are still 600.

udevtest /class/video4linux/video0

main: looking at device ‘/class/video4linux/video0’ from subsystem ‘video4linux’
udev_rules_get_name: add symlink ‘video’
udev_rules_get_name: rule applied, ‘video0’ becomes ‘video0’
create_node: creating device node ‘/dev/video0’, major = ‘81’, minor = ‘0’, mode = ‘0660’, uid = ‘0’, gid = ‘33’
create_node: creating symlink ‘/dev/video’ to ‘video0’