Uclibc and diet libc incompatibilities

I recently added the gettext function to my code but Uclibc has no gettext function. I tried finding the correct library without success. What should I link to and how?

I was also using obstacks but diet libc does not have obstack.h. Why not use malloc? Because it’s much easier to use an obstack to allocate and copy one char at a time from a config file and as I’m going to use a variety of structs for linked trees and lists it would make freeing the memory much easier. Now I could implement obstacks myself (they don’t seem to complicated,) but I wanted your advice.

PS: Your thread
has some dead links.

Why do you need l10n in something targeted at embedded platforms (as is implied by uClibc and dietlibc)?

arvidjaar wrote:
> Why do you need l10n in something targeted at embedded platforms (as is
> implied by uClibc and dietlibc)?

Are you saying ‘foreigners’ shouldn’t use devices with embedded
computers? So Frenchmen can’t drive cars etc etc?

Well said, but acctually I thought that the gettext functions allow translation of your program to other languages and that they were independent of the device so long as it’t software was POSIX compliant.

I don’t think that was said or implied. I also don’t think that would be the case. From having looked at the respectives sites, it makes me wonder where you got uClibc and dietlibc. With uClibc the INSTALL doc says to compile, from the looks of it, you have to compile the kernel to it http://www.uclibc.org/downloads/INSTALL With dietlibc you can compile programs against it http://www.fefe.de/dietlibc/FAQ.txt Happy compiling. :slight_smile:

I got uclibc from the open SUSE repo:


I downloaded diet and installed/compiled it with make.

I then tried to compile my program using the respective wrappers (the case for the commands is incorrect,)

diet gcc -pipe in.c

gcc-uclibc -pipe in.c

Yes, I guessed that, but it looks that way and it’s fun to tease them.:wink: