ubuntu user.. horrified by first login FREEZE

hi, im a 4 year ubuntu user… and i thought id give opensuse a try… and i installed… and it all went fine…

after the install on my first login… it just freezes
i can login fine with root… thats how im writing this right now
but i cant login with a normal user…

i deleted the user home directory contents and let it install new ones from the skel but still the same problem
i can login into twm or icewm but not gnome and thats what i want

why is this happening?

i have a dell inspiron 9400, 1.8 d/core… 2g ram…

i dont know whats going wrong? anyone to help me 2nite?

If you could share what version of openSUSE you installed, whether you are dual-booting with any other OS, your video card, etc., that would help with suggestions as to what you should do next.

Does /var/log/messages show any errors from the failed logins?

i found the solution elsewhere
a very strange problem but its to do with beagle…

i logged in via root and removed beagle completely and it worked fine… it was a permissions issue with beagle… id like to get beagle back and running, maybe its a 0day error that the suse devs will fix…

Thanks for the feedback puccaso!

It could be linked to this bug https://bugzilla.novell.com/show_bug.cgi?id=389656 they are working on.

Glad to read you sorted it!

Thanks for sharing your solution.

IMHO beagle is not worth the overhead it causes. One of the things that I do, during the install while reviewing the openSUSE software selection, is to remove beagle. My PCs are already old enough, … I don’t need beagle slowing my system down further. :slight_smile:

You probably picked up a lot of Linux stuff while using Ubuntu, … still, somethings are different on openSUSE, and in case it might be of help, here is a link to a top level description of some openSUSE Linux concepts:
Concepts - openSUSE

> id like to get beagle back and running

imho beagle is a hound that ain’t worth shooting…so don’t let it
breath (or start)…


Yep, even though Beagle has its uses for some, I find it more than I need. I prefer the extra speed. I am counted with the group that unistalls Beagle from a system right away.

I am glad your issues was fixed by deleting Beagle. I was afraid you would have all sorts of problems with a video card. This was an easy fix!

Same here. The first thing I do after an install is to delete beagle and install Google desktop.

Can an op or something bump this post up? I had this same issue and was almost ready to remove Suse all together, I cannot believe this is what the problem was. Solution worked though.

Could be an idea to create a sticky (pitfalls installing version xx) in the install category.

Glad you found the post before you chucked openSUSE! :wink:


I highly recommend you install the findutils-locate package. It blows Beagle out of the water for speed and stability.

On 07/03/2008 andrewd18 wrote:
> I highly recommend you install the findutils-locate package. It blows
> Beagle out of the water for speed and stability.

But it doesn’t search file content.
Actually I liked beagle on 10.3 (for the first time), and I still don’t have problems on 11 on my laptop. My desktop freezes regularly though when Beagle starts. The only difference is I have beagle for Firefox installed on the desktop… Hm…


Quoting myself,

@Oldcpu : You have a very good sticky with openSUSE 11 installation notes (I don’t dare add to it as to keep it clean).

Would you mind adding the reiserfs and beagle issues to it? Good info to have I would think :wink:


I’m not aware of a reiserfs issue.

As for beagle, its very much a personal thing. Many users don’t mind the initial performance hit from beagle, and claim after the first few days (weeks? months? ) of beagle indexing, the performance hit is small. Hence I don’t feel comfortable recommending in a stickie for users to remove beagle.

Well, it’s not so much the performance hit I’m referring to - it’s freezing of a system that seems to happen. Sometimes the system locks up for a couple of seconds, some report they need to force power off and cold boot.

An example post : keyboard stops working randomly - openSUSE Forums (have a look at comment #6)
and Is it normal for Suse 11.0 to freeze - openSUSE Forums

For now, I’m not sure if the reiserfs issue is linked to using Beagle or if it’s a separate issue.
some reports : https://bugzilla.novell.com/show_bug.cgi?id=396166

Does anyone know why suse installs this stupid cronjob that completely
reindexes all KDE and SuSE Documentation ON EVERY DAY? This freezes my
whole PC and is for sure responsible for evil reputation of beagle. As
anyone cares about searching daily accurate Docs with beagle?!?!

First thing I do is removing this damn cronjob and volia: after once
indexing all files beagle is barely noticeable! But kerry is a pain.
Just using beagle-query.

Hi Marco,

It this is true you might make a good case by reporting it as bug/enhancement over at opensuse.org?