Ubuntu 10.10 Netbook Remix

Ubuntu 10.10 seems to have troubles with cdroms…I used Ubuntu 8.04 lts and 10.04 lts with no cdrom issues.
10.10 does not show my CDROM/DVD USB device in ‘Places’ and I cannot get it’s UUID number via ROOT terminal , yet I did Remastersys backup of entire system, opened the Remastersys folder, right clicked the custom.iso file and burnt it using Brasero, which proves it is working on 10.10 but just not showing an icon. Inserting media of any kind does not open the Nautilus folder, yet other USB devices show immediately (USB sticks and USB harddrive appear instantly).

The CDROM/DVD USb device works in Windows on a different machine and I also attached a USB harddrive with Windows XP to my netbook which 10.10 is installed on, and the USB CDROM/DVD device shows up fine.
I tried mounting the device in Ubuntu 10.10, but I’m not that great at understanding commands, and the hundreds of different commands other people tried across the web don’t work. When I type dmesg the USB CDROM shows up as this :-

1605.179588] scsi 7:0:0:0: CD-ROM HL-DT-ST DVDRAM GSA-4084N KQ09 PQ: 0 ANSI: 0
1605.742588] sr0: scsi3-mmc drive: 24x/24x writer dvd-ram cd/rw xa/form2 cdda tray
1605.743306] sr 7:0:0:0: Attached scsi CD-ROM sr0

Also typing this below showed my device:-
ls /dev/disk/by-id -lah
lrwxrwxrwx 1 root root 9 2010-11-10 09:42 usb-HL-DT-ST_DVDRAM_GSA-4084N-0:0 → …/…/sr0

but typing this only displayed my internal HDD:-
ls /dev/disk/by-uuid -lah

drwxr-xr-x 2 root root 80 2010-11-10 09:15 .
drwxr-xr-x 5 root root 100 2010-11-10 09:15 …
lrwxrwxrwx 1 root root 10 2010-11-10 09:15 420CDBE80CDBD54F → …/…/sda1
lrwxrwxrwx 1 root root 10 2010-11-10 09:15 4c593da0-46c2-4dff-b389-a443d87792e5 → …/…/sda2

My USB CDROM/DVD device installed Ubuntu 10.10 just perfect, but then it disappeared some time without me noticing. Reinstallation does not help, the device still won’t appear…It doesn’t show up in fstab or mtab either.

What Ubuntu 10.10 needs is a CDROM detection and installation software program…in a .deb file, so it can be downloaded, installed and opened like a normal program. If Windows has been able to detect CDROM’s since the 1990’s I can’t see why Ubuntu suddenly has problems… And people shouldn’t have to be subjected to a crash course in programming to add devices. Ubuntu is extremely user-unfriendly. Wifi is another issue with Ubuntu that seems to be problematic and is easy as 123 on Windows…no wonder Linux is still an underground operating system.