Two sound cards

I have notebook with intel sound card and external usb card.

In openSUSE 10.3 (32 bit) with my old notebook worked everything fine, but now I change notebook and openSUSE 11 (64 bit) and can’t get external card to work.

In Yast I can only see intel card.

In 10.3 it worked when I add snd-usb-audio manualy and set it as primary card.

In opensuse 11 I add snd-usb-audio manualy, but test sound works only if it isn’t primary card.

When I set it as primary card it doesn’t work. When I try speaker-test, I get error

speaker-test 1.0.16

Playback device is default
Stream parameters are 48000Hz, S16_LE, 1 channels
Using 16 octaves of pink noise
ALSA lib confmisc.c:768:(parse_card) cannot find card '0'
ALSA lib conf.c:3513:(_snd_config_evaluate) function snd_func_card_driver returned error: není souborem ani adresářem
ALSA lib confmisc.c:392:(snd_func_concat) error evaluating strings
ALSA lib conf.c:3513:(_snd_config_evaluate) function snd_func_concat returned error: není souborem ani adresářem
ALSA lib confmisc.c:1251:(snd_func_refer) error evaluating name
ALSA lib conf.c:3513:(_snd_config_evaluate) function snd_func_refer returned error: není souborem ani adresářem
ALSA lib conf.c:3985:(snd_config_expand) Evaluate error: není souborem ani adresářem
ALSA lib pcm.c:2144:(snd_pcm_open_noupdate) Unknown PCM default
Playback open error: -2,není souborem ani adresářem

Test sound in yast also doesn’t work.

you have to add some options to /etc/modprobe.d/sound

options snd slots=snd-usb-audio,snd-hda-intel
# u1Nb.ec6beonotd8:82801I (ICH9 Family) HD Audio Controller
alias snd-card-1 snd-hda-intel
# uniq.unknown_key:USB Audio
alias snd-card-0 snd-usb-audio
options snd-usb-audio index=0 device_setup=0x09

Thanks for sharing your solution.

Out of curiosity, what USB sound device do you own?