Two small KDE related issues


Every time I try to clear ‘recently used documents’ within the kmenu nothing happens, i.e. the list is not cleared, until I reboot or log out and back in again. It’s an old issue but thought I’d just ask if there are some fix for this. There is another small flaw on my system as well which is with refreshing the content displayed in a directory using dolphin (and possibly other file-viewers/apps). For instance, if I unpack a tar/rar/zip package I have to manually refresh dolphin for having it display the new extracted folder.

I thought perhaps these issues could be related?

Any ideas?



I am using KDE4.5.3 and for dolphin, I didin’t get this kind of bug and neither for the kmenu. They have been fixed. :slight_smile:

OpenSuSE 11.2, KDE 4.3.5

Yes, you might want to consider upgrading to KDE4.4.x

Install KDE4.4 in openSUSE 11.2

The dolphin update bug showed up with KDE4.3 and is fixed with KDE4.4.x
The Kmenu - > recent documents problem also showed up with KDE4.3.x series … don’t know if it is fixed since I have recent documents off since it first showed.


I am probably going to update KDE but haven’t decided which version to choose, 4.4.x or 4.5.x

Any suggestions based on general merits/drawbacks is welcome

I seem to have the same problems still.

I upgraded to 4.5.4 just now, mainly because I wanted a more capable AmaroK which I now have. But these two other issues still persists. Could there be some settings/config files I could look into to try and solve them?

You upgraded, but did you restart your desktop yet? (Sorry if obvious).

Yes I did. I also cleaned the tmp folder before I restarted.

Maybe this config got carried through ~/.kde4/share/config/kickoffrc (and the problem config lies within)

You could rename it and restart…

Alright, thanks I’ll try that.

FWIW, similar thread (with opposite problem if that makes sense :)) here:

Suse 11.3 Kickoff Recently Used category

Hello again Deano!

I have the line ‘recently used’ in kickoffrc, and closing recently used apps works fine. However, to clear recently used docs I have to click it (clear doc…) logout and back in again and the list is cleared.

I tried to use konqueror instead of dolphin to see how the refresh worked then, but it was the same. I have to manually refresh konqueror to have it show for instance a recent extracted folder.

I have KDE 4.5.4 and I assure you that I don’t have these 2 problems. Weird though…

Just a note regarding the kde upgrade. I noticed just now that all the custom created widget on an additional panel I have on my desktop has changed position as if viewed in a mirror. Gimp which used to be far left is now far right, and so on:)

Well, this is a fairly recent installation and I didn’t have any of these problems on my previous OpenSuSE 11.2 install either:). That was a 32bit install and I am now on 64bit, perhaps it could be something regarding 64bit? All the hardware is the same as before.

That said, I remember having had these issues earlier.

I don’t think, I am on a 64 bits installation. But I have one thing differentthan you and I already suggested to you to do so : I am on openSUSE 11.3. :wink:

No not now, perhaps later:)

You could try this command DaaX if you are unsure of which arch you are on: uname -a

Don’t worry F_Sauce, I know exactly on wich arch I am on. :wink:

[QUOTEDon’t worry F_Sauce, I know exactly on wich arch I am on. [/QUOTE]

Cheers :slight_smile: