two questions

Hey all, not sure if this is the best place to put it or not, so feel free to move it if you need to, sorry for any inconvenience. I have 2 questions.

The first is I can’t seem to install software. By that I mean I can get into the installer, choose the software and click install, and it installs, but when I go to look for the software its not there. For example, I tried to download wine. I clicked it, and installed it, it went through the installation process, then automatically closed (no window saying installation complete) then when I go to try and install a program with wine (COD4 in this case) I can’t fine wine-anywhere. its not in the applications, not in the pop up menu to open with this program, etc. its like this with all software I try to install, updates, or otherwise

Second question i guess is more media though I think its linked to the first one, when I try to play a movie on DVD I get this message: No URI handler implemented for “DVD” from what I can find it suggests I need to download codecs for it, but Im not sure what codecs, and the codecs I did find it wont let me install due to previous problem.

Thanks for your time.

The problem is not where you posted. The problem is your title.

You need to summarize the specifics of a problem in your title. The experts in our forum want to focus on the area they know best, and answering a question that says “Two questions” is NOT what they want to do.

So if you have 2 questions you should start 2 threads, with a different more relevant subject in each.

I’m not a believe in point and click. Here is a guide with some hints on software installation.
openSUSE software installation hints - openSUSE Forums

To see if it is installed, query the rpm database for it. You can do that by typing:

rpm -q wine

or go to YaST > Software > Software Management and search for wine.

To find where wine is located type:

which wine


whereis wine

To execute wine … Lets say you have an MS-Windows program called “autostitch.exe” in the directory /home/patriot2010/pan. To run the program type:

wine /home/patriot2010/pan/autostitch.exe

To play a DVD you need libdvdcss (which provides the needed decryption).

You can install that by copying and pasting and running in a terminal with root permissions the following 3 commands:

zypper ar videolan
zypper install libdvdcss
zypper rr videolan

sorry about that, will keep it in mind next time

I found wine using that search function, but can’t seem to get it to run and can’t find it at all in the software management.

I tried downloading the codec manually like you suggested and it gave me a message that cannot access installation media and to check whether the server is accessible or not.

libdvdcss is NOT a codec. Its a decryption package. There is guidance on codecs here: Multi-media and Restricted Format Installation Guide - openSUSE Forums

Reference your error message, note you need to have internet running when you send that command. Please copy and paste from the terminal used, the EXACT command you used. I am suspicious of a syntax error.

Note in the command:

zypper ar videolan

between “/11.2/” and “videolan” is a space.

If it showed up with “rpm -q wine”, then its there in software management. I think you need to search again.

What is the name of the MS windows executable you are trying to run? What directory is this executable located?

ok i looked again and did find wine under software management, sry bout that was looking for the wrong thing, it just wont initialize. what I am trying to do is install COD4MW on the machine using my DVD drive. as far as installing the software, I couldn’t remember what exactly the message said so I re ran it.

david@linux-aiek:~> su
linux-aiek:/home/david # zypper ar Index of /pub/vlc/SuSE/11.2/ videolan
Adding repository ‘videolan’ [done]
Repository named ‘videolan’ already exists. Please use another alias.
linux-aiek:/home/david # install libdvdcss
install: missing destination file operand after libdvdcss' Try install --help’ for more information.
linux-aiek:/home/david # zypper install libdvdcss
Download (curl) error for ‘’:
Error code: Connection failed
Error message: Couldn’t resolve host ‘

Abort, retry, ignore? [a/r/i/?] (a): ^Clinux-aiek:/home/david # ^C
linux-aiek:/home/david #

i mistyped the second command the first time as you can see but finally got it right and this is what I got. notice, I never did get to zypper rr videolan

I quoted the error. it does not like the alias I used. So type these 4 lines:

zypper rr videolan
zypper ar videolan
zypper install libdvdcss
zypper rr videolan

clearly, the URL is WRONG there.

It is NOT ! Look again at the exact commands I gave.

I think you should post in our games area Games - openSUSE Forums for that with a title like:

Need help to run COD4MW under wine

To play a DVD you need libdvdcss (which provides the needed decryption).

You can install that by copying and pasting and running in a terminal with root permissions the following 3 commands:

zypper ar videolan
zypper install libdvdcss
zypper rr videolan


these are the exact commands you gave me. if it is not .org what is it then?

I tried the 4 new commands you gave me, and it said it installed ok, however it is still giving me the same message when I put in the DVD.

PLEASE try to be more careful. You were using It is NOT It is OK ??

I have to go to bed now as its very late.

Good luck.

Probably because that is NOT a video DVD. I thought you asked for help with a videoDVD (ie asked for help to play a movie on a DVD). I think that is a GAME dvd.

Please note my advise as to where you should post for help in setting up an MS windows game in Linux.

The only game I play in Linux is chess, and I do NOT use windows programs for that.

sorry for the confusion here, I was asking you for help with a videoDVD. the game DVD was a seperate issue, the issue with wine, this was the issue getting a MOVIE DVD to work. I believe, though that the issues were related, in fact I was just using wine as more of an example. the programs will install-but will not initiate. wine is installed but will not “initiate” and now, I have the libdvdcss installed, but it also, will not initiate, every time I try to play my movie, I get the same URI error.

I see these people trying to help you and their doing it by good means, introducing you to the command line. It can be tough but not impossible.

To see if wine is installed use the command

cnf wine

It will tell you the location of the wine program. On the other hand, in order to install programs with wine you will use

wine filename.exe

and unless you are in the folder where the file is contained, you will need to specify a path.

For instance, to install world of warcraft from /home/user/download

cd /home/user/download
and then
wine InstallWoW.exe

On the other hand if you are attempting to run the program installed via wine from the command line you need to specify its path inside the wine environment which will be something like

wine C(colon)\program files\someoddfolder\program.exe (and its not like windows where you can type a pathname with one forwardslash, for wine for some reason, at least from my experience, you will have to enter two forward slashes and you may encounter some issues with whitespace like Program Files vs. ProgramFiles and this is something I haven’t yet resolved although I’m told you shouldn’t experience this problem; further note that in the example I ommitted the colon symbol after C: because they were posting smilies as it did with the slashes so i just put (colon)).

and it will then execute the program.

A lot of programs don’t show a menu folder when you install them, instead just open up your terminal and try to type the program name (or better yet read the documentation for the program and get the precise terminal commands).

the cnf command used before is command-not-found and all it does is search for a package appropriate to execute the command you are trying to issue.

As for you media codecs, if you open up install software via

the start button>computer>install software
and enter your root password for access,
just search for codecs.

Most of these will be gstreamer, or libdvdcss I think is the other one. Search for DVD as well and you will come up on some dvd codecs. To play dvd’s you will require the ability to read them, which is what the codecs do they encrypt or decrypt to the appropriate format.

you might also require some other codec types to play various media formats if the default or popular OS ones aren’t working. On Ubuntu these were gstreamer proprietary codecs and programs like MPlayer came with their own codec libraries which were more successful in opening various media types which are encoded via geographic region or according to content. If you search for mplayer on the web, and it may be a defunct project now I haven’t used it in some two years or so but it was very good at what it did then, you will find on its homepage the appropriate links for installing codec libraries and default libraries with the GUI environment.

these links should help

WineHQ - Run Windows applications on Linux, BSD, Solaris and Mac OS X
MPlayer - The Movie Player

thanks, and I tried installing mplayer as well, with the same results. it will “install” but will not run.

Typically, when an app misbehaves when being launched, a way to get more information, is to launch it from a terminal. Do this for mplayer. Type:


I suspect you have encountered a packaging mistake, where mplayer’s config may be default trying to run vdpau output video mode where vdpau is not setup on your system. But until we see the error we will not know.

What application are you using to try and play the movie ? If I may, I recommend the application vlc for this.