two questions: 1 video card and 1 sound

Hi all,

I just installed OpenSUSE on my box;
I have a radeon 4890
and soundblaster audigy SE

First question: can I just download the .run package from ATI and run it?
IF not what do I need to do.

Second my sound card appears to be installed but makes absolutely no sound. where should I start. I noticed that pulse sound control was disabled in the install.

Any help is appreciated!

Go to Yast - Hardware - Sound
Your device should be listed, choose it and edit and walk thru the settings to a finish.

ATI drivers info
ATI - openSUSE

openSUSE Graphic Card Practical Theory Guide for Users - openSUSE Forums

I will try those; I have been having trouble with the sound in several distros.

NOTE: My ATI card has hdmi which the sound configure app wants to put as device 0. when I tried to remove it from OpenSUSE I lost sound in Win7. it appears that sound configs in linux affect Windows settings also.

Just set your system to use device 1
I do that on my box.

how do I set which device the system uses? I did not see that in YaST

From the mixer in the panel](

In yast I can actually set my pci card to device 0 or device 1
By default it would be device 1 and the nvida on-board device 0
Either way I switch which I use from kmix (kde)
Gnome will have something similar if you use gnome

So you should be able to leave the ati as 0
but use the mixer to select soundblaster

Sorry I forgot to mention that I am using KDE. I will try to set the default device with mix.

I am having trouble with the graphics driver. for a few reasons:

  1. repository links not working
  2. I have downloaded the driver from ATI,but when I click it (per the link you gave me) it opens in KWrite, which seems different than the directions indicate.

OK - Just stop and wait further instructions

First I want to check the output from a terminal of

zypper lr -d

here is the output

brihno@linux-1z8s:~> zypper lr -d

| Alias | Name | Enabled | Refresh | Priority | Type | URI | Service

1 | openSUSE 11.2-0 | openSUSE 11.2-0 | Yes | No | 99 | yast2 | cd:/// |
2 | repo-debug | openSUSE-11.2-Debug | No | Yes | 99 | NONE | Index of /debug/distribution/11.2/repo/oss |
3 | repo-non-oss | openSUSE-11.2-Non-Oss | Yes | Yes | 99 | yast2 | Index of /distribution/11.2/repo/non-oss |
4 | repo-oss | openSUSE-11.2-Oss | Yes | Yes | 99 | yast2 | Index of /distribution/11.2/repo/oss |
5 | repo-source | openSUSE-11.2-Source | No | Yes | 99 | NONE | Index of /source/distribution/11.2/repo/oss |
6 | repo-update | openSUSE-11.2-Update | Yes | Yes | 99 | rpm-md | Index of /update/11.2 |

Open a terminal and become su -

Become su in Terminal - HowTo - openSUSE Forums

Do the following there:

zypper ref


zypper up

If there was a kernel update, reboot as requested

the response was:
brihno@linux-1z8s:~> su
linux-1z8s:/home/brihno # zypper ref
Repository ‘openSUSE-11.2-Non-Oss’ is up to date.
Repository ‘openSUSE-11.2-Oss’ is up to date.
Repository ‘openSUSE-11.2-Update’ is up to date.
All repositories have been refreshed.
linux-1z8s:/home/brihno # zypper up
Loading repository data…
Reading installed packages…

Nothing to do.

Though I have noticed that when I run update a lot of errors are thrown; it’s almost as if the servers are down or something

Post result of this from a regular terminal

uname -a

Here it is:

linux-1z8s:/home/brihno # uname -a
Linux linux-1z8s #1 SMP PREEMPT 2009-10-26 15:49:03 +0100 i686 athlon i386 GNU/Linux

Something is not right.
Current kernel is:

You are browsing the net OK? With this PC?

yes, but I did have to modify resolv.conf; for some reason it keeps getting my router as DNS server when I install. perhaps I did not make the changes correctly?

I’m going to get you to rename that file, not delete it, so you can always put it back.
su terminal

mv /etc/resolv.conf /etc/resolv.conf.bak


see if zypper lu gives a different result
Hopefully you will still have a connection or another PC to reply with

If not to get it back

mv /etc/resolv.conf.bak /etc/resolv.conf

after changing the file name I have no connection, the zypper lu command fails. If you want to see the output I will have to rename the file to resolv.conf (I am on a different pc now)

I renamed the file to resolv.conf and now have a connection again.

Better put it back the way it was.

You may have to go to Yast and change your network settings from auto and put in the DNS settings for your connection