Two problems with today's forced-manual update

  1. (trivial)
Location 'http://download.opensuse.org/update/leap/15.3/sle/x86_64/util-linux-2.36.2-150300.4.20.1_150300.4.2
3.1.x86_64.drpm' is temporarily unaccessible.

that would be “inaccessible” :slight_smile:

  1. “WARNING: Nouveau DRI/3D driver selected” that driver has been the bane of my existence on Linux since someone decided that it’s license was so much more wonderful than the one used by NVidia that they should force it down our throats, even if it didn’t fully work. Eventually, they did get it to work, but now:

In order to install 'Mesa-dri-nouveau', you must agree to terms of the following license agreement:

WARNING: Nouveau DRI/3D driver selected.

This driver is considered experimental and is known to have issues with
applications that use certain 3D acceleration features of modern
NVIDIA hardware.

Symptoms include application crashes or lockups & crashes of your system's
graphical environment. Older Hardware and less demanding applications may work
just fine and do benefit from the Hardware acceleration features this driver
offers over software emulation.

Use of this driver is especially not recommended for use with the KDE Desktop
Environment or Qt-based Applications.

The hardware vendor potentially offers alternative drivers.

Please click "Accept" if you accept the risks that may come with the
installation of this driver. Choose "Cancel"  to prevent installation
of the driver and use software emulation instead.
**Do you agree with the terms of the license? [yes/no] (no):**

and saying “no” aborts the update. How about permanently banning Nouveau?

Search function: https://forums.opensuse.org/showthread.php/574472-Nouveau-DRI-3D-driver-without-NVIDIA?highlight=Nouveau+DRI%2F3D

You are running Leap 15.4, but that repo is for 15.3. Something wrong here?

The problem is that I downloaded 15.4 and forgot that I’m still looking for the Installation Round Tuit. :slight_smile: Beit 15.4 or 15.3, it’s still a problem. I guess this will encourage me to go find that Tuit.

https://status.opensuse.org/

Maybe a problem with the servers?

Thanks. Were I a Nouveau geek, I could probably follow that thread. I’m now retired and want to play with my camera instead of researching driver intricacies. :frowning: I’m mostly disgusted that the Nouveau folks would release such software, especially given that they managed to get distros to install it by default when it could not handle dual monitors. If this does destabilize my system, I will once again have to learn how to disable the thing, install the nVidia driver and fiddle the X system config files. It happens not to be how I enjoy spending my time. :wink:

zypper rm Mesa-dri-nouveau
zypper al Mesa-dri-nouveau

ought to fix you up just fine if you have no NVidia GPU. During installation you can deselect it in detailed package selection, and prevent a multitude of other distasteful things from being installed, by deselecting install recommended packages. You can continue the KISS philosophy by including solver.onlyRequires = true in /etc/zypp/zypp.conf.

AFAIK, Mesa-dri-nouveau can be thwarted in same manner if using NVidia’s proprietary drivers. I can’t be sure because I never use non-FOSS drivers on any of my own hardware, so don’t know if they require it. I doubt it though.

Starting to read your first post above, I stumbled inti the 15.3 repo in a 15.4 system and then stopped reading and reported this to you.

By incidence I now read the rest of the post. Did you see https://forums.opensuse.org/showthread.php/574472-Nouveau-DRI-3D-driver-without-NVIDIA?

This is the way I installed all my openSUSE Tumbleweed systems.

But beware that deselecting “install recommended packages” at install time might produce a system that will need “some refinement” in order to get the system one might want/need.

Regards

susejunky

Back in the early days of Linux, I was willing to do a lot of installation refinements. But I’m retired now and it’s no longer how I enjoy spending my time. :frowning: And, if I disable the Nouveau driver entirely, I’ll have to go re-learn how to get the nVidia drivers installed.

lspci says:

NVIDIA Corporation GP107 [GeForce GTX 1050 Ti]