Two opensuse 15.2 not seeing each other but other devices (MS Win, Android, Mac) see them

Hi,
I have 2 OpenSuse 15.2 linux (newlly installed), for a reason I don’t understand, I can connect to them (ssh, ping, samba) from other machines (MS WIndows, Android, Mac) but between the two, they cannot communicate.
Anybody can advice where I should start checking why this happens?

Thanks,

A.

What have you tried that doesn’t work?

How are they connected? In particular, could there be a routing problem?

I have tested disabling the firewall but no avail. I also configure the card to “public” and allow various firewall services but they still cannot see each other.

Both Linux machines can access the internet. They both can see the router but they cannot see each other. If it is a routing problem, shoudn’t they also have problem accessing the internet?

When you say that these two Linux hosts cannot see each other, what do you mean? I assume that the respective firewalls are blocking access to the services perhaps?

On each host, check

firewall-cmd --list-all

I expect that you’ll need to allow certain services that are currently being blocked.

For reference, one of my Linux hosts…

~> firewall-cmd --list-all
public (active)
  target: default
  icmp-block-inversion: no
  interfaces: eth1
  sources: 
  services: ssh samba nfs ftp mdns ws-discovery
  ports: 427/udp
  protocols: 
  masquerade: no
  forward-ports: 
  source-ports: 
  icmp-blocks: 
  rich rules: 

You can also port scan from each of the respective hosts

nmap <IP address>

*You may need to install nmap first

None of the command: ping, ssh, http… find the other Linux. What surprises me is that if I do ping, ssh, http… to those Linux box, they respond without any problem.


public (active)
  target: default
  icmp-block-inversion: no
  interfaces: eth1 wlan0
  sources: 
  services: dhcpv6-client nfs nfs3 ssh http samba
  ports: 22/tcp 53/udp
  protocols: 
  masquerade: no
  forward-ports: 
  source-ports: 
  icmp-blocks: 
  rich rules: 

This is what comes out


Nmap scan report for 192.168.2.18
Host is up.
All 1000 scanned ports on 192.168.2.18 are filtered

It seems like it knows that it is up but cannot access to it. But then, why other device (other OS) can?

Thanks.

Another thought: Without knowing any of the details about your LAN/WLAN…speculating that if using wifi connected Linux hosts, check that the wireless router does not have client isolation enabled, as that will effectively stop wifi-connected clients from talking to each other. Turn it off if applicable.

One of the Linux is wired connected and the other one is wireless. If the problem is at the wireless router, shouldn’t I have my issue only with the wireless Linux box?

It all depends on how your router is configured. Such a feature can firewall between wired and wireless hosts as well. What brand/model?

Just in case this is of interest…

If you have more than one router employed, please share your network topology.

That’s exactly what I have with my current setup. It uses minimal configuration and works without any glitches since installation: Network Management With Systemd - openSUSE Wiki

…and this is entirely unrelated to the OP’s issue.