Two laptops not getting connected through simple wire network

Hi all!

I have two Dell 1564 laptops with same specs. All I want to do is to connect them trough a cross over cable. I have Opensuse 11.2 installed on both of them. My problem is simply that whatever i do, they are not getting connected at all. Here are steps i have done:

  1. Connected both of them with crossover cable.
  2. Giving them static IPs of same network. i.e. 192.168.1.2 & 192.168.1.3.
  3. Disabled my firewall through Yast.

When i ping them, i get “Destination host unreachable”. One more thing which is significant here is that in Yast network setting, my Ethernet controller is being shown as “RTL8102e Family PCI-E Fast Ethernet NIC (Not connected)” although i do set the IP of it. In network connection, I see the message: “not connected to any network”.

The strange thing is that I have connected two PCs with cross over cable with same opensuse dvd and with same settings and they work just fine. Am i missing anything specific to laptops?

Any help would be appreciated.

If your 11.2 installations have not been updated, then you are a victim of the
routing bug that was in the DVDs for that release. What do you see with the command


/sbin/route -n

Does the resulting table have routing for the other PC?

Thanks for the reply.

routing table has following entries:

192.168.1.0 0.0.0.0 255.255.255.0 U 0 0 0 eth0
169.254.0.0 0.0.0.0 255.255.0.0 U 0 0 0 eth0
127.0.0.0 0.0.0.0 255.0.0.0 U 0 0 0 lo

On 08/22/2010 12:36 PM, jewelthief29 wrote:
>
> Thanks for the reply.
>
> routing table has following entries:
>
> 192.168.1.0 0.0.0.0 255.255.255.0 U 0 0 0 eth0
> 169.254.0.0 0.0.0.0 255.255.0.0 U 0 0 0 eth0
> 127.0.0.0 0.0.0.0 255.0.0.0 U 0 0 0 lo

Rule 1 should handle the routing for this case, but just in case you might try


sudo /sbin/route add default gw 192.168.1.3

for the one with IP of 192.168.1.2, and the reverse on the other one.

The other thing to check is the contents of the file
/etc/sysconfig/network/ifcfg-eth0. On one of my systems with a static IP, I have
the following:

BROADCAST=’’
ETHTOOL_OPTIONS=’’
IPADDR=‘192.168.1.51/24’
NAME=’’
NETWORK=’’
USERCONTROL=‘no’
BOOTPROTO=‘static’
MTU=’’
REMOTE_IPADDR=’’
STARTMODE=‘auto’
PREFIXLEN=‘24’

On 2010-08-22, jewelthief29 <jewelthief29@no-mx.forums.opensuse.org> wrote:
> I have two Dell 1564 laptops with same specs. All I want to do is to
> connect them trough a cross over cable. I have Opensuse 11.2 installed
> on both of them. My problem is simply that whatever i do, they are not
> getting connected at all. Here are steps i have done:
>
> 1. Connected both of them with crossover cable.
> 2. Giving them static IPs of same network. i.e. 192.168.1.2 &
> 192.168.1.3.
> 3. Disabled my firewall through Yast.

You know there is a standard for self-attribution of an IP, in case your
machine doesn’t find a DHCP server? Windows has this on by default, Mac too
I’m told. They get a 192.169.254.x address if I rememeber it well. I presume
this soft will configure all parameters for you. Saves time and cuts down on
typo’s and forgotten configs. Just leave your machine in DHCP.
Find a server? Get an IP. No server? Give yourself one.

You can install this for Linux. Can’t remember what it’s called. Try
zeroconf.

mmm… just looked it up in yast, take a look at kde4-kdnssd.


When in doubt, use brute force.
– Ken Thompson

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

The address range, just in case it matters, is 169.254.x.x. In this case
it should not matter since that is for people who cannot configure IP
addresses on their own and using a private range should be fine if setup
properly. In fact in the reply to Larry Finger earlier jewelthief29
showed that the box had a 169.254.x.x address previously so this is
apparently working somewhat already (before the static IP address was set).

Based on what has been said so far my first concern is why the device
shows as down. If the cables are plugged in properly then the connection
should show as up which makes me think that, perhaps, the cable is not
really a crossover cable at all. Let’s get the following:

ip route #(same info as route -n mostly, but a better command imo)
ip addr
ip -s link

Good luck.

On 08/22/2010 12:45 PM, Rikishi42 wrote:
> On 2010-08-22, jewelthief29 <jewelthief29@no-mx.forums.opensuse.org> wrote:
>> I have two Dell 1564 laptops with same specs. All I want to do is to
>> connect them trough a cross over cable. I have Opensuse 11.2 installed
>> on both of them. My problem is simply that whatever i do, they are not
>> getting connected at all. Here are steps i have done:
>>
>> 1. Connected both of them with crossover cable.
>> 2. Giving them static IPs of same network. i.e. 192.168.1.2 &
>> 192.168.1.3.
>> 3. Disabled my firewall through Yast.
>
> You know there is a standard for self-attribution of an IP, in case your
> machine doesn’t find a DHCP server? Windows has this on by default, Mac too
> I’m told. They get a 192.169.254.x address if I rememeber it well. I presume
> this soft will configure all parameters for you. Saves time and cuts down on
> typo’s and forgotten configs. Just leave your machine in DHCP.
> Find a server? Get an IP. No server? Give yourself one.
>
> You can install this for Linux. Can’t remember what it’s called. Try
> zeroconf.
>
> mmm… just looked it up in yast, take a look at kde4-kdnssd.
>
>
>
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2.0.15 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org/

iQIcBAEBAgAGBQJMccyjAAoJEF+XTK08PnB5uNwP/1r8z8nWVhciuiTXSQXFdMYh
rXFfmFRhhlB0JkewEKVxXWersM6WW/FW9nbnQ/AjpvvAsmo1FjHdylHmAiZ6EFy4
1w4leddSjk/sdblCZ2NlPU82DMBJFuJNNRyRPyFM8tdnzd4VmIW35Fx2vQBqFYoI
nBqFjMCErgtilxlRdtFhKRvn2YCjXoc7NujGYPEYgZyZJGE8Rsn6/Tx/FeN+bo5+
B9Vkw7szKxtmV5Vy8uAP3A92AgccM8SKCWrp0gROoZ5Kr/K5I24VSPQGQziKPmGu
1EZJTl3lKNzmAZfCDWHYOBZJmehDC41As9v89MR4vJYNCIntJ0idTJbTW3lM6jOK
MErQDo6wCJzsCK9SiL/czu7bBApr7oZ2j5lHc/6ZOO+kzVisMd96ObUZxGkKDiY1
tyIhAP2XY6xsmxS+LoYa3DXg4EOxhXYDk/gh/r4qxOkEwaUfzyTAsD8UWtCd+Dkk
XO40efG0XHKi+YZ2OzMkcM9A7knrtoqwzuuOMWC2s2Ts4egyXk2dRNRPnfORaDEQ
vN3ILqHluU7aSkdwZ7UzPQ6qXwKkJMBA1HIWnXr5GLEFu7GxWL39XKKAqogpebLC
Fcbdyxip2ZY/I9/4hFtHC2NQ8qMcVMUL0f9iRWKxHlxLpdblkW3IWRJxyPoKtGGc
oiaJiWBIrqbF7u/VW0BQ
=un9r
-----END PGP SIGNATURE-----