Two languages in application menu

As described in the title, I have two different languages in my KDE application menu: English and my native one.

Also, when I use “System > Yast” and type my root password, I get the Yast Control Center in my native language as well.

Yet when I log into my root account, everything is as it should be: in English.

Question: which configuration file should I remove in my regular user account to reset everything?

I do believe this is an old plasma 5 bug that needs to be fixed upstream (if someone reported it I don’t have a kde account)
happens in both 42.1 and 42.2
https://forums.opensuse.org/showthread.php/511353-After-leap-upgrade-my-system-has-a-mixed-language
https://forums.opensuse.org/showthread.php/520802-Discussion-thread-for-42-2-Release-Candidate-2-(RC2)?p=2799560#post2799560

the fix is to remove all except American English (you need to add English if not you’ll get the language defined by the region you selected) in plasma 5’s preferred languages setting

Configure Desktop - Regional Settings - Language

Note that each user (including root) can have their own language preferences. Also the system language preference can be set in Yast

nope it’s a bug yet to be fixed (maybe it is in 5.9)


the only fix is not to have multiple languages or set your localization to US
as you can see home is localized trash is not
plasma system settings is a mix-up of both languages

Removing the other option does fix the language for when I use Yast.

It doesn’t seem to fix the application menu. And, yes, I did log out and logged back in. Running

kbuildsycoca5 --noincremental

as suggested by the thread you linked, fixed it.

Thanks!

I know. But apparently you cannot set multilingual preferences. Or rather you can but it’s useless. Any time you change something and hit apply, it puts up a message that those changes will take effect the next time you log in. You cannot change the language during a session.

But this bug is annoying. I had English as primary and it somehow used the second language in the list. No wonder I couldn’t figure this out.

That is the most confusing thing: the mix-up of languages seems almost random.

I think plasma 5 does some caching
I got 2 languages for a day or two after removing the other one
and yes it was random what bothered me most was the mix in the start menu