Two issues with Thinkpad T23

I’m fairly new to openSUSE but ran Ubuntu for many years. I have an ongoing sound issue and a new issue with my PCMCIA network card.

I have the standard sound issue, where it won’t resume after hibernation. I turned off hibernation, which did fix the issue for awhile. One of the updates seems to have broken my sound again, so that it does not work even after rebooting. I’ve tried reinstalling the drivers but nothing. It’s an Intel sound card built into the motherboard. Any ideas? It does show up when running modprobe, just doesn’t give me any sound.

As for the network card, I was using an Orinoco silver card. It worked fine under Ubuntu, but I can’t get it to work under SUSE. I’ve researched and found the drivers but no change. It shows up in hardware info but nothing on the activity lights. Same with my Orinoco gold card. I have an old linksys card that will work, but I think it’s starting to fail. Any ideas on where to go next with this? Thanks for the help.

AFTER you get your sound working again, if this happens, try to restart the alsa sound driver with:

su -c 'rcalsasound restart'

When users state they re-install the sound driver it always leaves me with a bit of trepidation, for if one’s repositories are not setup conservatively one can end up with all sorts of weird drivers …

Can you show us what you got (with the sound not working) ?

Please provide the information suggested to be provided in the 2nd half of our multimedia stickie: Welcome to multimedia sub-area

… I’ll quote this for you to make it easier:

please post in this “multimedia” sub-forum, providing in your post the following information:


and select the SHARE/UPLOAD option and after the script finishes it will give you a URL to pass to the support personnel. Please post here the output URL/website-address that gives. Just the URL/website-address. You may need to run that script twice (the first time with root permissions to update in the /usr/sbin directory, and the second time to get the URL).
Note if for some reason that gives you no website/url/address then run it with the no-upload option:

/usr/sbin/ --no-upload

and post the file /etc/alsa-info.txt it creates to and press SUBMIT on that site and again post here the URL/website-address it provides.

… some clarification on running the script “” … when you run:


you should get something like this (if it asks for an update, select NO):](

followed by this (select the SHARE/UPLOAD option):](

followed by this (its quickest if you simply select ‘NO’ to seeing the output - you will see it on the web page) :](

followed by this (where in RED is the URL).](

Just post the URL you get (similar to the RED URL in my example, but yours will be different).

Again, if you can not get that, then run this with the no upload option:

/usr/sbin/ --no-upload

which will create the file /tmp/alsa-info.txt.  Copy that file and paste it on []( and press submit. That will give you a URL address. Please post that URL here.

Also provide the following:

  • in a terminal, or xterm, or konsole, type: rpm -qa ‘alsa#and post output here
  • in a terminal, or xterm, or konsole, type: rpm -qa ‘pulse#and post output here
  • in a terminal, or xterm, or konsole, type: rpm -q libasound2 #and post output here
  • in a terminal, or xterm, or konsole, type: uname -a #and post output here
  • for openSUSE-11.1 or earlier, in a terminal, or xterm, or konsole, type: cat /etc/modprobe.d/sound #and post output here
  • for openSUSE-11.2 or newer, in a terminal, or xterm, or konsole, type: cat /etc/modprobe.d/50-sound.conf #and post output here

Note I am on vacation in Asia (1/3 of the world away from where I live) with random to no internet access, so I may be VERY slow in replying. … Sorry 'bout that.

Thanks for your very clear instructions! I appreciate the help. Currently, sound is down in both Windows and Linux. I’ve seen this happen before, when it is turned off in Linux. I ran su -c ‘rcalsasound restart’ but it did not help. Here are my results:


rpm -qa ‘alsa


rpm -qa ‘pulse


rpm -q libasound2


uname -a

Linux #1 SMP 2010-08-20 19:21:29 +0200 i686 i686 i386 GNU/Linux

cat /etc/modprobe.d/50-sound.conf

options snd slots=snd-intel8x0

W60f.orZ_Nj_FOo6:ThinkPad A30/A30p/T23

alias snd-card-0 snd-intel8x0

Thanks for those details. All looks well there.

I recommend you read this page: CS4299 - ThinkWiki

In particular, note this:

No sound after suspending to RAM

Fortunately it is not necessary to remove and reinsert the snd-intel8x0 module. Simply mute and unmute all the mixer controls using alsamixer or amixer. You might want to create the following script and run it after your suspend commands:

mixers="Master PCM CD"
for mixer in $mixers ; do
  amixer sset $mixer mute
  amixer sset $mixer unmute

Other mixers you might want to add are Line (Line in on the laptop) and Aux (Line in on the docking station). Note that the case of the mixer names is important ("Master" not "master").