two app issues after updating to kde4.3

Just updated to kde 4.3 on 11.1 and everying seems ok except for two things.

  1. pidgin 2.5.1 will not run. I reinstalled it just in case after the update but for some reason it will not run. Seg faults.

  2. Newest amarok will not retrieve album art. When I click to retrieve missing album art it does nothing.

Anyone have these issues with kde 4.3 or have a fix?

Not sure about pidgin, but I have read around that lots of people are having problems with album art (also lyrics, track listings etc).

Seems to be because lots of these apps (not just amarok) use Amazon API’s to get this info, and Amazon have recently changed the rules for accessing those API’s.

Amazon API crackdown neuters book apps • The Register

Well that sucks, hopfully the devs for amarok can find a solution. I guess ill have to do without album art for a while.

jaybott wrote:

> Well that sucks, hopfully the devs for amarok can
find a solution. I
> guess ill have to do without album art for a
actually in the Amaork git they started using instead of Amazon, but there are issues
which are being worked on and it does not appear to
be as flexible as it was using Amazon.

openSuse 11.1 x64bit, KDE4.x Factory, Opera weekly

Works quite well. Covers not found automatically, mostly still can be found manually.

Maybe the devs at can tell you the reason of the switch from amazon to My guess: money.

That and the fact that each and every install of amarok would need its own Amazon API key - now thats a big incentive not to use it…

I’m building a new package to fix again the lyrics thing. If it works I will submitreq it shortly.
I will see what I can do about the covers.

But guys, you REALLY REALLY REALLY should stop doing this. Let me make this clear:

  • openSUSE 11.2 is in version freeze. No new versions of programs are added anymore.
  • Factory has Amarok 2.1.1, and that will be the version available in 11.2… even if a 2.1.2 is released before.
  • If you don’t report these bugs at openSUSE 11.2 will be released with an Amarok unable to fetch lyrics or covers. THIS FORUM ISN’T THE PLACE TO REPORT BUGS.

PS. I submit the fixes to Factory/KDE:KDE4:Factory:Desktop… if someone wants them for previous openSUSE versions open a bug report (and/or contact Packman).

For sure, but this isn’t a bug - Amarok works just fine. It always did. I’d have thought that the Amarok devs are aware of this, as they would have got an email from Amazon telling them so (hopefully).

It is Amazon who broke (for whatever reason) the API that Amarok, and lots of other apps, used in good faith.

Anyway, an API that requires every end user who downloads your application to go and ask Amazon for a key (and register etc) which they then have to copy/paste into a dialogue box before the app functions properly, is not a good API to use for this purpose.

Fine for webapps though, only one key needed. Someone somewhere (can’t remember who) suggested making a proxy webapp using a single key that Amarok (et al) could use for olookups. Not sure how legal that would be though.

ok so now that that mystery has been solved, on to pidgin. What repo has a newer version of it since the kde one is always outdated? Im just going to try a newer version of it to see if that fixes it.

you can search it in webpin,



Thanks, I uninstalled it and tried a few different version from here. Still none of them work on my system. I must have some package or app installed that is causing it to crash??? Is there some dump or debug file I can look at to tell me why this thing will not run?