twm desktop reinstall

Hi,

the TWM desktop on openSUSE 12.1 GNOME 64bit does not work for me. I am not able to login to this desktop (login to gnome shell and icewm works OK).

I would like to reinstall TWM desktop, but I am not able to figure out which package needs to be removed or reinstalled.

Please, let me know how can I remove or reinstall TWM desktop.

twm is included in xorg. There is nothing to reinstall. I don’t know why you can not login … though I haven’t tried on a 64bit sytem yet. Make sure the file /usr/share/xsessions/twm.desktop exists.

Yes the file /usr/share/xsessions/twm.desktop exists and looks like that:
[Desktop Entry]
X-SuSE-translate=true
Encoding=UTF-8
Type=XSession
Exec=twm
TryExec=twm
Name=TWM
Comment=The Tab Window Manager

The problem is that immediately after login to the TWM (I can see short blink of the blue background) I am logout to the standard Login dialog. IceWM works without any problems.

Weird. It starts for me on the 32bit 12.1 I’m working on - I haven’t configured nor tested everything though (I’m slow).
Is there any info in your ~/.xsession-errors? I take it you’re using gdm? Try to kill gdm, login in console as root and type this:

export WINDOWMANAGER=twm
export WINDOW_MANAGER=twm
startx

It should normally start X with twm.

Yes …


/etc/X11/xim: Checking whether an input method should be started.
/etc/X11/xim: use GDM_LANG=en_US.utf8
sourcing /etc/sysconfig/language to get the value of INPUT_METHOD
INPUT_METHOD is not set or empty (no user selected input method).
Trying to start a default input method for the locale en_US.utf8 ...
There is no default input method for the current locale.
Dummy input method "none" (do not use any fancy input method by default)
gnome-keyring-daemon: insufficient process capabilities, unsecure memory might get used
gnome-keyring-daemon: insufficient process capabilities, unsecure memory might get used
gnome-keyring-daemon: insufficient process capabilities, unsecure memory might get used
gnome-keyring-daemon: insufficient process capabilities, unsecure memory might get used
GNOME_KEYRING_CONTROL=/tmp/keyring-n8GI1p
GPG_AGENT_INFO=/tmp/keyring-n8GI1p/gpg:0:1
GNOME_KEYRING_CONTROL=/tmp/keyring-n8GI1p
GPG_AGENT_INFO=/tmp/keyring-n8GI1p/gpg:0:1
SSH_AUTH_SOCK=/tmp/keyring-n8GI1p/ssh
GNOME_KEYRING_CONTROL=/tmp/keyring-n8GI1p
GPG_AGENT_INFO=/tmp/keyring-n8GI1p/gpg:0:1
SSH_AUTH_SOCK=/tmp/keyring-n8GI1p/ssh
GNOME_KEYRING_CONTROL=/tmp/keyring-n8GI1p
GPG_AGENT_INFO=/tmp/keyring-n8GI1p/gpg:0:1
SSH_AUTH_SOCK=/tmp/keyring-n8GI1p/ssh
**
ERROR:gsd-printer.c:1165:on_pdi_bus_acquired: assertion failed: (npn_registration_id > 0)

(gnome-settings-daemon:3435): Gdk-CRITICAL **: gdk_x11_keymap_get_entries_for_keyval: assertion `keyval != 0' failed

(gnome-settings-daemon:3435): color-plugin-WARNING **: failed to get edid: unable to get EDID for output
Initializing tracker-miner-fs...
Initializing tracker-store...
Tracker-Message: Setting up monitor for changes to config file:'/home/kva/.config/tracker/tracker-store.cfg'
Tracker-Message: Setting up monitor for changes to config file:'/home/kva/.config/tracker/tracker-store.cfg'
Tracker-Message: Setting up monitor for changes to config file:'/home/kva/.config/tracker/tracker-miner-fs.cfg'
Starting log:
  File:'/home/kva/.local/share/tracker/tracker-store.log'
Starting log:
  File:'/home/kva/.local/share/tracker/tracker-miner-fs.log'

** (gsynaptics-init:3516): WARNING **: Using synclient
Failed to play sound: File or data not found
(nautilus:3536): Tracker-DEBUG: Initializing tracker-tags extension

Initializing nautilus-open-terminal extension
Initializing nautilus-gdu extension
Initializing nautilus-dropbox 0.6.9
** Message: applet now removed from the notification area
      JS LOG: GNOME Shell started at Mon Dec 05 2011 10:57:26 GMT+0100 (CET)

(gnome-shell:3502): folks-WARNING **: Error preparing persona store 'eds:1323074183.7443.5@think.think': Couldn't open address book ‘1323074183.7443.5@think.think’.

(gnome-shell:3502): folks-WARNING **: Error preparing persona store 'eds:1323074183.7443.8@think.think': Couldn't open address book ‘1323074183.7443.8@think.think’.

(gnome-shell:3502): folks-WARNING **: Error preparing persona store 'eds:1323074183.7443.7@think.think': Couldn't open address book ‘1323074183.7443.7@think.think’.

(gnome-shell:3502): folks-WARNING **: Error preparing persona store 'eds:1323074183.7443.6@think.think': Couldn't open address book ‘1323074183.7443.6@think.think’.
Window manager warning: CurrentTime used to choose focus window; focus window may not be correct.
Window manager warning: Got a request to focus the no_focus_window with a timestamp of 0.  This shouldn't happen!
** Message: applet now embedded in the notification area

(gnome-settings-daemon:3435): updates-plugin-WARNING **: Failed to get symlink: Error stating file '/run/udev/firmware-missing/intel-ucode/06-25-02': No such file or directory
lpstat: No destinations added.
Starting Dropbox...Dropbox isn't running!
Done!

I take it you’re using gdm? Try to kill gdm, login in console as root and type this:

export WINDOWMANAGER=twm
export WINDOW_MANAGER=twm
startx

It should normally start X with twm.

No, openSUSE 12.1 GNOME using xdm instead of gdm.

When I reproduce your steps to run TWM from console, I get the functional TWM desktop?!

I have installed NIVIDIA driver 290.xx (via openSUSE NVIDIA repo), too.

xdm? humm … I don’t know how the default xdm looks like. Mine doesn’t have a menu to select sessions but it’s my own xdm config that I use for ten years or so on any Linux and Unix. Anyway, I can log in in twm from xdm as well, basically the same way, by evaluating the WINDOW_MANAGER variable.
Is it not kdm?

Yes, twm is working. There might someting wrong in your system /etc/X11/xdm/Xsession or user .xsession or .xinitrc - whichever is used - or it’s using an older session file. I can not help that much, because my Xsession is quite different from the default.

It is not related.

That ~/.xsession-errors doesn’t say anything about twm. You should look at it just after twm failed and before logging in in Gnome. You could open a virtual console with CTRL-ALT-F2, rename or copy this file, get back to X by pressing CTRL-ALT-F7, log in in Gnome or icewm and take a look at the older .xsession-errors.