Twitter videos sound like Jabba the Hutt


Don’t know if I should post this in Multimedia or Internet, but here goes.

I’m using Firefox on OpenSUSE Leap 15.1, and Twitter videos have weird audio problems. All voices sound like Jabba the Hutt when he says “Bring me Solo and the wookie”. Anyone knows what’s going on here and how to fix this?


You’re probably lacking codecs. Packman installed?

And, please remove that signature. For obvious reasons.

Packman and codecs are all installed. For the record, here’s the script I use to setup my repos. And here’s the script that installs the extra stuff. It reads extra packages in this list. Everything multimedia works. Just audio on Twitter misbehaves.

Sorry to have offended you with my signature. It’s taken from GNU Fortune, by the way. I’ve changed it to my company’s website.

You did not offend a person, you probably forgot what you should have read in the Terms and Conditions of these forums:


Members who wish to post advertisements for any kind of good or service (free, paid, digital, or otherwise) must contact the openSUSE Forums staff for approval. Posted advertisements that have not received staff approval, whether or not an approval request has been made, will be removed and the member may be banned.

The staff of the openSUSE Forums reserve the right to determine what content is and is not acceptable under this policy. All staff decisions are final.

Thanks very much for helping me out with my signature, guys.


Now is there anyone who can actually answer the initial question ?

I never had problem with the sound of Twitter videos on firefox.

In the past, there was a time when Twitter videos would not play at all. But there was never a time where the video played but the sound was defective.

Do you have problems with sound from other sources (youtube videos, audio CDs, etc)?

FWIW, the audio issue you’re encountering is also described here…

Right, problem solved. The GoodTwitter plugin was misbehaving. Deactivating it solved the problem.

Glad it was a simple fix. :slight_smile: