twitter videos not playing in firefox

Hi everyone ! I have a problem with firefox, it used to work, but now twitter videos won’t play, it says “media format could not be played” or something similar. I have all restricted formats installed from the packman repos, gstreamer plugins ugly , gecko media player, etc. I really dont know what is the problem. Running Leap 42.2 here


~/> sudo rpm -qa gstreamer*
gstreamer-0_10-plugins-bad-0.10.23-187.1.x86_64
gstreamer-plugins-ugly-1.10.2-70.1.x86_64
gstreamer-0_10-lang-0.10.36-22.3.noarch
gstreamer-1.10.2-79.2.x86_64
gstreamer-0_10-plugins-ugly-32bit-0.10.19-17.3.x86_64
gstreamer-libnice-0.1.13-4.5.x86_64
gstreamer-plugins-good-lang-1.10.2-87.4.noarch
gstreamer-0_10-0.10.36-22.3.x86_64
gstreamer-0_10-plugins-ffmpeg-0.10.13-2000.2.x86_64
gstreamer-0_10-plugins-base-0.10.36-18.2.x86_64
gstreamer-0_10-plugins-bad-orig-addon-0.10.23-187.1.x86_64
gstreamer-0_10-plugins-ugly-0.10.19-17.3.x86_64
gstreamer-0_10-plugins-good-0.10.31-93.1.x86_64
gstreamer-0_10-plugin-gnomevfs-0.10.36-18.2.x86_64
gstreamer-plugins-qt-1.2.0-17.4.x86_64
gstreamer-0_10-plugins-ugly-orig-addon-0.10.19-17.2.x86_64
gstreamer-plugins-base-1.10.2-75.2.x86_64
gstreamer-plugins-farstream-0.2.8-1.5.x86_64
gstreamer-fluendo-mp3-21-2.1.x86_64
gstreamer-0_10-fluendo-mp3-21-2.1.x86_64
gstreamer-0_10-plugins-fluendo_mpegdemux-0.10.71-2.2.x86_64
gstreamer-plugins-good-1.10.2-87.4.x86_64
gstreamer-0_10-plugins-ugly-lang-0.10.19-17.3.noarch
gstreamer-0_10-plugins-fluendo_mpegmux-0.10.4-46.2.x86_64
gstreamer-0_10-plugins-base-lang-0.10.36-18.2.noarch
gstreamer-lang-1.10.2-79.2.noarch
gstreamer-0_10-plugins-good-extra-0.10.31-93.1.x86_64
gstreamer-0_10-plugin-esd-0.10.31-16.30.x86_64
gstreamer-plugins-bad-1.10.2-145.3.x86_64
gstreamer-plugins-ugly-32bit-1.8.3-1.2.x86_64
gstreamer-plugins-base-lang-1.10.2-75.2.noarch
gstreamer-plugins-bad-lang-1.10.2-145.3.noarch


~/> sudo rpm -qa | grep ffmpeg
gstreamer-0_10-plugins-ffmpeg-0.10.13-2000.2.x86_64
ffmpeg2theora-0.29-5.26.x86_64
ffmpeg-3.2-4.1.x86_64

It is not very interesting if you installed individual packages from Packman. You should do the “vendor switch to Packman”.

YaST > Software Management, then from the View menu choose Repositories. Then in the list of repos, select Packman. At right, above the list of Packages there is a line saying something like: Switch system packages to … Click on the underlined part and continue low-right.

lol! thank you very much it worked!! just one more question doing “switch system packages” is not the same as doing

zypper dup -r "repo" 

?
I 've being dealing with this playback issue for a long time seems that at some point it worked but I couldn’t figure how to get it back working again, thanks a lot.

Same difference different tool

As said. I offered the YaST version because IMHO it is easier to explain then

zypper dup --repo <repo-identification>

because then I have to explain how to find out what the actual is. Explaining to to

zypper lr -d

search for the Packman repo and use either the Number, or the Alias, or the Name …

But both are rather long stories to type (Sigh!). Specialy when you realize that this action is described all over the place