TwinView with Nvidia

Hi there,

I’ve had a look around and I’ve found quite a few posts on this topic, but no matter what I try, I can’t get this to work. This is the first time that I’ve given up on a problem and resorted to creating a new post.

I have a laptop (DFP-0) with a docking station and a monitor (DFP-2). I like to use the laptop screen as a second monitor with TwinView. This all worked fine until one day I moved everything into a different room and decided the laptop would go better to the right of the monitor. I managed to swap them around easily enough using Nvidia Settings, but then the panel and desktop icons appeared on the laptop screen rather than the monitor. Clicking on “Make this the primary display for the X screen” solves the problem but only until the next restart, even though I click on “Save to X Configuration File”. When I look at the file (/etc/X11/xorg.conf), it does indeed say “TwinViewXineramaInfoOrder” “DFP-2” and “nvidiaXineramaInfoOrder” “DFP-2”, which means that the monitor (DFP-2) should be the primary display, right? But then when I restart, the panel and desktop icons are back on the laptop screen, and if I go to Nvidia Settings, “Make this the primary display for the X screen” is unchecked again.

I tried changing everything back to how it was before with the laptop on the left, but the problem persisted. Now I don’t care which side it’s on, as long as it works! If the laptop’s set up to be on the right then there’s the additional problem that when I use the laptop away from the docking station, the panel doesn’t appear at all. In other words, when I want it on the monitor, it appears on the laptop screen, and when I want it on the laptop screen, it doesn’t appear at all!

I’ve tried modifying the contents of xorg.conf directly but with no success. I haven’t been brave enough to change very much as I’m scared of completely losing my GUI.

Here’s the “Screen” section of xorg.conf with the laptop set up to be on the left:

Section “Screen”
Identifier “Screen0”
Device “Device0”
Monitor “Monitor0”
DefaultDepth 24
Option “TwinView” “1”
Option “TwinViewXineramaInfoOrder” “DFP-2”
Option “Stereo” “0”
Option “nvidiaXineramaInfoOrder” “DFP-2”
Option “metamodes” “DFP-0: 1366x768_60 +0+0, DFP-2: 1920x1200_60 +1366+0; DFP-0: 1366x768_60 +0+0, DFP-2: nvidia-auto-select +1366+0; DFP-0: nvidia-auto-select +0+0, DFP-2: nvidia-auto-select +1366+0; DFP-0: 1366x768_60 +0+0; DFP-0: nvidia-auto-select +0+0”
SubSection “Display”
Depth 24

If the laptop is set up to be on the right, the long line reads:

Option         "metamodes" "DFP-0: 1366x768_60 +1920+0, DFP-2: 1920x1200_60 +0+0; DFP-0: 1366x768_60 +1920+0, DFP-2: nvidia-auto-select +0+0; DFP-0: nvidia-auto-select +1920+0, DFP-2: nvidia-auto-select +0+0; DFP-0: 1366x768_60 +0+0; DFP-0: nvidia-auto-select +0+0"

I would add a link to the whole file, but I can’t work out how.

Thanks in advance for any help!

I failed to see where you mention your openSUSE version or your Desktop being used. Using the most recent KDE desktop, up to 4.9 can help with this task but 4.8 is the most recent released with openSUSE 12.2, so tell us a bit more about your setup.

Thank You,

Sorry for the late reply. OpenSUSE 12.1 and KDE 4.7.2

And how or have you loaded the nVIDIA proprietary video driver? For TwinView and nVIDIA driver, I use the nvidia-settings application loaded from YaST, where you can also install their driver. It is also possible to install the very latest driver done the hard way. It does matter if you have a dual graphics setup with nVIDIA as there is another direction you must go if you have say Intel & nVIDIA video on the same PC. For links on nVIDIA have a look here:

Installing the nVIDIA Video Driver the Hard Way - Blogs - openSUSE Forums


LNVHW - Load NVIDIA (driver the) Hard Way from runlevel 3 - Version 1.46 - Blogs - openSUSE Forums

Thank You,

I’m afraid things are going from bad to worse…

I had loaded the nVIDIA driver using 1-click install. I saw that in your blog, you said to stay away from 1-click install, so I thought I’d try reloading it the repository way. After that, the only way that I could get a desktop at all was in failsafe mode.

I’m not sure exactly which video card model I have since lspci | grep VGA gives

01:00.0 VGA compatible controller: nVidia Corporation GF108 [Quadro NVS 4200M] (rev a1)

whereas I was expecting either GeForce 6xxx, GeForce FX 5xxx or GeForce 4xx/4xxx. Therefore, I’m not sure whether the driver should be x11-video-nvidia, x11-video-nvidiaG01 or x11-video-nvidiaG02, so I tried one after another, all in failsafe mode, but there was no change.

For some reason, /boot/grub/menu.lst has been modified. I’ve found that I need the boot option x11failsafe to get the desktop, but then only the laptop screen works, not the monitor. On top of that, the screen resolution is wrong, and when I open nvidia-settings, most of the options no longer appear, including all those relating to screen resolution and TwinView, and I get the following error message:

ERROR: NV-CONTROL extension not found on this Display.

ERROR: Unable to determine number of NVIDIA GPUs on ‘:0’.

ERROR: Unable to determine number of NVIDIA Frame Lock Devices on ‘:0’.

ERROR: Unable to determine number of NVIDIA VCSCs on ‘:0’.

I presume this is because of the boot option x11failsafe. I don’t know what the previous boot options were, but they seemed to work fine. Is there some way of recovering the older version of menu.lst? I have the files menu.lst~ and menu.lst.old, but they’ve both also been modified today and have the same options as menu.lst. This is possibly because I loaded x11-video-nvidia, x11-video-nvidiaG01 and x11-video-nvidiaG02, one after the other, and each time menu.lst got modified.

Well, you have tried lots of things it sounds like but basically you got two things to do out of three. 1) Remove the nVIDIA stuff x11-video-nvidiaG01 and x11-video-nvidiaG02 you find in YaST ; Software ; Software Management. Its possible to run YaST from terminal if you need to with the command: sudo /sbin/yast2. Then 2) To use the proprietary nVIDIA driver, follow my blog links already posted. OR 3) You must re-enable Kernel Mode Settings (KMS) a YaST ; System ; /etc/sysconfig Editor ; System ; Kernel ; NO_KMS_IN_INITRD=No (was Yes) and stop blacklisting the nouveau driver (remove the blacklist nouveau entry) from the file /etc/modprobe.d/nvidia.conf as root. This last step would allow you to (try) and use the open source video driver called nouveau after a restart which you should have used by default in a clean install (not an upgrade). The whole thing can be a problem when the open source nouveau driver does not work and the user messes up the installation of the proprietary nVIDIA driver. The 1-click process is intended to be simple, but it is too simple and may install the wrong driver. When you install the proprietary nVIDIA driver, their installer is way better in working with a wide variety nVIDIA cards. The open source version actually works with lots of nVIDIA cards, but not all. You as a user, have no idea about all of this and many Linux users are unsympathetic because nVIDIA chooses to not open up all of the info on how their video cards work and the nouveau driver, intended for nVIDIA cards, has been written without any assistance from nVIDIA. What a deal right?

Thank You,

Thank You,

Thanks for all your help.

In trying to solve what was a minor issue, I’ve only made things much worse than they were before. Now I just wish that I could get everything back the way it was. I’ve never done anything the hard way before, so I’m a bit apprehensive and worried I’ll just cause further problems.

Also, I don’t think the driver is the only problem since it previously worked more or less OK (TwinView, correct screen resolutions – the only problem was which screen was the primary display on startup) using the driver I’d got from 1-click install, whereas now, no matter whether I use x11-video-nvidia, x11-video-nvidiaG01 or x11-video-nvidiaG02, or whether I use 1-click install or the repository way, I have to boot using x11failsafe, the screen resolution is wrong, and only the laptop screen works. I found that the file I’d used to install the nVIDIA driver in the first place, when everything more or less worked, was still in my downloads folder, so I ran that, but it didn’t change anything. Surely if that worked OK before but doesn’t now, something else must have changed somewhere.

Before I try to install the driver the hard way, I’d just like to know if there’s any kind of system restore so that I can go back in case things go wrong, or if I can go back to how things were before I started trying to fix them.

By the way, when I click on My Computer, the information under ‘Display info’ seems to have changed. It now says:

Vendor:nVidia Corporation
2D driver:vesa

I’m sure ‘Model’ didn’t used to be blank, the 2D driver used to be nvidia, not vesa, and there used to be a 3D driver too. Any ideas what’s going on here?

Thanks again for your help, patience and understanding.