Twinview Second Monitor no Wallpaper

I’m running the latest versions of openSUSE and KDE with latest updates installed. I have an nVidia GTS 250 video card with two monitors hooked up.

Initially SUSE recognized my second monitor just fine. However, after installing nVidia’s own driver (to quiet the loud noise of the card’s fan on high) following these instructions, my monitor is only usable after I go into the nVidia X Server Settings (from terminal, as root: “nvidia-settings”) and configure it to TwinView.

All is well and good (I can move windows over to monitor 2), except that monitor 2 has no wallpaper (I’m new to KDE, does this mean that monitor has no desktop activity?) and the X Server configuration is not persistent. When I reboot I have to change the X Server settings back to get monitor 2 recognized again.

I tried looking for the X Server configuration file (xorg.conf, right?), in order to replace it with the edited version, but could not find it.

On Thu, 24 Feb 2011 13:06:01 +0530, pvtryan
<pvtryan@no-mx.forums.opensuse.org> wrote:

>
> I’m running the latest versions of openSUSE and KDE with latest updates
> installed. I have an nVidia GTS 250 video card with two monitors hooked
> up.
>
> Initially SUSE recognized my second monitor just fine. However, after
> installing nVidia’s own driver (to quiet the loud noise of the card’s
> fan on high) following ‘these instructions’
> (http://www.suse.de/~sndirsch/nvidia-installer-HOWTO.html), my monitor
> is only usable after I go into the nVidia X Server Settings (from
> terminal, as root: “nvidia-settings”) and configure it to TwinView.
>
> All is well and good (I can move windows over to monitor 2), except
> that monitor 2 has no wallpaper (I’m new to KDE, does this mean that
> monitor has no desktop activity?) and the X Server configuration is
> not persistent. When I reboot I have to change the X Server settings
> back to get monitor 2 recognized again.
>
> I tried looking for the X Server configuration file (xorg.conf,
> right?), in order to replace it with the edited version, but could not
> find it.
>

these days there is no single xorg.conf anymore; it has been split up into
different files under /etc/X11/xorg.conf.d, like 11-mouse.conf,
50-device.conf, 50-monitor.conf, etc. at present an existing xorg.conf
will still be recognized, but i don’t know for how long this will continue.

to make your nvidia configuration permanent, you’ll have to click on “Save
to X Configuration File,” under the “X Server Display Configuration” tab
in nvidia-settings. this shouldn’t be a problem since you already started
nvidia-settings as root. (to adjust settings for the running session, you
don’t have to be root; in order to make the changes permanent, i.e., write
them to xorg.conf, being root is required.)


phani.

After saving the X configuration file and rebooting, everything is working fine, including the wallpaper (desktop activity) on the second monitor. Thanks.