Twin Monitors on different cards?

Hi all,

I’ve got an ACER Veriton 7600GT, with an internal Intel 82865G, which drives the main monitor and a Radeon 9250 which drives a second monitor (on its first port).

The configuration seems to kill many live cds but not opensuse - that’s the good news.

The bad news is that, if I’ve understood this; Configuring graphics cards/Dual Head Mode - openSUSE, it should be detected and started in clone mode - it isn’t.

Running sax2 doesn’t help (and that’s the first thing in the XRandR instructions too.

I’ve yet to see my second monitor so much as flicker. Any ideas would be appreciated - I would like to see this working on the live cd before I commit to installing opensuse.

Thanks in advance for any help…

I have used two monitors a lot, but never two different video cards, one monitor each. Which openSUSE and desktop versions are you using? If you are using KDE, it does include a dual monitor application, though again, I have never tried to use different video cards. In KDE you go to Menu > Personnel Settings > Computer Administration > Display > Multiple Monitors. However, it does not sound like the second video card is being detected. Do you have any BIOS settings for this, have you checked? I do remember using one motherboard BIOS with built-in video that had a BIOS option to use both internal and add-in video cards, but I never tried to use it. I think it is worth a look on your part.

Thank You,

Along with openSUSE version, post the output of

/sbin/lspci -nnk

This should tell us what graphics cards are seen by system. Also, you could try

xrandr

to see what reported.

In addition to posting what deano_ferrai suggested, can you also copy and post into New - Pastie the content of /var/log/Xorg.0.log and /home/your-user-name/.xsession-errors and provide here the two URLs.

Also post here the output of:

cat /etc/SuSE-release
uname -a

Also post the output of running with root permissions:

sax2 -p

When you say you tried sax2 and it doesn’t help, did you run it from run level 3 (and NOT from X window) and exactly what arguments did you try? Did you try with root permissions things like

sax2 -r -c0 -d 0 -m 0=intel, -c1 -d 1 -m 1=radeon 

or combinations like that ? Note you should backup any functioning /etc/X11/xorg.conf file BEFORE trying that.

I assume you tried with root permissions:

man sax2

and read of the various sax2 options

Thanks for the replies.

This is a newly downloaded live cd…

>cat /etc/SuSE-release
openSUSE 11.2 (i586)
VERSION = 11.2

I assume the BIOS is OK as it all works under windoze.

>/sbin/lspci -nnk
00:00.0 Host bridge [0600]: Intel Corporation 82865G/PE/P DRAM Controller/Host-Hub Interface [8086:2570] (rev 02)
        Subsystem: Intel Corporation 82865G/PE/P DRAM Controller/Host-Hub Interface [8086:2570]                  
        Kernel driver in use: agpgart-intel                                                                      
00:02.0 VGA compatible controller [0300]: Intel Corporation 82865G Integrated Graphics Controller [8086:2572] (rev 02)
        Subsystem: Acer Incorporated [ALI] Device [1025:0031]                                                         
00:06.0 System peripheral [0880]: Intel Corporation 82865G/PE/P Processor to I/O Memory Interface [8086:2576] (rev 02)
00:1d.0 USB Controller [0c03]: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB UHCI Controller #1 [8086:24d2] (rev 02)  
        Subsystem: Acer Incorporated [ALI] Device [1025:0031]                                                         
        Kernel driver in use: uhci_hcd                                                                                
00:1d.1 USB Controller [0c03]: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB UHCI Controller #2 [8086:24d4] (rev 02)  
        Subsystem: Acer Incorporated [ALI] Device [1025:0031]                                                         
        Kernel driver in use: uhci_hcd
00:1d.2 USB Controller [0c03]: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB UHCI Controller #3 [8086:24d7] (rev 02)
        Subsystem: Acer Incorporated [ALI] Device [1025:0031]
        Kernel driver in use: uhci_hcd
00:1d.3 USB Controller [0c03]: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB UHCI Controller #4 [8086:24de] (rev 02)
        Subsystem: Acer Incorporated [ALI] Device [1025:0031]
        Kernel driver in use: uhci_hcd
00:1d.7 USB Controller [0c03]: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB2 EHCI Controller [8086:24dd] (rev 02)
        Subsystem: Acer Incorporated [ALI] Device [1025:0031]
        Kernel driver in use: ehci_hcd
00:1e.0 PCI bridge [0604]: Intel Corporation 82801 PCI Bridge [8086:244e] (rev c2)
00:1f.0 ISA bridge [0601]: Intel Corporation 82801EB/ER (ICH5/ICH5R) LPC Interface Bridge [8086:24d0] (rev 02)
00:1f.1 IDE interface [0101]: Intel Corporation 82801EB/ER (ICH5/ICH5R) IDE Controller [8086:24db] (rev 02)
        Subsystem: Acer Incorporated [ALI] Device [1025:0031]
        Kernel driver in use: ata_piix
00:1f.2 IDE interface [0101]: Intel Corporation 82801EB (ICH5) SATA Controller [8086:24d1] (rev 02)
        Subsystem: Acer Incorporated [ALI] Device [1025:0031]
        Kernel driver in use: ata_piix
00:1f.3 SMBus [0c05]: Intel Corporation 82801EB/ER (ICH5/ICH5R) SMBus Controller [8086:24d3] (rev 02)
        Subsystem: Acer Incorporated [ALI] Device [1025:0031]
        Kernel driver in use: i801_smbus
00:1f.5 Multimedia audio controller [0401]: Intel Corporation 82801EB/ER (ICH5/ICH5R) AC'97 Audio Controller [8086:24d5] (rev 02)
        Subsystem: Acer Incorporated [ALI] Device [1025:0031]
        Kernel driver in use: Intel ICH
01:00.0 VGA compatible controller [0300]: ATI Technologies Inc RV280 [Radeon 9200 PRO] [1002:5960] (rev 01)
        Subsystem: PC Partner Limited Device [174b:0250]
01:00.1 Display controller [0380]: ATI Technologies Inc RV280 [Radeon 9200 PRO] (Secondary) [1002:5940] (rev 01)
        Subsystem: PC Partner Limited Device [174b:0251]
01:01.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL-8169 Gigabit Ethernet [10ec:8169] (rev 10)
        Subsystem: Realtek Semiconductor Co., Ltd. RTL-8169 Gigabit Ethernet [10ec:8169]
        Kernel driver in use: r8169
01:0d.0 Ethernet controller [0200]: Broadcom Corporation NetXtreme BCM5705 Gigabit Ethernet [14e4:1653] (rev 03)
        Subsystem: Acer Incorporated [ALI] Device [1025:004a]
        Kernel driver in use: tg3

> xrandr
Screen 0: minimum 320 x 200, current 1280 x 1024, maximum 2048 x 2048
VGA connected 1280x1024+0+0 (normal left inverted right x axis y axis) 338mm x 270mm
   1280x1024      60.0*+   75.0
   1152x864       75.0
   1024x768       75.0     70.1     60.0
   832x624        74.6
   800x600        72.2     75.0     60.3     56.2
   640x480        75.0     72.8     66.7     59.9
   720x400        70.1

# sax2 -p
Chip: 0  is -> Intel 865 G                      00:02:0 0x8086 0x2572 PCI intel
Chip: 1  is -> ATI RV280 5960                   01:00:0 0x1002 0x5960 AGP radeon

Also, /var/log/Xorg.0.log at
#947997 - Pastie](http://pastie.org/947997)

My attempts to use sax2 were just based on the info in the link I gave,i.e. I just ran it.

I tried it at level 3 - no difference.

I tried “sax2 -r -c0 -d 0 -m 0=intel, -c1 -d 1 -m 1=radeon” - the only noticeable difference was that the config screen then said ‘initialised in clone mode’ (as opposed to ‘no configuration available’) or some such (didn’t copy the exact words).

Still not a flicker from the second monitor.

Sorry, no, I haven’t read the ‘man sax2’. This is a live cd testing exercise, just to see if linux, in general, and opensuse, in particular, has the potential to be a usable main OS for me. I have a limited amount of time to spend on it.

I was impressed with pclinuxos on my netbook but that live cd will only start in ‘safe mode’ (vesa) on my desktop.

Thanks again for the help.

Ok, note it MUST be run at “run level 3” and any attempts you made in run level 5 are probably invalid and you should not draw ANY conclusions from them.

did you try the xrandr command after having tried booting to X after running that sax2 command ?

Also, my understanding is there was supposed to be a space between the “c” and the “0”. I’m bad as my syntax was wrong (I rushed out the post before running to work). Anyway … that may not have made a difference but it adds doubt which is not helpful.

How about checking to see if your second monitor can be displayed at all ?

Try something like:

sax2 -r -c 1 -d 1 -m 1=radeon

or

sax2 -r -c 1 -d 1 -m 1=vesa

or

sax2 -r -c 1 -d 1 -m 1=fbdev

the idea being to see if you can get the 2nd monitor working by itself, and then once that is confirmed, start trying to get both working.

Note that the radeon and radeonhd drivers as packaged with openSUSE-11.2 were not so good. Many users updated those with drivers from X11 : Xorg, and some are just waiting for openSUSE-11.3.

You could try an openSUSE-11.3 milestone6 liveCD, but if you do, you should also copy from the factory repository (for 11.3) the 6 sax2 rpms, and then copy them to ram after booting to the liveCD, and install them into ram, so that you can then use sax2 as a wizard to help you configure 11.3. Unfortunately in 11.3 sax2 is not included on the liveCD.

Thanks oldcpu.

xrandr after sax2 has the same output as before.

Running ‘sax2 -r -c 1 -d 1 -m 1=vesa’ (for example) in level 3 says;

could not open DBM file: /var/cache/sax/files/config.new

several times and then fails. Refers me to /var/log/SaX.log, which is here: #948095 - Pastie](http://pastie.org/948095).

Olmy this is difficult for me to help because I do not have your hardware, nor have I ever worked with two graphic cards in one PC.

So you really need to do your best with the very limited suggestions I provide and try if you can to go a step further.

There is for example, this thread: Two graphics cards - openSUSE Forums

… now note the syntax (and driver/hardware) as different in that user’s case, but you still may be able to follow this.

For example, maybe instead try this:

sax2 -r -l -c 1, -d 1, -m 1=vesa

or try:

sax2 -r -l -c 1, -d 1, -m 1=fbdev

or try:

sax2 -r -l -c 1, -d 1, -m 1=radeon

Note you MUST do this from run level 3. If you do this with X already running it will NOT work. I do NOT know the exact syntax reference commas …

Did you try only vesa, or did you also try radeon and fbdev?

Before Sax2 failed, it did construct an xorg.conf (that presumeably was not saved). I note that to be this: #948203 - Pastie](http://pastie.org/948203)

Did you try copying that into a new xorg.conf file, and then running it?

From that file, I note this in the monitor section:

  Section "Monitor"
    DisplaySize  338 270
    HorizSync    30-83
    Identifier   "Monitor[0]"
    ModelName    "V173"
    Option       "DPMS"
    Option       "PreferredMode" "1280x1024"
    VendorName   "ACR"
    VertRefresh  43-75
    UseModes     "Modes[0]"
  EndSection

Is that correct wrt your second monitor ? ie An ACER V173 ? Or is it inappropriately populating your 1st monitor there?

I have now.

I can only assume it is valiantly attempting to run on my second monitor. It says it’s got to level 5 on the terminal on my first monitor but the second remains stubbornly asleep.

It’s correct, both monitors are the same.

Sorry, missed this. Yes; similar results on all of them.

There is always the chance this is a bug with 11.2 … I don’t know …

Is this a KDE live CD or a Gnome liveCD ? I am trying to help one Gnome user (unsuccessful thus far) who claims Gnome and 11.2 and the ATI 9200 pro are not compatible with each other … while KDE works (for myself and for others). … I can’t say its a Gnome problem, but neither have a spent the time to download a Gnome liveCD to disprove this assertion that Gnome has a problem.

Since you are using a liveCD, as I suggested already, you could try download openSUSE-11.3 milestone6 liveCD. You will also need to download (and copy via USB or other method to the PC’s ram): sax2, sax2-gui, sax2-ident, sax2-libsax, sax2-libsax-perl, sax2-libsax-python, sax2-tools. and then install those so you can sax2.

Then try the same as you tried for 11.2, but with 11.3.

11.3 has improved intel and radeon drivers and improved Mesa.

It’s KDE.

OK, I’ll give it a go next time my connection can be tied up for a while doing the download.

Can I get the sax2 stuff via Yast, after booting the cd?

This is a bit relevant to another test I want to do on another machine (netbook) - I’ve read that Yast can install the broadcom-wl package and will sort out which flavour is required. Every time I touch Yast on the live install, though, it seems to go off and try to update the entire system (possibly, I’m not familiar with it and it just kept on telling me it was downloading all sorts of stuff and taking a long time about it).

Is there a simple way to tell it to get package xxxx and ignore everything else (except dependencies)?

Otherwise, can you tell me where I can download this (sax2) stuff from and what to do with it?

Thanks again for all the help…

You can, if you point YaST software repositories to the right repository. For the “stable” Milestone-6, you need to point to the factory-snapshot, which is here for:

  • OSS
http://download.opensuse.org/factory-snapshot/repo/oss/
  • Non-OSS
http://download.opensuse.org/factory-snapshot/repo/non-oss/

I do not know enough to answer wireless questions.

Yes, do this via zypper.

ie for milestone6, with root permissions:

zypper ar http://download.opensuse.org/factory-snapshot/repo/oss/ oss-factory-snapshot
zypper install sax2 sax2-gui sax2-ident sax2-libsax sax2-libsax-perl sax2-libsax-python sax2-tools
zypper rr oss-factory-snapshot

and pay close attention to the syntax. I tried to get the syntax exact, spaces and all.

Note a regular user is “linux” and password is <enter> on a liveCD. Also the “root” password is <enter> on a liveCD.