TW: Zypper Nvidia repo error

Hi All,
I have a fresh install of OpenSuse TW. I love how blazing fast it is.

The problem I’m seeing is when I go to install any software, gcc for example I get an error message in zypper saying Nvidea repo is invalid. I have an AMD card in my system so I don’t really care about the Nvideo repo, how can I remove it?
I tried looking through YasT but I’m not super familiar with it, and couldn’t find it.

Here is the error message:

Retrieving repository 'Nvidia' metadata ................................................[error]

Repository 'Nvidia' is invalid.

[Nvidia|] Valid metadata not found at specified



- [|] Error trying to read from ''

- Download (curl) error for '':

Error code: Curl error 92

Error message: HTTP/2 stream 0 was not closed cleanly: PROTOCOL_ERROR (err 1)

Please check if the URIs defined for this repository are pointing to a valid repository.

Warning: Skipping repository 'Nvidia' because of the above error.

Some of the repositories have not been refreshed because of an error.

Loading repository data...

Reading installed packages...

Resolving package dependencies.`

On a “fresh” installation, the Nvidia repo is not installed. It needs manual user interaction to add the Nvidia repo. To remove the repo, go to yast software → configuration → Repositories → mark the nvidia repo-> remove


What libzypp version do you have (rpm -q libzypp)?

ah, I think the issue is I’m running Gecko Linux which is a slightly tuned version of Tumbleweed. I’ll have to report that bug somewhere.

When I goto the repo tab in Yast I don’t see anything Nvidia related. I’m not sure where it would be listed, if it’s under the Tumbleweed_OSS or non_OSS.
Ultimately I went to the repo directory, /etc/zypp/repos.d and marked the Nvidia.repo file “enabled=0”

Then I ran

sudo zypper refresh

and it’s all good.

I’m running libzypp-17.31.0-1.4.x86_64

libzypp has several fixes related to the curl error 92 in the version 17.31.14. You should test with at least this version to make sure it is not already fixed problem. No idea how to do it with your custom openSUSE derivative.

You could also try http instead of https.

Probably best in the future to post first in “Gecko Linux” support, since it’s NOT truly native SuSE … if you feel it’s somehow “better”, they should offer a solution

Good it’s fixed now :+1:

Then you should have tagged your question with “other” version, not “tumbleweed”, and tell what you are using in the very first post.

Lots of love for Gecko Linux :laughing:
I wouldn’t even go so far as to call it it’s own distro, it’s more flipping some presets than anything, adding fonts. The underlying system is “Tumbleweed” when I check /etc/os-release so selecting Tumbleweed as my question tag isn’t wrong in this case.

At the end of the day it was a question on how to enable/disable repos in Tumbleweed. I’m still not sure where it ended up in Yast, but I’ll have to learn how to use that better.

Thanks all for your help.
@arvidjaar I’ll try running the lates version of libzypp too

I agree with that. However, it would have helped if you had mentioned that this was Gecko linux in your opening post.

In a normal Tumbleweed install, there are no Nvidia repos until you add them. And that’s part of what made your opening post a bit confusing.

In any case, you can use:

Yast → Software → Software Repositories

to add or remove repos or to enable or disable them. Give it a try.

Thanks @nrickert, honestly I forgot about it myself till some one mentioned it’s not part of the default install. There’s no specific branding or anything like that.