TW unusable on machine with nVidia graphics

Display on logging onto KDE looks OK to begin with but on trying to do
something like switching desktops, the display starts breaking up and
freezing. Within a couple of minutes, it’s impossible to do anything
and the only way out is to hit the reset button.

This problem began to develop a few weeks ago and, at first, I thought
it was connected with the workspace theme I’d switched to; switching
back to Breeze seemed to cure it. However, that turned out to be a fluke
and the problem appeared there too after a day or so.

I thought the kernel might have something to do with it so updated my
13.2 session to the latest one, only to find I was now using a later
version than TW. After a couple of weeks TW caught up but although 13.2
gave no trouble, TW was still a mess.

I next tried a clean install of TW from the last iso (20150714) but
that didn’t help at all.

As with 13.2, I’m using the nouveau driver.

Anyone seen similar trouble with nVidia graphics cards?


Graham P Davis, Bracknell, Berks.
openSUSE 13.2 (64-bit); KDE 4.14.9; AMD Phenom II X2 550 Processor;
Kernel: 4.1.2; Video: nVidia GeForce 210 (using nouveau driver);
Sound: ATI SBx00 Azalia (Intel HDA)

I’m using an NV84 (GeForce 8600GTS) with the nouveau driver on an up to date TW and don’t have any graphics issues.

Maybe try changing the rendering backend (System Settings - Display & Monitor - Compositor), also check that the openGL interface is set to GLX and not EGL, which seems buggy at the moment.

Could also try progressively disabling desktop effects to see if it’s one of those causing the issue.

On Thu, 23 Jul 2015 10:16:01 GMT
tannington <tannington@no-mx.forums.microfocus.com> wrote:

>
> I’m using an NV84 (GeForce 8600GTS) with the nouveau driver on an up
> to date TW and don’t have any graphics issues.
>
> Maybe try changing the rendering backend (System Settings - Display &
> Monitor - Compositor), also check that the openGL interface is set to
> GLX and not EGL, which seems buggy at the moment.
>
> Could also try progressively disabling desktop effects to see if it’s
> one of those causing the issue.
>

Might try that if only I could get into the system for long enough
before it breaks! :wink:

I think my next attack will be to try another clean install but this
time setting up a brand new user to see if that makes any difference.
Could be there’s some iffy personal settings left over. The current
installation has only the one user and, of course, I can’t get into
root via the default logon panel. :frowning:


Graham P Davis, Bracknell, Berks.
openSUSE 13.2 (64-bit); KDE 4.14.9; AMD Phenom II X2 550 Processor;
Kernel: 4.1.2; Video: nVidia GeForce 210 (using nouveau driver);
Sound: ATI SBx00 Azalia (Intel HDA)

For me, nouveau works pretty well if I disable desktop effects. But with desktop effects on, it is a mess. This is with an older 6150LE card. I have not recently tried with Tumbleweed, though I have tried running another distro from live media with plasma 5, and it was a mess.

I recently tested openmandriva with KDE4, and that seemed quite stable. When I checked the desktop effects settings, they had been set to use Xrender instead of OpenGL. I’m not sure if that is possible with plasma5.

With opensuse KDE4 and nouveau, I would login to Icewm, and find the settings file where I could turn off desktop effects with a text editor. I haven’t tried that with Tumbleweed.

On Thu, 23 Jul 2015 12:56:01 GMT
nrickert <nrickert@no-mx.forums.microfocus.com> wrote:

> Cloddy;2720575 Wrote:
> > Anyone seen similar trouble with nVidia graphics cards?
>
> For me, nouveau works pretty well if I disable desktop effects. But
> with desktop effects on, it is a mess. This is with an older 6150LE
> card. I have not recently tried with Tumbleweed, though I have tried
> running another distro from live media with plasma 5, and it was a
> mess.

One trouble I see with Plasma5 is that desktop effects can only be
turned off item by item in the GUI; there is no overall switch-off
button as there is with KDE4 - or, at least, I couldn’t see one.

The graphics was working fine until about a month ago; no idea what’s
changed.


Graham P Davis, Bracknell, Berks.
openSUSE 13.2 (64-bit); KDE 4.14.9; AMD Phenom II X2 550 Processor;
Kernel: 4.1.2; Video: nVidia GeForce 210 (using nouveau driver);
Sound: ATI SBx00 Azalia (Intel HDA)

On Thu, 23 Jul 2015 10:41:30 GMT
Graham P Davis <cloddy@no-mx.forums.microfocus.com> wrote:

> On Thu, 23 Jul 2015 10:16:01 GMT
> tannington <tannington@no-mx.forums.microfocus.com> wrote:
>
> >
> > I’m using an NV84 (GeForce 8600GTS) with the nouveau driver on an up
> > to date TW and don’t have any graphics issues.
> >
> > Maybe try changing the rendering backend (System Settings - Display
> > & Monitor - Compositor), also check that the openGL interface is
> > set to GLX and not EGL, which seems buggy at the moment.
> >
> > Could also try progressively disabling desktop effects to see if
> > it’s one of those causing the issue.
> >
>
> Might try that if only I could get into the system for long enough
> before it breaks! :wink:
>
> I think my next attack will be to try another clean install but this
> time setting up a brand new user to see if that makes any difference.
> Could be there’s some iffy personal settings left over. The current
> installation has only the one user and, of course, I can’t get into
> root via the default logon panel. :frowning:
>

OK, done that and found that the new user works fine whilst the old
users, three of them, just collapse in a nasty heap. So, it looks like
local settings are the problem but they were not changed from default.
Having said that, the new user might have different defaults, being
from a later installation.

Next move is to remove/rename some config files as root for a
troublesome user and see if that makes a difference. Be useful to know
which ones to go for, though. Any suggestions?

Will also be trying to reproduce this on a non-nVidia machine.


Graham P Davis, Bracknell, Berks.
openSUSE 13.2 (64-bit); KDE 4.14.9; AMD Phenom II X2 550 Processor;
Kernel: 4.1.2; Video: nVidia GeForce 210 (using nouveau driver);
Sound: ATI SBx00 Azalia (Intel HDA)

Of course it may not be a plasma/compositing issue… but if it is then:

For starters I’d clear the users cache ( located ~/.cache and delete anything plasma* ) of the “plasma stuff” just to see if that makes any difference.

The config files for plasma are plasma* located ~/.config I’d rename those.

After that… your guess is as good as, if not better, than mine :slight_smile:

What happens if you disable compositing completely (alt-shift-F12)…

On Fri, 24 Jul 2015 09:06:01 GMT
tannington <tannington@no-mx.forums.microfocus.com> wrote:

>
> Cloddy;2720737 Wrote:
> >
> > Next move is to remove/rename some config files as root for a
> > troublesome user and see if that makes a difference. Be useful to
> > know which ones to go for, though. Any suggestions?
>
> Of course it may not be a plasma/compositing issue… but if it is
> then:
>
> For starters I’d clear the users cache ( located ~/.cache and delete
> anything plasma* ) of the “plasma stuff” just to see if that makes any
> difference.
>
> The config files for plasma are plasma* located ~/.config I’d rename
> those.
>

I tried renaming .config/plasmashellrc first and that seems [fingers
crossed here] to have done the trick. Configuration settings are
different to the old one. Looks as though a change in KDE is yet again
not compatible with old settings. That would explain why the newly
created user-session was not affected.

Luckily, after creating another clean install from 20150722, my user
session stayed functional for long enough for me to change the login
panel to one that would enable me to logon as root, thus giving me a
chance to tinker with my user settings at leisure.


Graham P Davis, Bracknell, Berks.
openSUSE 13.2 (64-bit); KDE 4.14.9; AMD Phenom II X2 550 Processor;
Kernel: 4.1.2; Video: nVidia GeForce 210 (using nouveau driver);
Sound: ATI SBx00 Azalia (Intel HDA)

On Fri, 24 Jul 2015 10:46:31 GMT
Graham P Davis <cloddy@no-mx.forums.microfocus.com> wrote:

> I tried renaming .config/plasmashellrc first and that seems [fingers
> crossed here] to have done the trick. Configuration settings are
> different to the old one. Looks as though a change in KDE is yet again
> not compatible with old settings. That would explain why the newly
> created user-session was not affected.

OK, I give up. Worked for a few hours and then picture started breaking
up and freezing until it reached the stage when the reset button came
into its own again. Tried renaming all the plasma… config files but to
no avail.


Graham P Davis, Bracknell, Berks.
openSUSE 13.2 (64-bit); KDE 4.14.9; AMD Phenom II X2 550 Processor;
Kernel: 4.1.2; Video: nVidia GeForce 210 (using nouveau driver);
Sound: ATI SBx00 Azalia (Intel HDA)

Arg - I just installed Tumbleweed and am having the same issue - lots of tearing and refresh issues after the session has been open for a while. A reboot temporarily fixes the issue.

My card is a GT 620.

Have you tried installing the NVIDIA driver to see if it helps?

On Wed, 29 Jul 2015 06:26:01 GMT
darklight tr <darklight_tr@no-mx.forums.microfocus.com> wrote:

>
> Arg - I just installed Tumbleweed and am having the same issue - lots
> of tearing and refresh issues after the session has been open for a
> while. A reboot temporarily fixes the issue.
>
> My card is a GT 620.
>
> Have you tried installing the NVIDIA driver to see if it helps?
>
>

No, I haven’t. Didn’t think it would be a long-term solution, what with
rapidly-changing kernels, but I suppose it might be an interesting
experiment.

I’ve submitted a bug report if you fancy adding your two-pennorth?
http://bugzilla.opensuse.org/show_bug.cgi?id=939436


Graham P Davis, Bracknell, Berks.
openSUSE 13.2 (64-bit); KDE 4.14.9; AMD Phenom II X2 550 Processor;
Kernel: 4.1.3; Video: nVidia GeForce 210 (using nouveau driver);
Sound: ATI SBx00 Azalia (Intel HDA)

disclaimer: I haven’t had a PC with nvidia graphics for about a year, so my adivce may be out of date.

In the past that was an issue for me when I installed nvidia drivers “the hard way”, however for the last year before my nvidia equipped PC died I switched to loading the driver in YAST. Just add the nvidia repo from the community repos. I went through a few kernel updates without issues.

That not really an option with Tumbleweed.

I was afraid that might be the case, hence the disclaimer.

If i can recommend, i had plasma crashes multiple times a day also firefox etc. After switching to EGL - systemsettings -> display and monitor -> compositor -> opengl interface -> EGL no more crash.

GF9600GSO,TW, Plasma 5.3.2

I’ll be happy to add to that bug report. This issue is really frustrating - my KDE session eventually bombs so bad that I have to hit the hardware reset button, which I hate doing.

Its annoying enough I’m considering moving back to 13.2 because in the current state KDE is basically unusable. Does creating a new user fix the issue as you indicated in the bug? I may end up doing that.

I just tried this, and unfortunately it doesn’t seem to be helping. I really appreciate the suggestion, though!