TW randomly reboots after last update

This computer has been running really stable with TW but after yesterdays updates it now runs normal for as long as 30 minutes and then spontaneously reboots. Acts just like you hit the reset button. This is very annoying as its my music server. It will also do it if its just sitting at the desktop with no apps running. Nothing is getting written to the logs when it does this either.
I have built 2 identical systems so to rule out a coincidental hardware failure -
What I have done so far:
Swapped ram and graphics board.
TW won’t stay up more than about 30 minutes. CPU temp is averaging 42C which is normal for a AMD 880K.

The system is dual boot and I have Yosemite as the other OS. I let Yosemite run overnight and it stayed up with no problems.
The other identical computer is running LEAP 42.1 and its 100% stable.

Any ideas? Wait for next update?


In fact, I am beginning to lose my trust on Linux in general.

  1. First, the blame should be shared with Intel for its flaky product Skylake.
    So, I cannot use Leap 42.1.
  2. Since kernel 4.7.x through 4.8.x, the linux in general became very flaky on my Skylake
    laptop. My tumbleweed-installed system freezes once a day by average or more.

I looked at systemd-journal log. But I simply cannot obtain any hint out of it. There is too much
information in it.

I reformatted all the file systems from BTRfs to XFS hoping for any solution without any
Then, I saw an article by Linus Torvalds himself commenting the miserable
situation with the current kernel version 4.8. The current tumbleweed kernel is 4.8.4-1.

I expected a quick fix because the kernel developers recognized the problem at least.
However, I have not been able to hear any good news or any good fix for the current kernel
problem so far.

I am thinking about kernel compilation which I had quit about fifteen years ago, since opensuse 6.x.

Any news?

An update just came up including “opensuse release”. Let it install the new update and rebooted and now it gets a Kernel Panic. Went from bad to worse. It does still boot ok using a the previous snapshot, the one that randomly reboots. Hope they fix this soon.

No idea if it will help, but kernel 4.8.6 has been accepted to Factory today, and will probably be in the next Tumbleweed snapshot…

Also, you may still have a kernel 4.7 installed and available in your boot menu (especially if you reverted to a previous snapshot), which may work better.
Have a look in “Advanced Options”.

Unfortunately 4.8.3-1 is the oldest snapshot…

Well, there are also plenty of older kernels available in the Kernel:* repos:

4.4.x (Leap 42.2’s kernel) in Kernel:openSUSE-42.2
4.1.x (Leap 42.1’s kernel) in Kernel:openSUSE-42.1
3.16.7 (13.2’s kernel) in Kernel:openSUSE-13.2

And also the latest unstable one (4.9rc3 at the moment) in Kernel:HEAD.

Trying different kernels might at least show if it really is a kernel problem…

I can only say that current Tumbleweed with Kernel 4.8.4 seems to run absolutely stable here, I did use a LiveCD for hours yesterday.
But such things tend to be highly specific to the hardware anyway.

I installed the 4.8.6 update last night and that fixed it. It stayed up all night with no crashes. Before it would rarely last more than 20-30 mins even just sitting with no apps running. Guess the last 2 kernels didn’t like my hardware.

That kernel didn’t last long - just came up for the update last night and this morning it updated to kernel 4.8.6-2 already… Hope it works…

Well, that kernel just contains two additional fixes AFAICS:

  • usbhid: add ATEN CS962 to list of quirky devices (bsc#1007615).
  • KEYS: Fix short sprintf buffer in /proc/keys show function
    (bsc#1004517, CVE-2016-7042).

Its still working. 4.8.6 definitely fixed it. 4.8.6-2 still working also…