TW on external HDD won't boot in second machine

Hi!

Have a TW KDE on a HDD used for some years externally with Dell Latitudes (Sata to eSata or USB3 adapter). This worked until recently, but now only the “primary” Latitude (used mostly) boots fine, while another Latitude fails to find the root partition (?) after Grub:

nobooot

The UUID should be permanent, or? Does the UUID change with the machine booting the HDD?

A wild guess:

There’s probably a missing driver so that the booting system cannot see that disk. I suggest that you rebuild the “initrd”, and then try again.

I’m assuming that you are experienced enough to know how to do that. But, if not, you can ask.

No, it does not.

Any idea why the HDD won’t boot? I even tried different SATA-USB3 bridges, no avail.

TW installs on USB-sticks booting fine in different machines.

Only difference I find from the top of my head: The HDD is a dual boot with an old Win7 install, but that should not get mounted on boot of TW, or?

Hi and thanks! I don’t think it’s a missing driver, it worked well in the past and the HDD is booting fine until long after Grub, all EXT4, all on the same HDD.

Had a look at fstab on the HDD TW:

  • No windows partitions mounted on boot
  • / is XT4, /home is XFS

Did the HDD always boot via eSATA and USB3 or did you change from eSATA to USB3 and the boot via USB failed?

In the latter case your initrd might miss the usb-storage module (or some other USB modules).

You can check (as root) with

# lsinitrd |grep usb-storage
-rw-r--r--   1 root     root        52375 May  7 14:10 usr/lib/modules/6.8.9-1-default/kernel/drivers/usb/storage/usb-storage.ko.zst

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.