TW can't see Bluetooth LE MIDI Keyboard after compiling support in Bluez

so I forked the bluez package on OBS and added in the MIDI flag and installed it.

I now have Bluetooth MIDI working fine when I connect an iPhone.

However I cannot connect my Korg microKey Air BLE midi keyboard.

The exact same hardware works in Fedora so I’m wondering if it’s some kind of security or something I need to turn off.

Lot’s of jiggering about with hciconfig and SPP doesn’t work.

I can’t find the device using bluetoothctl

any hunches as to whats causing the blockage appreciated.

here is my bluez fork

building manually locally doesn’t seem to fix it.

maybe it’s something to do with the systemd service or something

I’m not a dev btw, just some idiot who keeps tripping over wires

Isn’t it already there in the original OBS bluez.spec file?

from your build logfile

[ 14s] + ./configure --host=x86_64-suse-linux-gnu --build=x86_64-suse-linux-gnu --program-prefix= --disable-dependency-tracking --prefix=/usr --exec-prefix=/usr --bindir=/usr/bin --sbindir=/usr/sbin --sysconfdir=/etc --datadir=/usr/share --includedir=/usr/include --libdir=/usr/lib64 --libexecdir=/usr/libexec --localstatedir=/var --sharedstatedir=/var/lib --mandir=/usr/share/man --infodir=/usr/share/info --disable-silent-rules --enable-pie --enable-library --enable-tools --enable-cups --enable-hid2hci --enable-admin --enable-midi --enable-test --enable-experimental --enable-mesh --enable-midi --enable-test --enable-experimental --enable-deprecated --enable-datafiles --enable-sixaxis --with-dbusconfdir=/usr/share --enable-external-ell --with-systemdsystemunitdir=/usr/lib/systemd/system --with-systemduserunitdir=/usr/lib/systemd/user

cheers, yes you are totally correct, it’s enabled by default. I’m not familiar with .spec files and hought the bit under the %endif with the --enable-midi wasn’t being called somehow, due to not being able to see the Korg in the BT pairing thing in Gnome. I can’t have tested the iPhone midi before doing that.

so TW has midi OOTB which is cool

so now my problem is just TW can’t see the Korg, it doesn’t show up in any Bluetooth scans I run, using any tool.

works when I compiled bluez on fedora, so the hardware is good.

perhaps it’s some security thing I need to turn off or something.

right I got it working.

SPP mode enabled via hciconfig perhaps did it.

showed up as a mac address under bluetoothctl