TW after update to 20200211: Plasma has forgotten settings for root user after update to 5.18

Updated to TW 20200211 today, getting Kernel 5.5.2 and Plasma 5.18. Oh sh…, Plasma 5.18 has forgotten quite some settings - this in fact IS HORRIBLE.

My user settings (standard account) seem to be fine, as far as I could play around up to now. However, many Plasma settings related to the root user got lost:

  • Dolphin in root mode starts up from scratch, ignoring all previous settings I had. Moreover, it comes up with the standard theme/icon settings, not the dark mode I had set before.
  • Same for krusader in root mode. It starts up from scratch, does its first run settings (why the hell should it do that?), looks for auxiliary programs, and ignores all previous settings I had. It also ignores my dark theming/icons.
  • Similar for YaST, it now ignores the dark theming/icons I had set it to.

I logged in as root and checked the Plasma system settings - funny enough, they all look the same as I had before the TW update. (Yes, I know, logging into Plasma as root is really undesirable…) In particular, dark theming/icons are set properly for the root user.

What is Plasma 5.18 up to? Am I required to set it up all over again? Why are my dark theming/icons ignored now by programs which are run in root mode???

Oh man, what a mess now! I didn’t check the Plasma bugzilla yet, but will have to do this next. In the meantime, if there is help here I would be really grateful. In fact, we have Valentine Day today, so there are more important things to do than restore my really well-groomed TW to its good-looking prior state…

In any case, you should never log in in the GUI as root.

Running some applications from a “normal” users GUI as root (like YaST, Konsole “in Superuse mode”, Dolphin “in Superuser mode”) is OK, but never a login by root in the GUI. Did I say “never” already?

Yes, you did. And I knew, of course.

So, how do I run Plasma systemsettings for applying graphical settings to root apps like Dolphin, krudader and Konsole in root mode?

Then that is OK. I wrote this not so much for you, but for others that will read this and think it is a good idea “because I read this on the Internet”.

You can run sytemsettings5 in konsole as root or start typing ‘kdesu sytemsettings’ on the desktop.

Thank you, will do. That answers my general ”how to“ question, hope the Plasma issue gets solved that way or by a 5.18.1 update very soon.

It’s probably too late now but I should have written systemsettings5 in both suggestions, of course.

Just an idea: cache corruption. While logged out of any X session at all, login on a vtty, purge /root/.cache/ content, then try a Plasma session. If that turns out to be inadequate, you could try a functional “user” reset by deleting the KDE/Plasma content all mixed up with other app configs in /root/.config/.

All is fine now. It takes

kdesu systemsettings5
kdesu kvantummanager

to polish the graphical settings for programs that one has to or wishes to run as root, like YaST and (from time to time) Dolphin or Krusader or Kate.

Thanks to you all!