TW 20170913 prevent my intel graphic work

Hello :slight_smile:

Until today, my old dell mini 10 worked perfectly with tumbleweed 32 bits.

I updated it (zypper up) to TW 20170913 and now it do not start anymore: the screen is blurred, I’m not even sure it started X, because adding “3” on the grub linux line do not gives the init 3 start.

adding “nomodeset” allows me to start.

video is intel 945GSE and seems to be seen in X logs

any hint?

thanks
jdd

I have no idea if it has anything to do with your problem, but Tumbleweed should be updated using

zypper dup

and not zypper up.

I have often seen discussions about this, with usually opposite results (that is each discussion opposit from the previous).

But I just try it, with as first result than packman apps are pulled from opensuse, so I will need a zypper dup --from “Packman Repository”

As it’s running, I will report after it done

thanks
jdd

well… no change

a zypper dup did not make any good (nor any more bad…)

it’s too late today to test anymore

thanks
jdd

maybe a package mixup from a 3rd party repo what’s your repo list

zypper lr -d

the proper way to upgrade TW after you’ve added and done a vendor change to packman is

zypper dup --no-allow-vendor-change

… you may not have understood those discussions, because it is, for a long time

zypper dup

for Tumbleweed.

… and that has never changed.:wink:

so Richard Brown is wrong?

jdd

Well, more recently he wrote

zypper up is a partial solution, as it doesn’t allow packages to
change their repos (aka vendor change), but has its own flaws, as it
is often too conservative and doesn’t tidy up after itself. This can
lead to old packages lying around after they’ve been dropped from TW
or your OBS repos, leading to weird dependency chains of old packages
lurking around when you should have actually upgraded them all.

this also leads to weird breakages and odd behaviour.

“zypper dup --now-allow-vendor-change” forces zypper dup to use the
most important feature of zypper up “keep using the packages from the
same repositories from which I installed them from”. But otherwise
preserves all the usual zypper dup behaviour of ensuring you have a
complete, consistent, tumbleweed installation based on what packages
are, or are no longer, in our repositories.

This avoids the issues with ‘zypper up’ leaving ‘cruft’, prevents the
problem described in 2), and does the best job possible to mitigate
the problems described in 1) - but of course you’re still at the mercy
of whatever maintainers do in their OBS repos, and they do not benefit
from the review, integration work, and testing which the main
repositories benefit from.

Hope this helps,
R

The proper way to update (effectively upgrade) TW…

https://lwn.net/Articles/717489/

…and here…
https://en.opensuse.org/Portal:Tumbleweed

Follow the opensuse-factory mailing list to get notified about updates. New snapshots are released as often as they are ready and automatic QA has passed. This can be as often as daily but sometimes also takes a few weeks, when bigger changes are integrated. (Note that there can be some subtleties with updates, especially with multiple repositories. See for example recent discussion about using zypper dup versus zypper up)
Once you are running Tumbleweed to get updates every time a new snapshot has been released enter the following command as root (ideally inside a screen session):

zypper dup --no-allow-vendor-change

A recent libzypp update meant that /etc/zypp/zypp.conf was changed so that for most TW users running ‘zypper dup’ will default to inhibiting vendor changes as documented here
https://bugzilla.suse.com/show_bug.cgi?id=1031756

If even Richard is not that sure of what have to be done, think of a simple user…

anyway this have nothing to do with my problem, I almost solved right now.

I noticed that a crash happens very early in the boot process, with screen blurred on the left part but something looking like a kernel hoops (random hex dump) on a line, then the screen keep blur but the rest worked.

So :

  • Thanks to BTRFS I could start the previous snapshot with previous kernel
  • then in YaST I disabled graphical start

and all works again, only a bit less smart looking on start…

thanks for help

jdd

Well, I think it’s less about not being sure, but rather that zypper (“dup”) got a new feature, namely the possibility to disallow vendor change (which is even the default by now), so there is no reason to use “up” anymore and risk a broken system.

In earlier times, “zypper up” was the only way to prevent packages to be switched to different repos, which is quite important if you use additional repos.

  • Thanks to BTRFS I could start the previous snapshot with previous kernel

Even without btrfs or snapshots, you should be able to boot the previous kernel in “Advanced Options” in the boot menu.
openSUSE keeps at least two kernels installed by default since years…

then in YaST I disabled graphical start

You disabled plymouth, I suppose.

You should probably file a bug report about your crash though.