TuxGuitar won't start up

TuxGuitar 1.2-4.1.2 does not start on my system OpenSUSE 12.1+KDE 4.7.2
Exception in thread “main” java.lang.UnsatisfiedLinkError: Could not load SWT library. Reasons:
no swt-gtk-3730 in java.library.path
no swt-gtk in java.library.path
Can’t load library: /home/Wimmie/.swt/lib/linux/x86/libswt-gtk-3730.so
Can’t load library: /home/Wimmie/.swt/lib/linux/x86/libswt-gtk.so

    at org.eclipse.swt.internal.Library.loadLibrary(Library.java:284)
    at org.eclipse.swt.internal.Library.loadLibrary(Library.java:193)
    at org.eclipse.swt.internal.C.<clinit>(C.java:21)
    at org.eclipse.swt.internal.Converter.wcsToMbcs(Converter.java:63)
    at org.eclipse.swt.internal.Converter.wcsToMbcs(Converter.java:54)
    at org.eclipse.swt.widgets.Display.<clinit>(Display.java:132)
    at org.herac.tuxguitar.gui.TuxGuitar.displayGUI(Unknown Source)
    at org.herac.tuxguitar.gui.TGMain.main(Unknown Source)

I have Java-openjdk and Java-Sun/Oracle installed.
Any idea?

I found this README file(after installing TUXGUITAR)
inside there is something like this:

If you see an error like “java.lang.UnsatisfiedLinkError”, you will need to replace your swt shared library files and jar
packages compiled for your system. TuxGuitar comes with SWT for linux-x86, linux-x86_64, mac and win32-x86. make sure download
the correct file. if you need another version, download your SWT and replace in lib folder.
If you don’t have SWT installed in one of this locations: /lib, /usr/lib, /usr/local/lib or TuxGuitar/lib. You will need to
add its path to the LD_LIBRARY_PATH and CLASSPATH environment vars.

$export LD_LIBRARY_PATH=$LD_LIBRARY_PATH:/your_swt_library_folder/
$export CLASSPATH=$CLASSPATH:/your_swt_library_folder/swt.jar
good luck
I didn’t receive any error on my machnie but it didn’t start either. Anyway I don’t need it. Hopefully with the instructions in the README file you can run it.

Thanks a lot for your answer. I’ll have a try.
Well in general (not personally meant): that’s not an OpenSuse package example of working out of the box, is it?

This has been an issue with several programmes on OpenSuSE 12.1, I expect it has to do with the OpenJDK as I have never seen it while using Java. Java isn’t available from the official repositories for 12.1, but there is some info on how to obtain it here: SDB:Installing Java - openSUSE

This is what I guess is the cause, so bare that in mind. I have not tried Tuxguitar but I have seen this error message with several Java apps, including TripleA.

I have Java-openjdk and Java-Sun/Oracle installed

Sorry, didn’t see this. I suppose it might be necessary to specify what java you wish to use.

If the classpath suggestion doesn’t work, you can try the other options mentioned in this similar thread: http://forums.opensuse.org/english/get-technical-help-here/applications/473111-tuxguitar.html and let the forum know how it goes.