TuxGuitar crashes

I installed openSuse 13.1 64 bit the other day, then after all updates, installed TuxGuitar in Yast. It crashes when I try to get into Settings or Skins, as well as when I double click on a track name to check the tuning - actually, crashes when I click the button to exit that. I ran it from the command line, but I don’t understand a bit of it. Here’s what I think is the relevant information:

# A fatal error has been detected by the Java Runtime Environment:
#  SIGSEGV (0xb) at pc=0x00007fa5fe5496b8, pid=5325, tid=140351246079744
# JRE version: OpenJDK Runtime Environment (7.0_51) (build 1.7.0_51-b00)
# Java VM: OpenJDK 64-Bit Server VM (24.45-b08 mixed mode linux-amd64 compressed oops)
# Problematic frame:
# C  [libgobject-2.0.so.0+0x1a6b8]  g_object_get_qdata+0x18
# Failed to write core dump. Core dumps have been disabled. To enable core dumping, try "ulimit -c unlimited" before starting Java again
# An error report file with more information is saved as:
# /tmp/jvm-5325/hs_error.log
Compiled method (nm)    9208  141     n       org.eclipse.swt.internal.gtk.OS::_g_object_get_qdata (native)
 total in heap  [0x00007fa60c747e10,0x00007fa60c748190] = 896
 relocation     [0x00007fa60c747f30,0x00007fa60c747f90] = 96
 main code      [0x00007fa60c747fa0,0x00007fa60c748190] = 496
# If you would like to submit a bug report, please include
# instructions on how to reproduce the bug and visit:
#   http://icedtea.classpath.org/bugzilla
# The crash happened outside the Java Virtual Machine in native code.
# See problematic frame for where to report the bug.
/usr/bin/tuxguitar: line 125:  5325 Aborted                 ${JAVA} ${JAVA_FLAGS} ${PACKAGE_MAIN} $arg "$@"

There are also LOTS of these:

(TuxGuitar:5325): GLib-GObject-CRITICAL **: g_closure_add_invalidate_notifier: assertion 'closure->n_inotifiers < CLOSURE_MAX_N_INOTIFIERS' failed

As far as I can remember, on openSuse 12.3 I had TuxGuitar 1.2, same as now, though I don’t remember for sure. I looked at the error log mentioned in the first code tag above, but it is HUGE. I wasn’t sure if it was too big to post here…

I tried the web site for TuxGuitar, but that seems to be a dead link. I tried the bugzilla web page listed above, typed in “TuxGuitar”, this is what I got:

Zarro Boogs found.

Any ideas? If all else fails, it runs in a Windows XP VM (VirtualBox).


You could look here: http://sourceforge.net/p/tuxguitar/bugs/
Seems like the sourceforge page is regarded as the homepage for tuxguitar now.

Thanks - at least I now have a place to start! From what I read there, it may be a bug in eclipse-swt, so for now I’ll wait for any updates. I’ll post my problem there, who knows…

I haven’t really used any tablature writers/editors, if that is what you use TuxGuitar for, but searching for alternatives gave, among others, KGuitar and TablEdit; TablEdit should supposedly run fine through WINE. Might be alternative apps to use when waiting for a solution to the java issue.

Good luck!

A solution - sort of

I downloaded swt-4.4-gtk-linux-x86_64.zip from http://www.eclipse.org/swt
Then I download “GNU/Linux-x86_64 Binary Files” from http://www.tuxguitar.com/ar
This unpacks into a “local” directory, so I don’t mess up my system. Then I unpacked swt, and copied swt.jar to the “lib” directory in the unpacked TuxGuitar directory - NOT in my /usr/lib64. I then run “./TuxGuitar” from the local version, and it doesn’t crash when I adjust the mixer, or make changes to a track, such as the instrument or tuning. *However, *none of the “Settings” have any items. You can’t change the “skin”, so it’s that butt-ugly Gtk look. Can’t change the MIDI port to use Timidity. Ah well, at least it doesn’t crash. So, I guess the problem is related to eclipse-swt. Hope there’s an update in the future so it won’t have to look so ugly. I can still use TuxGuitar in the Windows 2000 VM, I suppose.