turning off screensavers

Every time I migrate to a new version of suse I have the niggly hassle of switching off all the screensavers, display cutoffs and dimmers. This time when going from 11.2 to 11.3 there seems to be an extra one to find.

I eventually managed to find all the ones in KDE:
System Settings -> desktop -> screensaver -> Start Automatically
System Settings -> advanced -> Power Management -> Edit Profiles -> Dim Display
System Settings -> advanced -> Power Management -> Edit Profiles -> screen

But now there seems to be one in X window which I have to turn off with:
xset -dpms
xset s off
xset s noblank

I assume this is something new in the default suse configuration, I have never had to do this before. If so why have they done this? (I am using the Nvidia driver the same as previous versions).

Also this has to be done every time I start the machine, what is the best way to turn this off permanently.

For suse 11.4 why not have a single setting to turn these all off permanently with one command?


Well the Kernel blanker has always been there but it should default to off. Why it sometimes is set on seems to be a mystery. I agree that there should be a single simple interface to control all.

gogalthorp wrote:
> I agree that there should be a single simple interface to control all.

i wonder if anyone has ever entered a FATE asking for (like):

“Please make an easy, one button/switch/clickable icon way to turn off
all automatic screen saving, blanking, sleeping, hibernating, screen
power saving etc functions while (for example) i watch a movie from a
DVD, or live news cast streaming over the net, or or or … And then
revert back to screen saving/blanking whatever when the movie is over
by another click. Or if you wanna make something REALLY cool build a
switch into Kaffeine/Totem/VLC/mplayer/etc/ to do that automatically
so i don’t have to remember to do it AFTER the screen goes BLACK while
s/he takes off her/his . . .”

seems like something a geek could figure out how to do for us
non-programmers, huh?

CAVEAT: http://is.gd/bpoMD [posted via NNTP w/openSUSE 10.3]

I would like to add that if the Power Management option “Let PowerDevil manage screen Powersaving” is not set, the kernel screen saver seems to start working and is suppressed if this option is selected. This option is normally set it would seem, but on one openSUSE 11.3 RC2 install, it was not checked by default on an Intel G31 chipset motherboard. The blank screens drove me cray until I found this option and set it back on in Power Management. I always use the KDE desktop and nVidia graphic cards.

Thank You,

I tried to fix this by creating a file Xscreen.sh as listed below and putting it in:
but this does not work. Any idea what I am doing wrong? I guess there must be a startup log somewhere that I can lookat to check whats happening?

#! /bin/bash


xset s noblank -dpms

exit 0

end Xscreen.sh

If this is the kernel screen blanker causing the problem, then you need to find place that creates the terminal 7 (the GUI term) and shut it down there. There also maybe a kernel option. When I had this problem back in 10.1 I never did find the right place.

The key to turning off all screen blanking in KDE4 is to use Powerdevil to manage the display rather than trying to disable it. Disabling screen power management leaves DPMS on it’s default settings which usually blanks after 10 mins.

The things to do:

  1. Disable the screensaver.

  2. In Power Management create a new profile called “Always On”. On the screen tab tick “Enable display power management” also tick “Standby” “Suspend” & “Power off” and set each to 0 min. In General Settings tick “Let Powerdevil manage screen powersaving” and select “Always On”.

  3. Log out, log back in.

Obviously you don’t have to create a new profile to do this, I find it more beneficial to leave the preset profiles on their defaults.

Thanks very much, this works well.

Its not very intuitive to those of us who have not read the manuals, If you had not explained it I would have been concerned that setting the time to 0 would activate the screen blanker immediately.

I guess this should be a change request to the KDE writers rather than SUSE?


I thought I’d post my question to this thread - it’s the same question, only it relates to Gnome:

I have a fresh install of 11.3 (Gnome) on Intel D510MO motherboard. Everything runs beautifully, except I cannot disable some power saving features: after precisely 15 minutes of user inactivity, the monitor says “no signal” and goes into sleep mode.

I already disabled everything in Power Management preferences, aka “gnome-power-preferences” (“on AC power” tab, “put display to sleep when inactive for: never”), I unchecked “activate screensaver when computer is idle” in screensaver preferences, I executed xset commands mentioned in this thread. I cannot find anything related to power management in the BIOS or in the monitor menus. Is there anything else I can try?


This worked well for keeping my monitor on, but if I want the screensaver to kick in after
20 minutes, what settings other than on the ‘Screensaver options’ do I have to set?
The settings there alone do not seem to work.