Turn On PC Using WOL- Fails on 13.2 worked on 13.1 with same steps.

Hi guys

Trying top start up my PC using WOL. But it fails.
Here is what I did.

Enabled WOL in bios of my PC.
Ran ifconfig, got my adapter name and hwaddr.
Installed WOL client on my phone and configured with MAC/9.
Ran wire shark and saw packets.
Ran ethtool and found Wake on was d needs to be g
Ran ethtool -s enp3s0 wol g

shut down PC and it worked. Once, as expected.
To make it persistent
I tried to edit /usr/lib/systemd/system-shutdown/mdadm.shutdown"
by adding
ifconfig enp3s0 up
ethtool -s enp3s0 wol g
to the file and it does not work unless I manually set to g (ethtool -s enp3s0 wol g)
ANy ideas?

Here is what I see/ have

thanks in advance
John Kilbert

Try to add the the following line to after.local file and check.

ethtool -s enp3s0 wol g

Awesome. Thanks!


ethtool -s enp3s0 wol g



reboot, checked with

ethtool enp3s0|grep Wake-on

    Supports Wake-on: pumbg
    Wake-on: g

perfect. reboot WOL works.

thanks for your help!

My pleasure.Have a nice day.