turn off keyring

At boot time I get asked to input my password to open the keyring. I don’t need this level of security and want to either pass the password in a script or disable the keyring without disallowing my wireless connection. How do I do that and where do I find out about this keyring thing? TIA

bump bump bump

Are you talking about the gnome keyring, or about kwallet in KDE?

argon99 wrote:

> bump bump bump
try this

rm ~/.gnome2/keyrings/default.keyring

Next time keyring asks your for new passwords enter two times empty

If that does not help, try this

PC: oS 11.3 64 bit | Intel Core2 Quad Q8300@2.50GHz | KDE 4.6.1 | GeForce
9600 GT | 4GB Ram
Eee PC 1201n: oS 11.4 64 bit | Intel Atom 330@1.60GHz | Gnome 2.32 | nVidia
ION | 3GB Ram

keyring = credentials repository
You can maintain certificates (and other security credentials) in different separate groups, ie. keyrings

So, it sounds as though when your system boots up, something is running that needs security credentials and it sounds like it’s your wireless connection. If your wireless connection is “open” (no credentials) then a connection can be made without accessing a keyring but yours appears to require <and> it appears that your network connection is invoked on bootup (likely using IFUP/IFDOWN) instead of on User Login (typically using Knetworkmanager or Gnome Network Manager).

Solution 1
If your machine is a laptop and you move between wireless AP, you should not be connecting on bootup. Configure your network settings to use “Network Manager” instead.

Solution 2
If you really want your system to connect to wireless on bootup <without> a User logged in, then you need to provide network credentials to networking services either without a keyring (eg WPA_SUPPLICANT.CONF hashed password) or in a keyring the system can access.