turn off disable touchpad while typing

I have an EliteBook 8540p with OpenSUSE 42.2 gnome installed and was wondering how to be able to use the touchpad while typing (to play minecraft.) I checked in settings and dconf-editor but didn’t find anything. Please help.

Have a read of this openSUSE Gnome guide…

https://doc.opensuse.org/documentation/leap/gnomeuser/html/book.gnomeuser/cha.gnome.settings.html#sec.gnome.settings.hardware.mouse

In the Touchpad section of the dialog, you can turn the touchpad on and off. Use Touchpad Speed to adjust the sensitivity of the touchpad pointer. You can also disable the touchpad while typing and enable clicks by tapping the touchpad.

the guide SAYS you can turn on and off disable while typing, BUT the only options I see are touchpad on/off, natural scrolling on/off, touchpad speed, and tap to click.
https://photos-6.dropbox.com/t/2/AABmH0oXXToq_wHpIFl5-b4c-FUpBkwgbP6AoaqFYbHATw/12/433166608/png/32x32/1/_/1/2/Screenshot%20from%202016-12-24%2015-20-00.png/ELKg5-cEGAIgAigC/kRwAbd96SdlNpgQxV63RjpALLb6rhhmticLnJUUmtTU?size=1600x1200&size_mode=3

Let’s have a look at how the device is being reported…

xinput
xinput list-props 'name of touchpad device'

Hopefully, a Gnome user can chime in here.

You could create a custom Xorg config file eg /etc/X11/xorg.conf.d/80-touchpad.conf with the ‘DisableWhileTyping’ option

Section "InputClass"
        Identifier "libinput touchpad catchall"
        MatchIsTouchpad "on"
        MatchDevicePath "/dev/input/event*"
        Driver "libinput"
 Option "DisableWhileTyping" "true"
EndSection

Save when done, then CTRL-ALT-Backspace(twice) to restart the X-server.

For more libinput options, refer to

man libinput

I tried the file you suggested creating (I just coppied and pasted, I didn’t think that there were any variables you gave that I had to change, correct me if I’m wrong,) but changed disable while typing to false because I am trying to turn this feature OFF, but to no avail. This is the output of xinput, I did have to install it before running it.

alex@linux-k3rl:~> xinput
⎡ Virtual core pointer                        id=2    [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                  id=4    [slave  pointer  (2)]
⎜   ↳ PS/2 Generic Mouse                          id=11    [slave  pointer  (2)]
⎜   ↳ SynPS/2 Synaptics TouchPad                  id=12    [slave  pointer  (2)]
⎣ Virtual core keyboard                       id=3    [master keyboard (2)]
    ↳ Virtual core XTEST keyboard                 id=5    [slave  keyboard (3)]
    ↳ Power Button                                id=6    [slave  keyboard (3)]
    ↳ Video Bus                                   id=7    [slave  keyboard (3)]
    ↳ Sleep Button                                id=8    [slave  keyboard (3)]
    ↳ HP Webcam [2 MP Macro]                      id=9    [slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard                id=10    [slave  keyboard (3)]
    ↳ HP WMI hotkeys                              id=13    [slave  keyboard (3)]
alex@linux-k3rl:~> xinput list-props 11
Device 'PS/2 Generic Mouse':
    Device Enabled (142):    1
    Coordinate Transformation Matrix (144):    1.000000, 0.000000, 0.000000, 0.000000, 1.000000, 0.000000, 0.000000, 0.000000, 1.000000
    libinput Accel Speed (276):    0.000000
    libinput Accel Speed Default (277):    0.000000
    libinput Accel Profiles Available (278):    1, 1
    libinput Accel Profile Enabled (279):    1, 0
    libinput Accel Profile Enabled Default (280):    1, 0
    libinput Natural Scrolling Enabled (281):    0
    libinput Natural Scrolling Enabled Default (282):    0
    libinput Send Events Modes Available (260):    1, 0
    libinput Send Events Mode Enabled (261):    0, 0
    libinput Send Events Mode Enabled Default (262):    0, 0
    libinput Left Handed Enabled (283):    0
    libinput Left Handed Enabled Default (284):    0
    libinput Scroll Methods Available (285):    0, 0, 1
    libinput Scroll Method Enabled (286):    0, 0, 1
    libinput Scroll Method Enabled Default (287):    0, 0, 1
    libinput Button Scrolling Button (288):    2
    libinput Button Scrolling Button Default (289):    274
    libinput Middle Emulation Enabled (290):    0
    libinput Middle Emulation Enabled Default (291):    0
    Device Node (263):    "/dev/input/event1"
    Device Product ID (264):    2, 1
    libinput Drag Lock Buttons (292):    <no items>
    libinput Horizontal Scroll Enabled (265):    1


Ah, I see. It is probably libinput’s palm detection at work. Most users prefer it, but I can see how it might not be so desirable for gamers.

Is there any way that I can turn this off? It makes gaming EVEN HARDER on linux!

This blog discusses libinput and palm detection
http://who-t.blogspot.co.nz/2016/08/libinput-and-disable-while-typing.html

I’m still on a learning curve with all of this myself. It’s the corner cases that are triggering bug reports and workarounds. Anyway, with your situation, it might be useful to inhibit palm detection, and this might be achievable by getting the touchpad treated as an external device, rather than an internal device (associated with the adjacent keyboard). Udev has a HW database for this purpose

https://fossies.org/linux/systemd/hwdb/70-touchpad.hwdb

The basic idea would be to create a custom file /etc/udev/hwdb.d/71-touchpad-local.hwdb with an entry like this perhaps

 # Permitted keys:
#   Specify if a touchpad is a built-in one or external:
#   ID_INPUT_TOUCHPAD_INTEGRATION=internal|external
touchpad:i8042:*
touchpad:rmi:*
ID_INPUT_TOUCHPAD_INTEGRATION=externall

I’ll leave you to research this further. Good luck.

On Sat 24 Dec 2016 10:36:02 PM CST, deano ferrari wrote:

This blog discusses libinput and palm detection
http://tinyurl.com/glwk3ml

I’m still on a learning curve with all of this myself. It’s the corner
cases that are triggering bug reports and workarounds. Anyway, with your
situation, it might be useful to inhibit palm detection, and this might
be achievable by getting the touchpad treated as an external device,
rather than an internal device (associated with the adjacent keyboard).
Udev has a HW database for this purpose

https://fossies.org/linux/systemd/hwdb/70-touchpad.hwdb

The basic idea would be to create a custom file
/etc/udev/hwdb.d/71-touchpad-local.hwdb with an entry like this perhaps

Code:

Permitted keys:

Specify if a touchpad is a built-in one or external:

ID_INPUT_TOUCHPAD_INTEGRATION=internal|external

touchpad:i8042:*
touchpad:rmi:*
ID_INPUT_TOUCHPAD_INTEGRATION=externall

I’ll leave you to research this further. Good luck.

Hi
Hmmm, I used the ‘existing’ 60-libinput.conf (as opposed to a new
file…)


"Before"
xinput list-props appletouch

libinput Disable While Typing Enabled (335):	1
libinput Disable While Typing Enabled Default (336):	1

/etc/X11/xorg.conf.d/60-libinput.conf

Section "InputClass"
Identifier "libinput touchpad catchall"
MatchIsTouchpad "on"
MatchDevicePath "/dev/input/event*"
Driver "libinput"
Option "Tapping" "On"
Option "DisableWhileTyping" "0"
EndSection

"After"
xinput list-props appletouch

libinput Disable While Typing Enabled (335):	0
libinput Disable While Typing Enabled Default (336):	1

Result, can type and move mouse…


Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
openSUSE Leap 42.1|GNOME 3.16.2|4.1.36-41-default
If you find this post helpful and are logged into the web interface,
please show your appreciation and click on the star below… Thanks!

The only danger with that is that it might get overwritten by an update. I made a mistake with the path when I first suggested the custom file. I edited the post afterwords (/etc/X11/xorg.conf.d/80-touchpad.conf).